544,051 active members*
1,858 visitors online*
Register for free
Login
Results 1 to 11 of 11
  1. #1
    Registered
    Join Date
    Jan 2006
    Posts
    14

    904 system error on 6M

    I have an other Sizuoka B3V with a different problem.
    Fanuc 6M again.
    This machine has been in storage for over a year so when I fired it up, I got a parity error.
    I was told the batteries may be dead and to replace them.
    They were and I did replace them with new, same brand and model number.
    I now get a "system error 904"
    Any ideas?
    -Kelly

  2. #2
    Registered
    Join Date
    Jan 2005
    Posts
    2
    I suppose that you have lost all parameters because of dead batteriries.
    Please check parameters are similar to manual. If not, re–set the parameters and all other data.

  3. #3
    Community Moderator Al_The_Man's Avatar
    Join Date
    Dec 2003
    Posts
    23711
    If you hadn't before you probabally lost all the parameters now, BTW wether sure or not, always replace the batteries while the power is on, otherwise you DO lose everything.
    Al.
    CNC, Mechatronics Integration and Custom Machine Design

    “Logic will get you from A to B. Imagination will take you everywhere.”
    Albert E.

  4. #4
    Registered
    Join Date
    Sep 2005
    Posts
    767

    Ah ... what?

    I hate to be a killjoy here, but the Fanuc 6 didn't have batteries. It used a magnetic bubble memory board, which doesn't require battery backup.

    There are a few aftermarket memory boards out there for the Fanuc 6 that might use battery backup with static RAM chips, but Fanuc never made them that way. I think Tulip Technologies sells a RAM board the replaces the Fanuc bubble board.

    The Fanuc 3T and 3M used batteries, so did the Fanuc 10 and the later 0T/0M controls. The 6T/6M and the 11T/11M and the 15T/15M had bubble memory with no batteries at all.

  5. #5
    Registered
    Join Date
    Jan 2006
    Posts
    14
    I wondered about that,,,,, because my other B-3V has the board you speak of,,,,,

    Okay here's what is written on the boards in each machine:

    Shizuoka B-3V #62030
    SRAM(BMU) 64-2 A16B-2201-0135 A

    Shizuoka B-3V #62045
    BMU 64-2 A87L-0001-0016 11H

    #62030 gets a system error 904 when I push the green "on" button on the control

    #62045 runs in MDI, HAND, STEP, JOG, and RAPID.
    I can enter data in EDIT.
    I get not response from any button input in MEMO
    I have not tried anything in TAPE since I do not have a puncher.

    Again,,, I thank you all for your interest and advice.
    -Kelly

  6. #6
    Registered
    Join Date
    Sep 2005
    Posts
    767

    First I've heard of it

    This is the first I've ever heard of this! Apparently, Fanuc has been making a static RAM (SRAM) replacement for the original bubble memory board (BMU). It's obviously a Fanuc board, since it has an "A16B" part number.

    I would guess that Fanuc 6 users were complaining about the high cost of replacing the original bubble memory boards, so Fanuc began to offer an SRAM version at lower cost. I very sure that the original system 6's were never sold with an SRAM board, because I was an Applications engineer with General Numeric at the time the Fanuc 6 was being sold in the US. The Fanuc 6 was my specialty.

    Your 62045 machine seems to have a safety interlock of some kind preventing you from cycle starting the machine in MEMORY mode. If you can operate in MDI, JOG, HANDLE, etc., but you can't run in MEMORY mode, it usually means that the cycle start is being inhibited by the machine interface. This is usually done for one of the following reasons:

    1) You haven't zero-returned all the axes since power up
    2) Your way lube pump is low on oil
    3) Your air pressure is low, or the air pressure switch is bad
    4) You have some other safety issue that would prevent cycle start, such as a "door open" switch, "tool changer not aligned" condition, etc.

    On your 62030 machine, you're getting a parity alarm from the bubble memory (in your case SRAM memory, not bubble). You can clear the memory in several stages, but if you clear out all the data, you'll loose your parameters, tool offsets, part programs, PC ladder parameters, and any macro programs you may have. Fortunately for you, you've got another similar machine that you can use as a template for re-entering these data.

    The first, and least intrusive "memory clear" procedure it to just erase all your part programs. This procedure won't affect your system parameters, so try this first: Hold the RESET and the DELETE button while you turn the power on.

    If that doesn't get rid of the "904" alarm, try the next step. This procedure clears all your parameters also: Turn on the "Parameter write" switch on the main PCB, then hold the CAN and the DELETE button while turning on the CNCs power. You'll then have to re-enter all the parameters.

    If all else fails, you'll need to do a "Bubble Memory All Clear". This is the "nuclear" option: Turn on the Parameter write switch on the main PCB, hold the letter "O" key and the DELETE key while turning the power on. You'll have to re-enter everything after that.

    The system 6 will let you key in any parameter (even option parameters) in MDI mode. The options are in parameters 001-005 and in parameters 300-305. If you plan to load the parameter data with a serial DNC link, you'll need to manually enter these parameters first (to make the serial port work):

    Parameter 002, bit 5 (the serial port option)
    Parameters 311-313
    Parameters 340 and 341.

    Also, The INPUT DEVICE 2 bit on the SETTING page must be "1" to read through the serial port.

    You can enter the regular parameters in MDI or with a serial DNC link, but the PC parameters must be entered using MDI. On your other machine, press the PARAM button twice to see if you have any PC parameters. Some machines never used the internal Fanuc PC, so these parameters are not visible. If they are, you'll have some "Timer" data, some "Counter" data, "Keep relays", and "Data tables" that must be entered. These data are for interface functions, and should be defined in a "ladder diagram" document from Shizuoka.

  7. #7
    Registered
    Join Date
    Jan 2006
    Posts
    14
    Thanks for the quick reply.
    After reading your advice, here's what I did on #62030:
    Fired up the phase converter.
    Turned on main power switch near the tool rack.
    1. First pushed and held down RESET & DELETE keys while pushing green button on control. Result when screen lit up,,,,, SYSTEM ERROR 904
    Pushed red button on control to turn off.
    2. First moved the parameter write swith to "enable", then pushed and held down the CAN & DELETE keys while pushing the green button on the control. Result when screen lit up,,,, SYSTEM ERROR 904
    Pushed red button on control to turn off.
    3. With parameter switch still in "enable" position, I pushed and held letter "O" and DELETE keys while pushing green button on control. Result when screnn lit up,,,,, SYSTEM ERROR 904
    Pushed red button on control to turn off.
    Turned off main on/off switch near tool rack.
    Turned off phase converter.
    Turned off shop lights.
    Closed shop door.
    Locked shop door.
    Walked to house.
    Went to kitchen.
    Opened refrigerator.
    Got a can of beer and frozen glass.
    Opened can of beer.
    Poured beer into frozen glass.
    Walked to computer with beer in hand.
    Began writting this letter.

    But seriously, What do I do next?
    -Kelly

  8. #8
    this may sound dumb but is the A axis enabled without there being an indexer on the table , i'm assuming its a mill

  9. #9
    Registered
    Join Date
    Sep 2005
    Posts
    767

    BMU initialize procedure

    This may or may not work with your SRAM version of the Bubble Memory Unit (BMU), but I thought I'd mention it anyway:

    Bubble memory chips sometimes have bad "loops" (similar to bad sectors on a hard drive). These bad loops must be "written out" so that the CNC doesn't try to access them. There is a BMU initialize procedure that writes these data to the bubble board, and it also clears all the other data from the bubble. This procedure is a bit like doing a low-level format on a hard drive.

    If you have a REAL bubble board (not SRAM), then there will be some "Defective loop numbers" printed right on the shield that covers the bubble device(s). Depending on the size of your bubble board, you may have one, two, or four bubble devices, and you have to enter these numbers for each device. I'm assuming that your SRAM version of the BMU board does not have any defective loop numbers to enter, but you can go through the same procedure anyway.

    Here's the procedure:

    1) If you have a "real" BMU board, turn the CNC off, remove the board, and record the defective loop numbers for each device on the board. These are just a series of 3-digit numbers. I'm assuming that the SRAM board will not have any defective loop numbers to enter.

    2) Reinstall the board, and hold the minus (-) and the decimal point (.) keys while you turn the control on.

    3) From the menu, press "4" to begin the BMU initialize mode

    4) From the next menu, Press "2" (Write by manual)

    5) Turn on the BMU Free Mode switch on the CNCs main PCB. If the switch is not on, it will tell you to turn it on.

    6) Another screen will appear for entering the defective loop data for "device 1". Enter each number and press INPUT. When done, press the START key to write to the bubble. On the SRAM board, I assume that you'll just press START without entering any defective loop numbers. If more than one device is present, you will get another menu for "Device 2". Enter the Device 2 defective loop numbers, pressing INPUT each time. Press START when done.

    7) When all data has been entered, turn off the control, turn the BMU Free Mode switch off, then turn the control back on again.

    This procedure WILL erase all the data on the bubble board, but you've already got a board that has no data to recover anyway. I don't know if your SRAM board will respond to this procedure or not, but it's worth a try.

    FYI: This procedure is fully described in the 6T/6M Maintenance manual

  10. #10

  11. #11

    Join Date
    May 2018
    Posts
    4

    Re: 904 system error on 6M

    Hi! I got same System Error 904 on a Fanuc 6M controller. I replaced battery (Rechargeable Battery) that was damaged on the FANRAM Board (It replaced an old Bubble Memory Board). After that I tried procedure to re-enter parameters (Turn on the "Parameter write" switch on the main PCB, then hold the CAN and the DELETE button (tried "O" and DELETE too) while turning on the CNCs power) but nothing occurred. Same message on screen (System Error 904). Please, any other advise about this error? Thank you all.

    P.D.: I have no Maintenance Manual (bought machine without it), so I will appreciate a lot if someone in the forum can provide it.

Similar Threads

  1. 6m system error
    By BrianM03 in forum Fanuc
    Replies: 4
    Last Post: 05-19-2021, 06:56 PM
  2. SYSTEM BUS ERROR
    By Antonio Arguijo in forum Okuma
    Replies: 0
    Last Post: 08-30-2011, 08:56 PM
  3. MV-40 SYSTEM NO. 1 ERROR
    By cowboysam777 in forum Mori Seiki Mills
    Replies: 2
    Last Post: 09-01-2010, 02:11 AM
  4. system error 902
    By woonsteel in forum Fanuc
    Replies: 2
    Last Post: 08-06-2009, 09:37 PM
  5. 6M System Error
    By Sailor in forum Fanuc
    Replies: 7
    Last Post: 06-01-2007, 11:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •