496,342 active members
7,586 visitors online
Register for free
Login
496,342 active members
Page 1 of 5 123
Results 1 to 12 of 49
  1. #1
    suganesh95
    Guest

    Chinese Spindle making rattling noise !

    Hello everyone.

    I purchased a Chinese spindle via AliExpress. It is a 1.5 kW, 24000 rpm, ER16 liquid-cooled spindle.
    When I run the spindle above 11,000 rpm it makes some kind of rattling noise like something is interfering inside, but the shaft spins smoothly and below 11,000 rpm the noise disappears. There is no resistance felt when I spin the shaft with my hand. It is perfectly smooth. I contacted the seller and he said it is normal and that I continue to use it. But the noise is quite worrying me.

    [url]https://www.youtube.com/watch?v=LrzEDfsBpPY[/url]

    Since I was just testing the spindle for a few seconds I did not connect the water cooling tubes yet (in the video). Later I did a long run (running continuously for about an hour) with the tubes connected and water flowing through it, the spindle seemed to be working fine, no overheating or reduction in speed except for the noise it keeps making.

    Can anyone tell me what is the problem? Is it all right to continue using it? Or what can be done to stop the noise?

    Thank you !

  2. #2
    Registered
    Join Date
    Nov 2012
    Posts
    684

    Re: Chinese Spindle making rattling noise !

    Notice how the frequency of the noise stays the same as the spindle spins up and down? Just a wild guess, but I suspect it's VFD output that has little "glitches" in it.

    Try this: change the VFD stopping mode from "Decelerate to stop" to "Coast to stop". See if the noise goes away as soon as you hit the Stop button.

  3. #3
    suganesh95
    Guest

    Re: Chinese Spindle making rattling noise !

    Thank you for your reply!

    Will check and let you know.

  4. #4
    suganesh95
    Guest

    Re: Chinese Spindle making rattling noise !

    CitizenOfDreams you are right! There is some kind of glitch from the VFD output. I changed the settings as said by you and the noise disappeared as soon as I pressed the stop button. Can you further help me in correcting the issue? Any changes in VFD settings ? I am using a cheap chinese VFD. Model : YL620-A 2.2kW output and the spindle is a 1.5kW 400Hz model.

    Thank you!

  5. #5
    Registered
    Join Date
    Nov 2012
    Posts
    684

    Re: Chinese Spindle making rattling noise !

    [QUOTE=suganesh95;2257976]CitizenOfDreams you are right! There is some kind of glitch from the VFD output.[/QUOTE]

    I would try changing the carrier frequency and see what happens.

  6. #6
    suganesh95
    Guest

    Re: Chinese Spindle making rattling noise !

    Honestly, I'm a newbie and there are many settings in VFD that I am not able to figure out what they mean. I am uploading pics of my present settings and maybe you can help me out with it.

    (P.S - Ignore the stopping mode as I have set it to "coast to stop")

    Thank you.
    Attached Thumbnails Attached Thumbnails 1.jpg   2.jpg   3.jpg  

  7. #7
    Registered
    Join Date
    Nov 2012
    Posts
    684

    Re: Chinese Spindle making rattling noise !

    Is this a complete list of functions? Looks like there should be much more. The "Carrier frequency" parameter is usually way down the list.

  8. #8
    suganesh95
    Guest

    Re: Chinese Spindle making rattling noise !

    There are still many ! I just uploaded the ones which i set. Anyways i will upload the remaining ones so that you can have a look.
    Please go through them.

    Thank you !
    Attached Files Attached Files

  9. #9
    Registered
    Join Date
    Nov 2012
    Posts
    684

    Re: Chinese Spindle making rattling noise !

    Carrier frequency, or PWM frequency, is parameter P12.19. Try cutting it in half or doubling it and see what happens.

  10. #10

    Join Date
    Jan 2005
    Posts
    9040

    Re: Chinese Spindle making rattling noise !

    [QUOTE=suganesh95;2257760]Hello everyone.

    I purchased a Chinese spindle via AliExpress. It is a 1.5 kW, 24000 rpm, ER16 liquid-cooled spindle.
    When I run the spindle above 11,000 rpm it makes some kind of rattling noise like something is interfering inside, but the shaft spins smoothly and below 11,000 rpm the noise disappears. There is no resistance felt when I spin the shaft with my hand. It is perfectly smooth. I contacted the seller and he said it is normal and that I continue to use it. But the noise is quite worrying me.

    [url]https://www.youtube.com/watch?v=LrzEDfsBpPY[/url]

    Since I was just testing the spindle for a few seconds I did not connect the water cooling tubes yet (in the video). Later I did a long run (running continuously for about an hour) with the tubes connected and water flowing through it, the spindle seemed to be working fine, no overheating or reduction in speed except for the noise it keeps making.

    Can anyone tell me what is the problem? Is it all right to continue using it? Or what can be done to stop the noise?

    Thank you ![/QUOTE]

    Have you checked the Ground is connected, pin 4 in the spindle, this has to have continuity to the spindle body, if not this has to be corrected, it also sounds like you have some parameters set incorrect, do you have a list of the parameters you set

    Just looked at what you posted no they are not set correct I will post you a list of what you have to set, but first we have to know which VFD Drive you have
    Mactec54

  11. #11

    Join Date
    Jan 2005
    Posts
    9040

    Re: Chinese Spindle making rattling noise !

    [QUOTE=CitizenOfDreams;2258034]Carrier frequency, or PWM frequency, is parameter P12.19. Try cutting it in half or doubling it and see what happens.[/QUOTE]

    You are miss leading this new user if he has not changed the carrier frequency then the default setting is fine for these spindles, his main Parameters are not set correct this is something you can't make guesses with
    Mactec54

  12. #12

    Join Date
    Jan 2005
    Posts
    9040

    Re: Chinese Spindle making rattling noise !

    [QUOTE=suganesh95;2258016]There are still many ! I just uploaded the ones which i set. Anyways i will upload the remaining ones so that you can have a look.
    Please go through them.

    Thank you ![/QUOTE]

    Things I need to know to be able to give you the correct parameters to set, don't run your spindle again until you have the correct Parameters set

    VFD Drive spec's make and model #

    Spindle voltage ??
    Spindle Amps ??

    A Photo of the VFD Drive also would help to see if it is real or a clone
    Mactec54

Page 1 of 5 123

Similar Threads

  1. Help with PRT-E1500 VFD 220v Please, spindle making a noise but not turning
    By graeme1234 in forum General CNC Machine Related Electronics
    Replies: 3
    Last Post: 01-13-2019, 07:42 PM
  2. Spindle making grinding/humming noise
    By machinisto in forum Haas Mills
    Replies: 1
    Last Post: 10-21-2014, 09:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •