504,132 active members
4,528 visitors online
Register for free
Login
Results 1 to 6 of 6
  1. #1

    Join Date
    Jul 2019
    Posts
    2

    CW-5000 popping fuses, won't run more than a few seconds

    Hello! I bought a used CW-5000 chiller. It starts up and gives the 3 beeps for the water sensor, but that subsides. However, after about 30 seconds, the machine just shuts down as it pops the fuse inside the power inlet port. The compressor never comes on, and the green NORMAL LED is very faint and pulsing before the fuse blows. The red Alarm LED is bright and properly lit when it is triggered, and the LCD screen functions properly.

    I'd appreciate any help on where to look or what to try to keep this machine running.

    Thank you!

  2. #2
    Registered
    Join Date
    Jan 2008
    Posts
    876

    Re: CW-5000 popping fuses, won't run more than a few seconds

    Are you using the correct fuse mine uses these Fast Blow Glass Tube Fuse 10A 250V 5mm x 20mm

  3. #3

    Join Date
    Jul 2019
    Posts
    2

    Re: CW-5000 popping fuses, won't run more than a few seconds

    When I bought it, it had a 20A that was already blown. I just realized that I thought I was using 15A fuses now, but they are actually 3.15A fuses, so I see why they are blowing. I'll order some 10A and see what it will do, and I've ordered some more of the 20A like the original to try them as well.

  4. #4
    Member
    Join Date
    Sep 2005
    Posts
    1604

    Re: CW-5000 popping fuses, won't run more than a few seconds

    If its blowing fuses and the lights are dimming, first what voltage is it set for and what voltage do you have feeding? You did not list a location so I am assuming your in USA? My guess either your compressor is bad or the capacitor for starting either a PSC or starting relay and capacitor is bad.

    On mine the power switch went bad and I just wired it direct because its turned on and off via my power strip which turns the machine and exhaust fan on at the same time.
    Retired Master Electrician, HVAC/R Commercial. FLA Saturn 2 4x4 CNC Router

  5. #5
    Registered
    Join Date
    Jan 2008
    Posts
    876

    Re: CW-5000 popping fuses, won't run more than a few seconds

    Quote Originally Posted by wmgeorge View Post
    If its blowing fuses and the lights are dimming, first what voltage is it set for and what voltage do you have feeding? You did not list a location so I am assuming your in USA? My guess either your compressor is bad or the capacitor for starting either a PSC or starting relay and capacitor is bad.

    On mine the power switch went bad and I just wired it direct because its turned on and off via my power strip which turns the machine and exhaust fan on at the same time.
    He said he was using 3.15 amp that will blow before the compressor starts. I blow my 10 amp when one of my fans was bad and tried a 7 amp that I had. When I got the right ones and the fan replaced it runs just fine. these are the ones I bought

    https://www.ebay.com/itm/172618204576

  6. #6
    Member
    Join Date
    Sep 2005
    Posts
    1604

    Re: CW-5000 popping fuses, won't run more than a few seconds

    Quote Originally Posted by fixtureman1 View Post
    He said he was using 3.15 amp that will blow before the compressor starts. I blow my 10 amp when one of my fans was bad and tried a 7 amp that I had. When I got the right ones and the fan replaced it runs just fine. these are the ones I bought

    https://www.ebay.com/itm/172618204576

    When I bought it, it had a 20A that was already blown.

    I was going by this part of his ^^^^^ post, yes I understand he has too small a fuse now but when a 20A was blown its not a good sign.
    Retired Master Electrician, HVAC/R Commercial. FLA Saturn 2 4x4 CNC Router

Similar Threads

  1. Retrofit Prolight 5000 (Benchman 5000) to run Mach
    By Impyman18 in forum Benchtop Machines
    Replies: 25
    Last Post: 07-10-2019, 04:12 AM
  2. CNC 3040 popping and making noise
    By JoshG502 in forum Chinese Machines
    Replies: 6
    Last Post: 09-27-2017, 09:27 PM
  3. G0752 CNC conversion keeps popping breakers
    By Neverliftchassi in forum Benchtop Machines
    Replies: 6
    Last Post: 08-18-2017, 07:06 PM
  4. as she flaunts EYE-POPPING
    By chilaiguleta in forum Hypertherm Plasma
    Replies: 0
    Last Post: 08-10-2017, 06:34 PM
  5. X2 spindle popping reset
    By cyclestart in forum Benchtop Machines
    Replies: 3
    Last Post: 03-17-2008, 08:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •