525,809 active members*
3,070 visitors online*
Register for free
Login
Results 1 to 4 of 4
  1. #1
    Registered
    Join Date
    Jan 2008
    Posts
    3

    Fanuc FTP problem

    Hello,

    I have a Makino v33 with a Professional 3 Fanuc control. A couple of years ago we began to have trouble with the FTP server. In the middle of transferring a file form the PC to the control it would drop the connection. We've swapped out the cable, the computer, tried both physical Ethernet ports, the new router, direct cable without a router, and even a new PCMCIA card.

    I can PING the machine from any computer but the FTP server does not respond to connection request. Only way around it is to power cycle the machine. Any suggestions on how to fix it?

    Thank you,
    Ivan

  2. #2
    Registered
    Join Date
    Dec 2005
    Posts
    447

    Re: Fanuc FTP problem

    I am not familiar with your environment specifically, but I do know a little about FTP.

    What FTP client are you using? Try setting it to passive.

    What OS is your client PC? Verify your MTU is set to match your machine.

    Is the PCMCIA ethernet card on the machine 10, 100, or 1000 base-t. Is it full duplex or half? Some older ethernet cards are 10 base-t and can flip/flop duplex randomly when connected to a modern switch. If your switch is managed you should look the port statistics to see what's happening.

  3. #3
    Registered
    Join Date
    Apr 2012
    Posts
    40

    Re: Fanuc FTP problem

    You said you put a new PC card in the control. Did you do a DSFORMAT?
    What mode are you running your DS in? Buffer/Storage/FTP?
    Have you tried WinSCP for an FTP server on your PC?
    Check the Data Server function parameters 921 - 923 for host OS setting. Heck, may as well check ALL the DS parameters against the original setting from the factory.
    0, 100, 904 - 970. Manual is B-64014EN

  4. #4

    Join Date
    Jul 2020
    Posts
    1

    Re: Fanuc FTP problem

    Hi guys!
    I have similar problem. My machine is 2004 model johnford dmc1200 and its control unit fanuc 18M. Could you explain me about how can I connect dataserver and connect with FTP program? I connected PC to dataserver as like (dataserver)-RS422-Ethernet converter- PC and I have set up alftp program but I couldn't success it
    Thank you

Similar Threads

  1. Fanuc 10m DNC problem
    By SeastEng in forum General Off Topic Discussions
    Replies: 1
    Last Post: 12-21-2018, 07:49 AM
  2. Fanuc PML-L&M Problem
    By taspunsaen in forum Want To Buy...Need help!
    Replies: 3
    Last Post: 01-16-2012, 03:32 PM
  3. Fanuc O-M problem
    By cncrookie_85 in forum Fanuc
    Replies: 1
    Last Post: 04-06-2011, 06:47 PM
  4. Fanuc new 0I problem
    By sylvain in forum European Club House
    Replies: 2
    Last Post: 12-30-2007, 06:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •