524,118 active members*
2,080 visitors online*
Register for free
Login
Results 1 to 20 of 20
  1. #1
    Registered
    Join Date
    Jan 2016
    Posts
    14

    fanuc oi tc EMG

    Hi
    I have a yh-28 lathe with oi tc
    it gives a emg alarm and it doenst go away and the emergency switch works normaly
    I hope someone can help me

  2. #2
    Registered
    Join Date
    Apr 2011
    Posts
    594

    Re: fanuc oi tc EMG

    Check X8.4 and G8.4. Both signals must be on to clear ESTOP

  3. #3
    Registered
    Join Date
    Jan 2016
    Posts
    14
    Quote Originally Posted by drdos View Post
    Check X8.4 and G8.4. Both signals must be on to clear ESTOP
    Thanks for your response
    x8.4 is on but g8.4 is off

  4. #4
    Registered
    Join Date
    Apr 2011
    Posts
    594

    Re: fanuc oi tc EMG

    Can you see what in the ladder is preventing G8.4 from coming on? You need to search for the coil in the ladder.

  5. #5
    Registered
    Join Date
    Jan 2016
    Posts
    14

    Wink Re: fanuc oi tc EMG

    Quote Originally Posted by drdos View Post
    Can you see what in the ladder is preventing G8.4 from coming on? You need to search for the coil in the ladder.
    Here is a picture

  6. #6
    Registered
    Join Date
    Dec 2009
    Posts
    617

    Re: fanuc oi tc EMG

    do you have a pdf document with your electrical diagram?
    or open the electrical diagram and in 1 page should be the entire emergency circuit,make a photo and post it.

  7. #7
    Registered
    Join Date
    Jan 2016
    Posts
    14
    Quote Originally Posted by zavateandu View Post
    do you have a pdf document with your electrical diagram?
    or open the electrical diagram and in 1 page should be the entire emergency circuit,make a photo and post it.
    I dont have the diagram I realy dont kwon what to do

  8. #8
    Registered
    Join Date
    Dec 2009
    Posts
    617

    Re: fanuc oi tc EMG

    you should check with a voltmeter if you have +24v DC in the emergency stop buttons and on the limit switch for hard travel for all axes.One of these has an interrupt.

  9. #9
    Registered
    Join Date
    Jan 2016
    Posts
    14
    Quote Originally Posted by zavateandu View Post
    you should check with a voltmeter if you have +24v DC in the emergency stop buttons and on the limit switch for hard travel for all axes.One of these has an interrupt.
    At the red emergency switch I have 24vdc betweer L and E when the switch is normal closed but at the limit switches it is not clear, there are 4 wires from 2 switches but none of them have 24vdc

  10. #10
    Registered
    Join Date
    Dec 2009
    Posts
    617

    Re: fanuc oi tc EMG

    show us a picture.If the limit switch is not pressed ,you should have 24v on it.

  11. #11
    Registered
    Join Date
    Jan 2016
    Posts
    14

    Re: fanuc oi tc EMG

    Quote Originally Posted by zavateandu View Post
    show us a picture.If the limit switch is not pressed ,you should have 24v on it.
    The first picture is from the emergency switch, I have 24vdc between the red wire and 103
    In the second picture 119 122 124 are coming from the hard limit switches and there is no 24vdc between any of them

  12. #12
    Registered
    Join Date
    Jan 2016
    Posts
    14
    Quote Originally Posted by zavateandu View Post
    show us a picture.If the limit switch is not pressed ,you should have 24v on it.
    I dont understand what you mean with 24v over the switch
    if it is a closes switch how can there be 24v on it ?

  13. #13
    Registered
    Join Date
    Dec 2009
    Posts
    617

    Re: fanuc oi tc EMG

    This is a standard Emergency circuit
    Attachment 307126

    you have the EMG push button than you have the overtravels 131,132 ,this is from a lathe so 2 axes limit switches,the +24v(L
    +) goes in the EMG than goes to the switches and than in a relay and finally to L-.
    So is like the christmas tree leds that are connected in serial mode.
    all the contacts are normally closed so when 1 of these is open the 24V will not reach the relay so the machine will show alarm and NOT READY state.
    the point is you must measure the 24V(L+) checking with the L-.
    This is basic electric so i hope you understand it.
    good luck.

  14. #14
    Registered
    Join Date
    Jan 2016
    Posts
    14
    Quote Originally Posted by zavateandu View Post
    This is a standard Emergency circuit
    Attachment 307126

    you have the EMG push button than you have the overtravels 131,132 ,this is from a lathe so 2 axes limit switches,the +24v(L
    +) goes in the EMG than goes to the switches and than in a relay and finally to L-.
    So is like the christmas tree leds that are connected in serial mode.
    all the contacts are normally closed so when 1 of these is open the 24V will not reach the relay so the machine will show alarm and NOT READY state.
    the point is you must measure the 24V(L+) checking with the L-.
    This is basic electric so i hope you understand it.
    good luck.
    Thanks for your help man I finaly fixed it there was a wire not connected well

  15. #15
    Registered
    Join Date
    Jan 2010
    Posts
    3

    Re: fanuc oi tc EMG

    I am having the same problem, but my F45 will not come on

  16. #16
    Junior Member
    Join Date
    Jan 2018
    Posts
    1

    Please resend the attachment, I am having similar problem

    Quote Originally Posted by zavateandu View Post
    This is a standard Emergency circuit
    Attachment 307126

    you have the EMG push button than you have the overtravels 131,132 ,this is from a lathe so 2 axes limit switches,the +24v(L
    +) goes in the EMG than goes to the switches and than in a relay and finally to L-.
    So is like the christmas tree leds that are connected in serial mode.
    all the contacts are normally closed so when 1 of these is open the 24V will not reach the relay so the machine will show alarm and NOT READY state.
    the point is you must measure the 24V(L+) checking with the L-.
    This is basic electric so i hope you understand it.
    good luck.
    Please resend the attachment, I am having similar problem

  17. #17
    Registered
    Join Date
    Dec 2015
    Posts
    92

    Re: fanuc oi tc EMG

    Hi
    i need help regarding 21i mb controller.On i/o card a20b-2002-0521/06A connectors CE56,CE57 i dont know on which pin number having *esp signal.
    a1=24v,b1=0v i know that but other pins number which function it have i dont know can anyone help with this problem.

  18. #18
    Registered
    Join Date
    Apr 2011
    Posts
    594

    Re: fanuc oi tc EMG

    Quote Originally Posted by phucrobusl View Post
    Hi
    i need help regarding 21i mb controller.On i/o card a20b-2002-0521/06A connectors CE56,CE57 i dont know on which pin number having *esp signal.
    a1=24v,b1=0v i know that but other pins number which function it have i dont know can anyone help with this problem.
    The problem is these connections are variables. That mean it all depends on how the I/O assignments has been laid out. Fanuc states in this example:


    Xm+0.0 M= starting address for this address. So if your starting address is X8 this pin would be X8+0.0 or X8.0
    Hope that helps.

  19. #19
    Registered
    Join Date
    Dec 2015
    Posts
    92

    Re: fanuc oi tc EMG

    Quote Originally Posted by drdos View Post
    The problem is these connections are variables. That mean it all depends on how the I/O assignments has been laid out. Fanuc states in this example:


    Xm+0.0 M= starting address for this address. So if your starting address is X8 this pin would be X8+0.0 or X8.0
    Hope that helps.
    yes i think you are right but i dont know w to I/O assignment to do from X8.+0.could you please help me. rd181993@gmail.com.
    thanks.

  20. #20
    Member
    Join Date
    May 2020
    Posts
    9

    Re: fanuc oi tc EMG

    Hi!!!
    I have a similar problem with a Nakamura Tome TMC-12 Control Series 21-T, this machine was working well, until a technician came to check a vibration in the Z axis servo, apparently it loaded parameters and the machine did not return to work, I have a backup of the machine parameters, I reloaded them, no alarm comes out, but it is in EMG state, I can navigate the menus, but nothing else works (spindle, hydraulic system, turret , move the axes).
    Hopefully someone can help me, best regards.

Similar Threads

  1. Replies: 8
    Last Post: 09-25-2014, 02:58 PM
  2. Replies: 1
    Last Post: 04-14-2014, 07:41 PM
  3. Replies: 0
    Last Post: 01-28-2014, 04:41 AM
  4. Replies: 10
    Last Post: 03-02-2013, 05:00 AM
  5. Replies: 5
    Last Post: 03-09-2011, 04:11 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •