543,877 active members*
2,412 visitors online*
Register for free
Login

Thread: Help

Results 1 to 8 of 8
  1. #1

    Help

    Maybe I'm finally in the right forum

    I posted a while back that I was randomly losing steps in the x direction during complicated tool paths when I speed up from 60 imp to 90 ipm. I hear how slow that is all the time, however I’ve only done 1911 grips and turkey pot calls so far, they are small and complete fairly quickly using 3D adaptive during roughing with a 1/4” end mill w/0.15 optimal load and .39 ADOC. The driver on that axis was a Longs Motor DM860a. I decided to swap it out with a Geckodrive 203v I bought used off eBay. After the swap, I have no movement on my X axis. I unplugged the cable from the motor and controller to check continuity through the cable, checked out fine on all pins. Then I checked cable to motor continuity between the - and + coils of each motor winding. I found an intermittent problem while wiggling the aviation plug I used to connect the motor pig tail to the motor cable. Solider joints looked good and there didn’t seemed to be a broken wire. Turns out the connector itself had a short in it(perhaps I overheated it while soldering?). I replaced that connection with a good one, plugged everything back in, still no motion. I checked the continuity between each motor winding from the terminal screws on the Geckodrive with everything plugged in. I have continuity. In fact I have holding torque, and when I jog my x axis back and forth in UCCNC the DRO shows movement. Im at a loss here, any ideas? I assume my problem with losing steps before might of actually been caused by the wiring issue and not the Longs Motor DM860A. TIA

  2. #2

    Re: Help

    Did you try to swap wirings/drivers/motors?

  3. #3
    Yes. Swapped motor cables first, then drives. There is holding torque on the motor, just no motion. Thanx

  4. #4
    Registered
    Join Date
    Dec 2012
    Posts
    177

    Re: Help

    Is this only on the X axis ?
    check if the motor current set to the right value and then try at a very low speed.
    If the X and Y motors are the same, careful swap the connection from the drivers to the motors and try again. But be aware that the end stops won't work correctly.

  5. #5

    Re: Help

    Lose/improper connections in my case has caused the weirdest results including drivers and motors failing.

    In one case I found that I had partialy fucnctioning break-out board because of a lose wire, I had to replace the break-out board.



    Keep trying, you will figure it out.

  6. #6
    Yes, only on the x axis. I plugged my DM860A back in and everything is working. I tried every possible combination of motor and drives but the G203v just doesn’t seem to be communicating with my UC300ETH. As mentioned above, my x axis worked fine jogging it around on the old drive. At first it seemed to just not handle a complicated tool path like Morph(Fusion360) at 90 ipm. Seemed to do fine with 60 ipm. So according to a review left on the particular stepper motors I have, they don’t like to operate above 200 kHz. So in UCCNC I changed my kernel speed to 100 kHz. I tried it(ran another 1911 grip that included the offending morph toolpath) @ 90 ipm and it worked great. Then I decided to run it again just in case. During the 3D adaptive toolpath @ 90 ipm it started missing steps. So I ruled out the Morph toolpath theory. I read online how to figure kernel speed for desired IPM @ desired microstep. I had the DM 860a set on 16 micro steps. So I divided the number of steps(1.8*=200steps) by my ballscrew movement per rev(1605 ball screw) and then multiplied that number by my micro steps(16). Then I put in my desired max feedrate(200 IPM x 25.4(in to mm)=5080mm/60(secs)=84.6mm/sec). And then multiplied that by 640 to get my kernel speed.

    200(steps)/5(pitch) *16(microsteps)=640steps/mm
    200(IPM)*25.4(in to mm)/60(secs)=84.6mm/sec
    640*84.6=54,144
    ~54 kHz

    Since the UC300ETH has presets of 25,50,100,200, and 400 kHz, I decided I could get even longer PWM of i dropped my micro stepping to 10x and I could run at 50kHz. Long story but that’s when I decided to just switch to the used Geckodrive I bought off eBay because I was going to be inside my control box anyway, and love the Gecko I have on my Z axis. So to make the story even more tiring, I discovered a faulty connector while diagnosing why I didn’t have continuity between coils of the stepper motor while probing the Gecko. After I sorted that, I still couldn’t get the Gecko to move X axis. I have just now switched back to the DM860A so I can get some work done in what’s left of the weekend. I suspect the faulty connector was the culprit the whole time. I will send the Gecko back to them to have it inspected/repaired. Now my question is do you think I should stick with the 16 microsteps or change to 10. If I stick with 16 I’ll increase my kernel freq to 100kHz. My drives are capable of 200, and my motors supposedly can handle up to 173kHz. Do you think I’m getting a strong enough pulse with my kernel set to 100 kHz and my microstepping set to 16 @ 200 IPM? I really like the smoothness set that high(don’t HAVE to have the resolution), but I want to make sure I have enough torque to hold inertia of the rapid direction changes that happen while maching small parts. Calibration is not a problem as I use a dial indicator at the end of a full axis travel to dial in the number of steps. Accuracy is paramount in these small parts. Sorry for the insane amount of rambling and info, but I really appreciate any advice.

  7. #7

    Re: Help

    Tried to reply to old thread in Tapatalk... it was gone. Tried to message you... blocked. Here was my reply...

    I normally work on industrial servo driven CNC machinery, but I do dabble in some home brew stuff. I recently worked on a commercial machine that someone had swapped out the controls on. They had pulled the old controls (that were blown out, for some reason) and installed a cheap CNC system in. They fudged with it for months before calling me. It was DOA when I was called in. Every motor on the unit was doing exactly what you described. I scoped the NPN outputs from the controller to the motor (motors had built in closed loop servo drives, but were controlled like a stepper with pulse and direction) and found the driver chips on the controller were only changing state by .6VDC. Not enough to trigger the drives, but they were also shorted in the partially on state, which kept the servo in lock rotor. I repaired the card, and reinstalled. Motor movement was restored. I then set up the entire machine per customer needs. The only thing I found that could have caused the problem was shorted cabling. The customer, in an effort to save money, made his own 6C cables for driving the motor. He didn't use the correct pins. He also didn't use the correct crimpers for the pins he did use. He ended up blowing the drivers on all 4 axes because he started swapping cables before he knew what the problem was. He ended up putting the BAD motor connection on all 4 axes before calling me. I do not know your drive, but I would look at the outputs from the control, outputs from the drive, etc., with an oscilloscope. Be careful if you do not know how to use a scope, as using it improperly (e.g., having the scope grounded, not isolated, and probing into voltage that's not referenced to earth) could cause more damage than you can imagine. Also, using an ungrounded scope can and will be a hazard to your health of you are probing high voltage and touch ANYTHING metal on the scope. This includes the set screws in the adjustment knobs. Ask me how I know...lol

    Sent from my SM-N975U using Tapatalk

  8. #8
    Thanx for the reply. I have no idea why you are blocked or how to undo it, but I’ll look in to it. I haven’t run a job yet (Mother’s Day), but I put the old driver back in(sending the 203v back to have Gecko look at it). I believe the faulty connector on the MOTOR pig tail to be the culprit. I was reasonably confident my home built cables were right because I triple checked everything for continuity as I built it. I’ve done lots of soldering and I opted to solder every connect in my entire system. I also built all my cabling using 5 strand(4+bare copper) Mylar shielded cable and only grounded the bare wire at one end. Since I may never need 200 IPM I opted to just leave my kernel speed at 50kHz and stepping at 16. It’s so smooth and accurate up to 150 ipm. And if we are being realistic, who needs to cut small parts any faster? Whole sheets of ply on an 8x4 sure. 4-5 in parts on a 16x24, nah. This thing is ridiculously accurate,I’ll attach a couple of pics from my first cuts. Thanx
    Attached Thumbnails Attached Thumbnails 783EC05B-805C-4A61-A1AC-27E258FB6942.jpg   48E99C11-F398-484D-ACE1-61456AB298C8.jpg  

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •