554,075 active members*
4,137 visitors online*
Register for free
Login
IndustryArena Forum > WoodWorking Machines > DIY CNC Router Table Machines > Zen Toolworks > Help with identical parts cutting wrong size depending on X location on 48X96 sheet
Results 1 to 3 of 3
  1. #1

    Help with identical parts cutting wrong size depending on X location on 48X96 sheet

    Hi folks!
    I've been 'tinkering' around with a Zenbot 4896 I bought a year or so ago and recently developed a problem I can't quite figure out and thought I'd run it by some people who undoubtedly know more about it than I do. I've been trying to learn just by reading and working but can't quite understand what's going on with this one.

    I'm building cabinets, they're about 20X24X28 or something to that effect, and the two opposite sides are basically identical in profile size. So two sets of two sides. There are also some blocks, etc. cut out on a 48X96 sheet in various places on the sheet, basically one large file that cuts out at once and then you put everything together.

    I started noticing the belts were sagging on the X axis, especially with the heat this summer. I'm only cutting on this thing maybe 7 or 8 hours a month, so this problem didn't develop until the heat, which might be related.

    So I start having an issue where the sides are cutting at different sizes on the X axis (96 axis). The Y axis is pretty much always perfect. So if the part is in the middle third of the sheet, it will be the correct X length. If the part is in the 1st third, or the last third, it will be too long, by about half an inch. This is pretty severe when you're trying to make mirrored cabinet sides.

    There is a strange area in the middle of the sheet where if I put a block say 3X5, and one right next to it, one will cut 3X5 and the one right next to it will cut 3X5.25. I have no clue how that's possible.

    -------------------------------------------------------------------------------------------------------------------------------------

    This is all laid out in V Carve Pro, and then exported with mach 3 arcs inches as the post processor. I'm running at 100ipm and it has the old school Metabo router on it. Router speed is about 15000rpm. Cutting depth is about .14"

    The problem is getting worse, it was always doing it but before in the winter months, it was more like 1/16" off so it wasn't that big of a deal. Now it's half an inch off, and I THOUGHT it was the belts.

    So today I researched it, figured out how to tension those belts, and then more importantly, how to calibrate Mach III. Boy I was sure I had it, the X axis was off about an inch from one end to the other, so I used the auto calibrate setting in Mach 3 and got that sucker where it's perfect. I mean you can go 96" and it stops exactly at 96". I also did the Y axis, everything is lined up, the belts have no slack, etc.

    -------------------------------------------------------------------------------------------------------------------------------------

    Cut another sheet... and..... it's exactly the same. The parts in the middle seem correct, if they're on the first third of the sheet they're too long if they're on the last third of the sheet they're too long, still by about 1/2". Rechecking the file in V Carve pro and everything is identical and laid out perfect size, and if I export another G code and then compare the text in the .txt file they are identical to the file that doesn't cut right. If I run the file through the preview in V Carve Pro, everything comes out the right size, and I ran the file through an online simulator and everything came out square and correct.... so I'm left thinking it's a hardware problem. This is only on the X/A axis, the Y axis is always fine. If I run the router down the table to any spot on the X axis, and then measure, it is always in the correct spot (but I can't do this while it's cutting)

    ---------------------------------------------------------------------------------------------------------------------------------------

    Here's what I'm leaning towards:

    A. It could be the Gecko drive for the X axis, possibly. Or the A axis, which is on the other side of the gantry and is a slave to the X (somehow)

    B. It could be the X or A motor itself

    C. It could be the belts although they look fine...

    D. It could be something with the A, when I zero Mach III I have no "A" axis even shown, and I always zero the X, I have no clue what is even turning the A or how that's setup, it just plugs into the Gecko.


    Any thoughts? Thank you for reading my book!

  2. #2

    Re: Help with identical parts cutting wrong size depending on X location on 48X96 she

    I believe I found my problem. When I noticed the belts were sagging, I adjusted the motors by loosening them and pulling them tight, this tightened up the belts.... I did this in the middle of the table (with the gantry parked in the middle). The Y was never slack but it's only 4 feet.

    Today I ran the program in the air and it always cuts the exact same with no load. I then created a new file with everything slightly moved, and ran into the same problems.

    A close inspection of the belts though shows that when I pulled them tight, I must have stretched and damaged the belt in the center of the table as you can see, on the A drive. The X the belt looks fine...

    So for whatever reason, with the A stretched in that small spot, it's enough to add about 1/4" play, and then the rest of the table has about 1/4" in it as well just from the belts being slack and me not knowing how to set the steps automatically with Mach III.

    So I'm going to order new belts and slide them in, then reset the steps and I think it will clean it up. It may work better than ever, I bought it used. The belts measure 15mm with a 3mm pitch.

  3. #3

    Re: Help with identical parts cutting wrong size depending on X location on 48X96 she

    Just to finish this thread in case anybody else finds it down the road (nobody replied)..... new belts fixed this up and got it cutting very accurately. The spot where the belt was stretched in the middle perfectly reproduced each time, you'd get 3/8's of an inch or so stretched at that point over and over again, when we took the belts out there was a bunch of dust and a large piece of particle board stuck in that area that probably got behind the gear at some point and made that area when we tightened the motors. It seems to work a little easier to tighten them if you pull from the end of the machine, and wobble the gantry a little bit to make sure the belt is seated tightly, you don't have to loosen the motors to tighten them.

Similar Threads

  1. Gecko G540 + LinuxCNC parts are the wrong size
    By geroge in forum General CNC Machine Related Electronics
    Replies: 1
    Last Post: 11-07-2017, 02:26 AM
  2. My parts are coming out the wrong size!
    By bremerr in forum DIY CNC Router Table Machines
    Replies: 30
    Last Post: 12-18-2015, 04:43 PM
  3. cutting wrong size hole
    By macplus in forum LazyCam
    Replies: 1
    Last Post: 11-30-2014, 11:23 PM
  4. Cnc parts cutting wrong size
    By o1jason in forum Stepcraft
    Replies: 0
    Last Post: 11-24-2014, 07:44 AM
  5. G540 cutting size wrong
    By Ed Williams in forum Gecko Drives
    Replies: 1
    Last Post: 10-30-2011, 01:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •