530,212 active members*
3,273 visitors online*
Register for free
Results 1 to 2 of 2
  1. #1

    Help troubleshooting my university laser setup

    I work as a doctorate student in a public university in Brazil, and i use this setup to do various researches with plants. We bought this equipment from a seller here in Brazil who imports it straight from China, however he doesn't know how to set up the equipment. From what I could deduce he gave access through Teamviewer to a person in China that restored a backup and configured the program (EZcad). However the system had several viruses and Windows crashed every time I tried to save something in EZcad.
    Recently I decided to format the computer and install a clean version of Windows, that's when the problems started.I will try to describe my problem as best as I can, hope someone can help me.

    I can't make the communication between my controller board and the Galvanometer Scanner Head work. I can successfully install the driver and have EZcad control the laser start and stop commands, also control its power, but nothing more.I believe the main clue I have from the source of the problem is the symptom shown by the Scanner Head. When the Scanner Head is turned on only on power it keeps the red common laser (pointer?) in the center, however just as I plug the usb cable into the notebook it slightly moves one of the mirrors and the red common laser is directed to the far edge of the output hole. I made a video showing this symptom:


    The troubleshooting i got from the Galvanometer Scanner Head manual sugests "Check the interference sources and the input signal circuit" to correct this problem. However the data cables are shielded and i checked the wiring multiple times.

    What I already tried:

    A. Changing versions of Windows; Tried Windows 7/10, both in 32 and 64-bit versions
    B. All drivers that can be found on the internet, I tested at least 15 (most of them being the same driver with just different name)
    C. I checked the wiring several timesI grounded the whole system
    D. Checked the conductor integrity of the Sino-galvo cables with a multimeter
    E I tested every version of EZcad I could find (2.7.0; 2.7.6; 2.9.4; 2.12.3; 2.14.9; 2.14.10; 2.14.11)
    F. Donwloaded the datasheets of the controller board main components and tested the voltages, seems fine.

    My suspicions:

    A. Port tab in EZcad not configured (Imgur 4)
    B. IO State show at ports with green state (Imgur 5)
    C. IO Mask not configured or wrong (Imgur 6 and 7)

    Imgur album: https://imgur.com/a/ELmoXZn


    Galvanometer Scanner Head: Sino-Galvo JD2808 (Imgur 9)
    Laser Source: 150w CO2 tube
    Controller board: LMCUSB V2 (JCZ copy) (Imgur 1 and 2)
    Chiller: CW-5000 (Imgur 10)
    Laser Tube Power Supply: HY-T100 (Probable copy of something I don't know) (Imgur 8)

    Do anybody have a clue of what i am missing?

    Also, is there a better software than EZcad or controller board that i can use?

  2. #2
    Join Date
    Aug 2020

    Re: Help with troubleshooting my university laser setup

    Hello, for questions about ezcad software, you can log on to the website to leave a message or call us directly.

Similar Threads

  1. Servo setup and troubleshooting (Samsung CSDJ Plus 02BX2 - CSM 02BB)
    By Zavashier in forum Servo Motors / Drives
    Replies: 35
    Last Post: 04-30-2020, 03:02 AM
  2. Plasma Laser Troubleshooting....
    By cnclaserman in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 0
    Last Post: 02-08-2018, 08:08 PM
  3. Trumpf Laser Cutting Troubleshooting....
    By cnclaserman in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 2
    Last Post: 02-08-2018, 07:34 PM
  4. Need Help Troubleshooting a 40watt CO2 Ebay Laser Engraver Issue
    By TGC in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 0
    Last Post: 01-31-2018, 05:21 AM
  5. Replies: 0
    Last Post: 01-30-2018, 03:06 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts