540,538 active members*
5,373 visitors online*
Register for free
Login
IndustryArena Forum > Machine Controllers Software and Solutions > PlanetCNC > Huanyang spindle speed control issues with output control board and 0-10v
Results 1 to 2 of 2
  1. #1

    Huanyang spindle speed control issues with output control board and 0-10v

    Posting this mostly for the benefit of anyone that had the same issue, who happens to be searching for a solution.

    I am running 2.2kv huanyang vfd with mk3/4 planet-cnc controller and output control board. Its wired for 2 relay 0-10v spindle speed control via TNGv2 on a Rasberry Pi. Settings were all correct per how-tos on planet-cnc site

    I was able to control the speed, but not very reliably and not to the full speed range of 8-24k rpm. I had the set the s value to a speed that would "trick" it into running close to the speed I wanted. For example, S5000 gave me 16k at 100%, which I could dial down to maybe 13k.
    What I found was that the output of the output board would only go down to about 4v. Disconnected the wires from the vfd and measured the vtage again. Now it was putting out exactly the right voltage throughout the 0-100% range. S24 = 10v at 100%, and 8k ( the minimum ) at 0%.
    I run shielded wire that is grounded on everything on this machine - including the wires that ran to the 0-10v signal. I cut the ground wire, and the problem was gone. Works beautifully.
    All I and think of is that there is some kind of loop/short into the ground and it was inducing a current in that line? The weird thing is that I had no other running issues with it. I'll have to see if I can figure out where the leak is coming from and how much...

    Anyway, if you're having controller weirdness, and you're not an electronics expert, check your shielded and grounded connections. Hope this helps someone. I struggled with it for months.

    Drew M

  2. #2
    Registered
    Join Date
    Feb 2011
    Posts
    80

    Re: Huanyang spindle speed control issues with output control board and 0-10v

    Do you have grounded on both sides?
    As I have been informed it shoud be only on one side....( I am not an EE...)
    Can you test it with one side on ground?
    rgds

Similar Threads

  1. SX3 spindle speed control replacement board
    By Wade16 in forum X3/SX3/G0619/G0463
    Replies: 10
    Last Post: 10-06-2018, 11:31 AM
  2. Replies: 1
    Last Post: 10-19-2017, 12:48 PM
  3. Spindle dc speed control board.
    By jkcab95 in forum General CNC Machine Related Electronics
    Replies: 10
    Last Post: 03-25-2017, 06:23 PM
  4. Connecting a breakout board to spindle speed control
    By waisberg in forum Commercial CNC Wood Routers
    Replies: 3
    Last Post: 10-25-2012, 08:04 AM
  5. breakout board with spindle speed control
    By 6bx in forum General CNC Machine Related Electronics
    Replies: 6
    Last Post: 02-19-2009, 08:35 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •