545,783 active members*
2,056 visitors online*
Register for free
Login
IndustryArena Forum > MetalWorking Machines > HURCO > Hurco BMC30 system/HDD problems
Results 1 to 5 of 5
  1. #1
    Registered
    Join Date
    Feb 2007
    Posts
    8

    Hurco BMC30 system/HDD problems

    Hello!

    Colegue has a problem with Hurco BMC30, machine holds on start-up.

    Machine worked without any problems until someone tried to change the language from german to english. After that the service guy came and said that there is problem with the disc and that he can't solve the problem. Only good thing was that he gave us two diskettes with software and some papers from some sort of manual on how to set up the software. The diskettes contain following files:
    - EXECPROG (without extension?)
    - HURCO.LDR
    - LEAD_DE.LAN
    - LEAD_DG.LAN
    - CONFIG folder

    After that I searched the web and found out that the HDD is FAT12 (FAT16?) formatted and partitioned in 10M primary drive. I have an old computer with WIN98 and MS-DOS and when I connected the original disc I saw that the primary drive only had the file HURCO.LDR, without any other files.
    I copied all of the files to primary drive and I also prepared a second HDD (213M) with the same file structure.

    Now we come to the "fun" part When machine is started we get a normal "BIOS" window, then the RAM is checked. After that problems begin ... First we get "Invalid configuration information - please run SETUP program". Next screen says "Loading executive - please wait" and the final screen says "Base memory fault - less than 640K detected". After this message nothing happens until the reset.
    After that, I changed original HDD with the second one and started the machine again ... I again get the "Invalid configuration information - please run SETUP program", after thet screen with two options (F1/F2) appears. When I press F2 some sort of BIOS is shown and I have to set the clock/date and the hard drive information (user definable drive type 48 and 49). After I set this and confirm (F10?) I only get the message "Error loading operating system". After reset I come back to the same setup screen and all the info from the previous adjustments is gone. It apears like the BIOS battery is dead?

    What am I doing wrong? Is there a battery for "BIOS" and where is it located?

    Sorry for long post, I hope that you can understand the problems and advise.

    Best regards, Peter

  2. #2
    Registered
    Join Date
    Jun 2008
    Posts
    1054
    Send the HDD and any disks back to Hurco in The UK and it will be fixed.

  3. #3
    Registered
    Join Date
    Feb 2012
    Posts
    67
    Quote Originally Posted by bloke View Post
    Send the HDD and any disks back to Hurco in The UK and it will be fixed.
    Is this a Hurco courtesy service? If not, what is the cost?

    Tom

  4. #4
    Registered
    Join Date
    Jun 2008
    Posts
    1054
    Usually just the time to fix it. Couple of hours at most.

  5. #5
    Member
    Join Date
    Jun 2021
    Posts
    2

    Re: Hurco BMC30 system/HDD problems

    Quote Originally Posted by PPG78 View Post
    Hello!

    Colegue has a problem with Hurco BMC30, machine holds on start-up.

    Machine worked without any problems until someone tried to change the language from german to english. After that the service guy came and said that there is problem with the disc and that he can't solve the problem. Only good thing was that he gave us two diskettes with software and some papers from some sort of manual on how to set up the software. The diskettes contain following files:
    - EXECPROG (without extension?)
    - HURCO.LDR
    - LEAD_DE.LAN
    - LEAD_DG.LAN
    - CONFIG folder

    After that I searched the web and found out that the HDD is FAT12 (FAT16?) formatted and partitioned in 10M primary drive. I have an old computer with WIN98 and MS-DOS and when I connected the original disc I saw that the primary drive only had the file HURCO.LDR, without any other files.
    I copied all of the files to primary drive and I also prepared a second HDD (213M) with the same file structure.

    Now we come to the "fun" part When machine is started we get a normal "BIOS" window, then the RAM is checked. After that problems begin ... First we get "Invalid configuration information - please run SETUP program". Next screen says "Loading executive - please wait" and the final screen says "Base memory fault - less than 640K detected". After this message nothing happens until the reset.
    After that, I changed original HDD with the second one and started the machine again ... I again get the "Invalid configuration information - please run SETUP program", after thet screen with two options (F1/F2) appears. When I press F2 some sort of BIOS is shown and I have to set the clock/date and the hard drive information (user definable drive type 48 and 49). After I set this and confirm (F10?) I only get the message "Error loading operating system". After reset I come back to the same setup screen and all the info from the previous adjustments is gone. It apears like the BIOS battery is dead?

    What am I doing wrong? Is there a battery for "BIOS" and where is it located?

    Sorry for long post, I hope that you can understand the problems and advise.

    Best regards, Peter
    Hello,
    I just wonder. Did you solve this issue? I have just replaced the mother PCB in my Hurco BMC30 Max3 and there is "read error message" after memory check. I changed the BIOS setting and set HDD parameters (they are different then on the old mother PCB) but nothing has changed after F10 and reset. It comes back to the previous ones. I connected the CMOS battery at J14 as well. Thanks for an advice.

Similar Threads

  1. Hurco BMC30 wash down pumps
    By anchovy in forum HURCO
    Replies: 5
    Last Post: 03-03-2013, 05:00 AM
  2. Hurco BMC30 tool change problem.
    By scottjkolb in forum HURCO
    Replies: 6
    Last Post: 11-25-2011, 09:34 PM
  3. Replies: 0
    Last Post: 11-12-2009, 03:25 PM
  4. Hurco BMC30 spindle problem
    By electromech in forum Benchtop Machines
    Replies: 4
    Last Post: 04-07-2008, 10:43 AM
  5. Hurco BMC30 spindle problem
    By javed08 in forum General CNC (Mill / Lathe) Control Software (NC)
    Replies: 1
    Last Post: 08-08-2007, 05:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •