I'm using this 5 axis breakout board with Mach3.
I'm using a diode laser and M10 M11 to do laser raster images.
I'm using vectric to output the gcode, when doing raster work every time M11 and M10 are engaged the axis motion (X and Y axis) become very jerky and unsmooth.
This happens only when I'm doing raster engraving and there's a lot of m11 and m10 codes in the file. This does not happen if I'm doing vector work.

Things I've tried so far:
1- Turned off constant velocity in mach3.
2- Put decoupling capacitor on the 5v input.
3- Replaced the cables with shielded ones.
4- Set constant velocity distortion tolerance from 1 - 180.
5- Slowed down the feed rate and made it faster.

All of the above didn't work.
Your ideas are welcome!