527,773 active members*
2,863 visitors online*
Register for free
Login
IndustryArena Forum > MetalWorking Machines > Okuma > LB15 OPUS 5000-II CRPB-II board needed.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Jul 2007
    Posts
    103

    LB15 OPUS 5000-II CRPB-II board needed.

    G'day guys,

    I can confirm that replacing the CRPB board has solved my boot up problem as I managed to get a tech to test the machine with his test board and it worked.

    The tech advised I could find one online or perhaps have my original board repaired.

    Does anyone know of a good second hand source for these boards or their refurbishment?

    Part number is OPUS 5000-II CRPB-II, 1911-164-2 (but the test board 164-1 worked but tech said may be missing some features)
    Attached Thumbnails Attached Thumbnails IMG_20180614_170357-1600.jpg   IMG_20180614_133752-1600.jpg   IMG_20180614_170416-1600.jpg  

  2. #2

    Join Date
    Mar 2020
    Posts
    10

    Re: LB15 OPUS 5000-II CRPB-II board needed.

    Hello rotec,

    Do you remember what kind of issues you had? Was it hanging on the boot, giving error message or something else?
    Also, if you remember - do the numbers in the white box matter or is it enough to have the same model number? For example, our main board (that we're trying to replace) has model number E4809-436-011-E (but has 1911-1500-15-330 in the white box), so getting the E4809-436-011-E, will work or not?

    Thanks

  3. #3
    Junior Member
    Join Date
    Jul 2007
    Posts
    103

    Re: LB15 OPUS 5000-II CRPB-II board needed.

    Quote Originally Posted by cmcraeslo View Post
    Hello rotec,

    Do you remember what kind of issues you had? Was it hanging on the boot, giving error message or something else?
    Also, if you remember - do the numbers in the white box matter or is it enough to have the same model number? For example, our main board (that we're trying to replace) has model number E4809-436-011-E (but has 1911-1500-15-330 in the white box), so getting the E4809-436-011-E, will work or not?

    Thanks
    My issue was I had no CRT working, and the machine would not boot up or start.
    I resolved the issue by replacing the board with E4809-436-011-E from eBay, yes it worked, it was a compatible board.

    Paul

  4. #4

    Join Date
    Mar 2020
    Posts
    10

    Re: LB15 OPUS 5000-II CRPB-II board needed.

    Thanks!

Similar Threads

  1. Tapping with ocuma lb15 osp 5000
    By xal3r in forum Okuma
    Replies: 23
    Last Post: 09-01-2016, 07:21 AM
  2. 1984 LB15 Spindle alarm help needed
    By WC56 in forum Okuma
    Replies: 27
    Last Post: 11-26-2015, 02:23 AM
  3. OPUS 5000 Okuma OR10
    By cncboy1 in forum Okuma
    Replies: 0
    Last Post: 05-01-2008, 09:47 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •