we've got this machine that is acting weird right now, we have 2 laptops (just bought another one for reserve today) which we are using for transmiting programs to machines.
We've also got 4 fanuc machines also using RS-232 for communication and transfering of programs to and from machines.

On old laptop everything works just fine on every machine, on this new one every fanuc machine works fine and on this Mikron Haas VCE 750 I can send programs from machine to laptop, no problems, but when I try to send program from laptop to machine it says RS-232 empty program every time I try.

I've tried just now to once again send same program using older laptop and it will work no problem.

So it seems to me either there is something weirdly wrong with this new laptop or with haas machine.

Cable is not a problem since we can use this older laptop both ways no problem.
Also every time when I press send on new laptop, during transmission of program I see some weird <DC><DC> characters in between G-code lines. What is that?

?What is weird also is that when I use older laptop (which normally work as it should) and press send on laptop to send a program, but on the machine end I haven't pressed receive I get same weird <DC><DC> characters during transmission of program and after I've done that I press receive on machine and then send on laptop it will recreate the same alarm "RS-232 empty program" on machine.
?If I now, after that, reset machine alarm and repeat process of sending from laptop to machine, it will work this second and every other time. Only when I don't press receive on machine and press send on laptop it will act up like that.

I've tried setting up communication ports on newer laptop and on machine, set parity to none, but nothing helped.
Even the simplest program:
wont go through.

What could be the problem?
Thanks for any advice in advance.