Hi,

I am trying to fix a Mitsubishi spindle controller, its model FR-SF-2-11K-BC / sub model G52A.

The owner had the spindle drive motor go bad and it took out the controller with it, he replaced the motor but is still getting error AL023 on the controller readout / and error: "010 SPNDL SPEED ERROR." on the CRT screen.

I put a good controller we had in their CNC machine and it worked fine, I took their bad controller and put it on our CNC machine and we received the same error.

The odd thing is that X, Y, and Z, work fine but when you hit the spindle START button and then try to run the spindle up to like 150 rpms with no load on it the CRT screen instantly says that the spindle has a 120% load on it but the motor never spins meanwhile the spindle spins freely by hand and the RPMs of spinning it by hand are showing up on the CRT.

And again this CNC machine works just fine with our controller in it and unfortunately the only spare SF-CA boards that we have are version G53B which are not compatible with the other electronics on his controller unit and the main board won't even power up (and yes I checked all the jumpers).

I took his controller all apart and tested all of the transistor modules and ended up replacing two with used ones that we had, I verified against our controller that all of the little red, white, and blue, wires go where they are supposed to go on the three long black main board connectors, I've also tested the two current/amperage sensors on the U and V outputs and they match our controller pretty closely.

On the large contactor I did an ohms check on all three phases and everything came out equal, same with the three U-V-W outputs and the three big white wires that come up to the transistor modules for the braking system everything is equal, the three big capacitors are also testing ok.

One final test that I did which required multiple reboots to accomplish within the few seconds that I had before the error shut everything down was that there is about 300 volts DC sitting on the two inputs of the three transistor modules and the U-V-W outputs all have 8 volts AC @ 180 Hz or kHz (I don't remember which now), and even with the RPMs at 150 and the 120% load all three phases are still at 8 volts AC.

I also replaced the SF-TL board with one of ours but none the less its still giving the same error.

My two theories at this point are that the transistor modules are failing under load, or there is some kind of communication failure between the SF-CA main board and the transistor modules.

If any one has a schematic of this entire unit I would appreciate it and/or any other help would be appreciated.

Thanks, -Landon