541,063 active members*
3,415 visitors online*
Register for free
Login
IndustryArena Forum > Additive Manufacturing / 3D Printers and 3D Scanners > Electronics > Need Help with STB4100 board with TB6560 driver
Results 1 to 1 of 1
  1. #1
    Member
    Join Date
    Apr 2021
    Posts
    1

    Question Need Help with STB4100 board with TB6560 driver

    Hello all,
    I am kinda new to the diy cnc world. Can someone please tell me if it is possible to pair a STB4100 (Mach3 USB) board with MD430 (TB6560) driver?
    The board output seems to use a different labels than the driver inputs. one is step/dir/en/+5v and the other is using the pul+/Pul-/dir+/dir- etc.
    any help is much appreciated.
    Attached Thumbnails Attached Thumbnails IMG_4176[1].jpg   IMG_4175[1].jpg  

  2. #2
    Registered
    Join Date
    Nov 2012
    Posts
    1072

    Re: Need Help with STB4100 board with TB6560 driver

    Step goes to Pul-
    Dir goes to Dir-
    +5V goes to Pul+ and Dir+.

  3. #3
    Registered
    Join Date
    Jan 2018
    Posts
    562

    Re: Need Help with STB4100 board with TB6560 driver

    As Citizen said below.

    However.
    You can also use 'en' if you wish to enable or disable the drivers. (they are default enabled so isn't normally needed) I think it just saves a bit of power use when sat idle.
    So:
    Step
    goes to Pul-
    Dir goes to Dir-
    But then instead:
    +5V goes to Pul+ and Dir+ and Enbl+
    EN goes to Enbl-

    En (enable) is set on one of the outputs (ie: P14 on mine, then configured as output 1 = P14 in my ports/pins IO pages).
    This gives you the lowdown on what the 'en' label is.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •