540,357 active members*
985 visitors online*
Register for free
Login
Results 1 to 5 of 5
  1. #1

    Join Date
    Apr 2021
    Posts
    3

    Need to reinstall ESS

    I tried setting up a USB hub so I only had one cable to swap to move my laptop out to the machine. I was fully operational and working beautifully using a USB ethernet adapter. I tried plugging the USB ethernet adapter into the usb hub and it was not found when loading Mach4. I removed the ethernet cable from the usb adapter and plugged it into the hub directly, it was not found when loading Mach4. I tried to launch the SCU application and there was only one adapter showing- the SmoothStepper Network static record. I selected it and clicked Configure Everything and it was not recognizing pings.

    I decided to go back to the usb ethernet adapter, so I moved the cable back to the adapter and plugged the adapter back into the single USB on the laptop. When I launch Mach4, it is not recognized. I tried using the SCU to reconfigure the adapter, but it says it appears I already have one configured. How do I delete or clear the existing driver so I can reinstall the ESS?

  2. #2
    Registered
    Join Date
    Mar 2017
    Posts
    217

    Re: Need to reinstall ESS

    Open device manager. In the menu options choose to show hidden devices. Look through and delete the driver after that. Then it may recognize again.

    Sent from my SM-N960U using Tapatalk

  3. #3
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003
    Posts
    35442

    Re: Need to reinstall ESS

    Do you have a USB Smoothstepper or an ethernet Smoothstepper (ESS)?
    I don't think that Mach4 supports the USB Smoothsteppers
    Gerry

    UCCNC 2017 Screenset
    http://www.thecncwoodworker.com/2017.html

    Mach3 2010 Screenset
    http://www.thecncwoodworker.com/2010.html

    JointCAM - CNC Dovetails & Box Joints
    http://www.g-forcecnc.com/jointcam.html

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)

  4. #4

    Join Date
    Apr 2021
    Posts
    3

    Re: Need to reinstall ESS

    I am using a usb to ethernet adapter and it was working just fine before I ran the SCU while it was plugged in via a hub.

    Thanks for the suggestion- I cleared device manager and it was recognized when I plugged in the USB to ethernet adapter. Same message when trying to run the SCU. I opened Network Connections and can see the SmoothStepper Network- I can disable it but the option for Delete is greyed out. I'm so mad at myself for running the SCU while plugged into the hub. Stupid mistake.

  5. #5

    Join Date
    Apr 2021
    Posts
    3

    Re: Need to reinstall ESS *Resolved

    **Solved**

    Avid support came right back with the ultimate answer at the bottom. After I reset my internet settings per their instructions, I still received the error message when running the SCU to set up the SmoothStepper. I checked in Network Connections>>Change Adapter Options to get to the Network Connections window and saw that the only remaining network was the SmoothStepper. Last time I checked here before the reset it was locked and I couldn't disable it but now I could. After disabling it and rebooting I was able to run the SCU and get pings. When I opened Mach4, I had full control again.





    Here's the email from Support:


    Thanks for reaching out, the only way to really delete the Smoothstepper connection would be to do a complete "Network Reset" however, it does have some downsides.

    The consequences of a full network reset are that ALL network adapters are completely set up from scratch again by Windows, so the SCU will need to be run again to set up the network for the CNC controller/Smoothstepper, but also any other saved network setting and Wifi networks / credentials, etc. will be removed, and will need to be reconfigured.

    A Network reset can be performed from the Setting app - you can most easily get to it by just searching for "network reset" in Windows:
    Select that option, which will take you to it in the Settings app:

    Just click Reset now, and then Yes at the following prompt.

    Your PC will then Reboot and your network drivers will be restored to default.

Similar Threads

  1. Reinstall everything to small
    By Gallchobhair in forum BobCad-Cam
    Replies: 3
    Last Post: 02-17-2018, 09:57 PM
  2. Madcam reinstall
    By Woodworker24 in forum MadCAM
    Replies: 6
    Last Post: 08-02-2012, 12:34 PM
  3. v23 reinstall
    By ErnieD in forum BobCad-Cam
    Replies: 18
    Last Post: 06-03-2012, 04:55 PM
  4. Reinstall control software
    By mishikwest in forum Techno CNC
    Replies: 2
    Last Post: 09-20-2009, 02:32 PM
  5. Uninstall / Reinstall
    By j-radkemachine in forum BobCad-Cam
    Replies: 1
    Last Post: 06-05-2007, 04:13 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •