589,390 active members*
6,340 visitors online*
Register for free
Login
IndustryArena Forum > CNC Electronics > Stepper Motors / Drives > Nema 34 closed loop driver alarm problem(HBS86H)
Results 1 to 10 of 10
  1. #1
    Join Date
    Mar 2019
    Posts
    6

    Nema 34 closed loop driver alarm problem(HBS86H)

    Greetings,

    I have a problem with getting the motor run.

    Bought <a href="https://www.ebay.com/itm/US-SHIP-NEMA34-Closed-Loop-Stepper-motor-34SSM1460-1000line142mm-9N-M-HBS86H/153292309608?hash=item23b0ef0468%3Ag%3AcGsAAOSwkvt cCLIp&frcectupt=true&fbclid=IwAR1Y0ci_PGn2Kx44ZvH5 6afmrTspnOuSM3_9gJBNHN62vZ5VY8P16xkUPD8">these</a> drivers and motors from e bay and wiried one of them accordingly to seller's specification.

    I supply the driver with S-400-60(60v DC switching power supply).

    When i connect driver and motor and plug in the power supply, green diode on driver lights up. But when i connect driver with my BoB, red alarm diode on driver lights up.

    I'm using <a href="https://www.ebay.com/itm/5Axis-CNC-Breakout-Board-with-USB-Cable-fr-Stepper-Motor-Drive-Controller-MACH3/202488240836?_trkparms=aid%3D555018%26algo%3DPL.SI M%26ao%3D1%26asc%3D20131003132420%26meid%3D85f5c83 c9020414d97b696f0b6f5abf7%26pid%3D100005%26rk%3D4% 26rkt%3D12%26sd%3D262781362960%26itm%3D20248824083 6&_trksid=p2047675.c100005.m1851">5 axis BoB from ebay</a>.

    I would be thankful if someone more expierienced could point me to possible errors in my setup.

    Photos of setup are in attachment.

  2. #2
    Join Date
    Dec 2003
    Posts
    1254

    Re: Nema 34 closed loop driver alarm problem(HBS86H)

    Have you tried looking on youtube?It was a great help to me when I had similar problems making a Nema 23 setup work,although you will have to watch for people who seem to like the sound of their own voice and spread solid information rather thinly.This fellow seems to be doing something very similar to the OP and has good information and links.

    https://www.youtube.com/watch?v=j9EpLjhIOVQ

  3. #3
    Join Date
    Mar 2019
    Posts
    6

    Re: Nema 34 closed loop driver alarm problem(HBS86H)

    Thank's for your answer.

    I've seen this video. Problem is that my driver has diffirent pins order than this.

    I managed to find some other specifications from seller (Closed loop motor driver-HBS86H - China Changzhou Longs Motor , diffirent from those from ebay) and rewiried encoder input. Now when I plug in power supply with just driver and motor(not connected to BoB), motor vibrates a little bit and then start to buzz. I find information on forum that buzzing when idle should be normal.

    Then i connected driver to my BoB. When i pluged in power supply my PC and driver board turned off. I tried to turn it on again not connected to BoB and it buzz again so I think I didn't burn driver.

    I'm suspecting that something is not right with in my connection between driver and BoB and that why alarm was on in the first place.

    But I don't see problem in connection. I am feeding PUL+, DIR+, and ENA+ with 5v from the BoB, and connected PUL-,DIR- and ENA- to the BoB. Am I missing something ?

  4. #4
    Join Date
    Dec 2003
    Posts
    1254

    Re: Nema 34 closed loop driver alarm problem(HBS86H)

    Do you have any software loaded that would allow you to turn the stepper motors?I found a very similar situation when I was connecting my much more basic Nema 23's and the problem disappeared when I switched the connections from one pair of coils.

  5. #5
    Join Date
    Mar 2019
    Posts
    6

    Re: Nema 34 closed loop driver alarm problem(HBS86H)

    I switched two wires on my encoder input and now everything works. Strange, but finally works. It turns out that buzzing sound was not normal, motor is pretty quiet when idle.

    routalot, thank you for your help.

  6. #6
    Join Date
    Mar 2017
    Posts
    1

    Re: Nema 34 closed loop driver alarm problem(HBS86H)

    Quote Originally Posted by Lnt View Post
    I switched two wires on my encoder input and now everything works. Strange, but finally works. It turns out that buzzing sound was not normal, motor is pretty quiet when idle.

    routalot, thank you for your help.
    having same problem.. what were your final encoder connections if you dont mind me asking.. if tried everything.

  7. #7
    Join Date
    Mar 2019
    Posts
    6

    Re: Nema 34 closed loop driver alarm problem(HBS86H)

    Quote Originally Posted by wildtrak View Post
    having same problem.. what were your final encoder connections if you dont mind me asking.. if tried everything.
    On 2 drivers i wired WHITE, BLUE, GREEN, YELLOW, RED, BLACK (from top to bottom, red is Vcc, and black is GND), and on another 2 i have connection BLUE, WHITE, YELLOW, GREEN, RED, BLACK.

  8. #8
    Join Date
    May 2013
    Posts
    3

    Re: Nema 34 closed loop driver alarm problem(HBS86H)

    I also had problems with the Chinese servo stepper.
    IT APPEARS THAT THE BLACK WIRE IS NOT AT ALL GND.
    The safest way to connect everything properly is to carefully unscrew the encoder housing and LOOK AT THE COLORS OF THE CONNECTIONS
    Indulis
    Attachment 437432

  9. #9
    Join Date
    Dec 2021
    Posts
    1

    Re: Nema 34 closed loop driver alarm problem(HBS86H)

    Quote Originally Posted by indulisap View Post
    I also had problems with the Chinese servo stepper.
    IT APPEARS THAT THE BLACK WIRE IS NOT AT ALL GND.
    The safest way to connect everything properly is to carefully unscrew the encoder housing and LOOK AT THE COLORS OF THE CONNECTIONS
    Indulis
    Attachment 437432
    Also for me it turned out that the documentation of the pin colors was not up to reality and all I could get was a buzzing sound, uncontrolled movements and a flashing alarm LED. See attached photo with the back lid unmounted. After adhering to what was printed on the board and not on paper, everything was working perfectly!

  10. #10
    Join Date
    Dec 2019
    Posts
    4

    Re: Nema 34 closed loop driver alarm problem(HBS86H)

    Can any these closed loop driver fit you?
    https://www.oyostepper.com/category-...er-Driver.html
    I also confront diffrent problem in my robots project.

  11. #11

    Re: Nema 34 closed loop driver alarm problem(HBS86H)

    Quote Originally Posted by Lnt View Post
    On 2 drivers i wired WHITE, BLUE, GREEN, YELLOW, RED, BLACK (from top to bottom, red is Vcc, and black is GND), and on another 2 i have connection BLUE, WHITE, YELLOW, GREEN, RED, BLACK.
    Well, that solved my problem thank you. Four new HBS86H's from HLTNC two that work correctly in any position in my setup e.g. X, Y or Z, any psu, any stepper motor, connection cables or wiring loom and two that did not. That was until I rewired the encoder feedback connection at the HBS86H to WHITE, BLUE, GREEN, YELLOW, RED, BLACK (contrary to the documentation). This means the HBS86H is wired incorrectly internally. You would think that SW2 of the HLTNC units (SW5 on a Leadshine) would fix the problem but it does not.

    Thanks again

Similar Threads

  1. NEMA 23 Closed Loop Stepper Motor System-Hybrid Servo Kit
    By automationtechinc in forum Automation Technology Products
    Replies: 0
    Last Post: 07-22-2018, 05:53 PM
  2. Replies: 10
    Last Post: 04-09-2018, 07:05 AM
  3. Closed loop stepper motors w/driver
    By sprintcar72 in forum Stepper Motors / Drives
    Replies: 8
    Last Post: 02-18-2017, 04:24 AM
  4. Replies: 0
    Last Post: 05-06-2015, 01:11 PM
  5. Closed Loop Driver vs. Closed Loop Computer
    By ojibberish in forum Gecko Drives
    Replies: 3
    Last Post: 06-08-2004, 05:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •