528,076 active members*
2,638 visitors online*
Register for free
Login
Results 1 to 5 of 5
  1. #1
    Registered
    Join Date
    Jan 2006
    Posts
    40

    New controller woes

    I have been running my PCNC1100 series 1 with Pathpilot 2 on a Dell computer without any problems until recently when the computer broke.

    Rather than getting the Dell fixed I wanted to move to a Mesa/Ethernet solution with a small fanless form factor PC I had from about 4 years ago. Pathpilot loaded up and controlled the mill over ethernet fine and but the PC was running too hot to touch and kept on locking up.

    As a replacement PC I bought one of these: https://www.amazon.co.uk/gp/product/...?ie=UTF8&psc=1

    Pathpilot 2 installed without a problem however when restarting the PC it just goes into the bios and looking at the boot settings it isn't finding a boot partition it can use (or that is my interpretation of what I am seeing).

    I have checked the date/time setting, AHCI is the hard drive setting as per the trouble shooting section in the Tormach installation guide.

    As an extra check that the new PC is working I loaded Mint from a USB drive and everything checks out.

    The bios is americal megatrends (c) 2020 and the configuration I have tried are:
    Disabled Trusted Computing (was enabled).
    Disabled Platform Trust Technology (was enabled)
    Chip set/South Bridge/OS selection is set to Linux (was Windows)

    After each combination I reloaded PathPilot from the USB stick again, but it hasn't made any difference.

    I have contacted Tormach support but as it isn't one of their controllers they, not surprisingly, don't want to know.

    Can you suggest anything else I might try or failing that any recommendations for a current small form factor computer that is known to work with PathPilot?

    Dave.

  2. #2
    Registered
    Join Date
    Nov 2012
    Posts
    496

    Re: New controller woes

    You need to post a screen shot of the error you get when booting.
    My spider senses say that this is probably a UEFI versus MBR boot mode problem, perhaps?
    Also, following the advice for the Tormach controller BIOS settings only goes so far, as your system may be very different.
    It may be that the PathPilot installer forces MBR mode, but your new computer only works with UEFI mode, for example.
    You should be able to make that work by editing the grub configs and running update-grub from the command line after installing PathPilot, if that's the problem.
    (The internet of course has more detailed descriptions of these things, if you should go googling ...)

  3. #3
    Registered
    Join Date
    Jan 2006
    Posts
    40

    Re: New controller woes

    There is no error as such while booting. After installing PathPilot 2 from the USB stick when you come to restart the computer it just goes straight to the bios screen. Anyhow I have included the start up bios screen and also the boot screen.

    I have tried installing Mint after PathPilot and keeping PathPilot as well with the hope of getting more control during boot, but unfortunately it fails to install with PathPilot. Doing a fresh install where PathPilot is removed works fine.

    Dave.

  4. #4
    Registered
    Join Date
    Nov 2012
    Posts
    496

    Re: New controller woes

    No UEFI settings? That's exciting.
    You'd have to boot from a USB stick and take a look at the partition table installed by PathPilot to figure out what's going on then ...
    My guess is your BIOS is UEFI-only, and won't even boot MBR anymore, whereas the PathPilot installer may still be MBR. Maybe there's a setting you can pull up in the PathPilot installer where you select/configure the disk to install to?

Similar Threads

  1. LPT woes...ugh
    By chemsolder in forum USB, RS232, PARALLEL etc
    Replies: 3
    Last Post: 11-04-2014, 08:07 PM
  2. VF-4 vs VF-5: Z travel woes...
    By MarkSerbu in forum Haas Mills
    Replies: 5
    Last Post: 11-19-2012, 07:55 PM
  3. Bridgeport Series 2 interact 2 controller woes
    By Teyber12 in forum Bridgeport / Hardinge Mills
    Replies: 6
    Last Post: 10-31-2010, 11:19 AM
  4. RE- My woes with CNC......
    By kbillan in forum Taig Mills / Lathes
    Replies: 53
    Last Post: 01-16-2009, 11:22 PM
  5. Bob CAD woes
    By Mr. LocoMartin in forum BobCad-Cam
    Replies: 23
    Last Post: 01-25-2008, 09:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •