521,872 active members*
2,285 visitors online*
Register for free
Login
Results 1 to 2 of 2
  1. #1

    Not backing off limit switch issue.....

    Not backing off limit switch issue.....

    Hi folks,
    When I Ref X axis it travels to the limit sensor (inductive proximity type) and just stops, the small led light on the sensor body itself stays lit and Mach3 goes into emergency stop, it does not back off the switch and confirm Ref 0. I have to partially remove the sensor to put out it's led and reset the warning in Mach3 before I can jog back the x axis off the switch.
    The Y and Z axis Ref fine and back off the switches and the green Led in the diagnostics panel changes from Red to Green for these two, but the X axis does not and stays Red.

    The Machine is an ARF6040E ethernet version so no serial port fixes or issues apply.
    As limit switches are the inductive proximity type there is obviously not physical binding or jamming.

    I have Googled myself to near death searching for a solution, a read through hundreds of fruitless forum posts, most refering to similar but slightly different issues, common suggestions recommend upping debounce setting and attaching capacitors to the switch etc, I have tried the debounce adjustments, but that made no difference, not ready to start messing with caps just yet.

    An additional issue I have is the Z axis will not back off the probe when Auto tool zero, the macro script for the ATZ says it should back off 10mm.
    It does Zero the Z axis tool correctly, just doesn't back off the probe, I have to press the reset button on the bottom left of Mach3 and "page up" to back off.
    This is less of a concern than the X axis issue, but none the less an obvious problem.

    Many thanks in advance for anyone willing to help out

  2. #2

    Re: Not backing off limit switch issue.....

    I fixed it, I went through all the ports and pin settings with the ARF setup guide, everything seemed correctly set except the emergency stop was not assigned to pin 5, it was on pin 0 the same as the X-axis proximity sensor/homing , changed from that 0 to 5 and everything now works, Ref all Home worked correctly from the Main Mach 3 panel and auto tool zero worked correctly and backed off the correct 10mm, hooray

Similar Threads

  1. limit switch issue after replacing BoB
    By japes in forum DIY CNC Router Table Machines
    Replies: 0
    Last Post: 07-18-2018, 09:50 AM
  2. G540 Limit Switch issue, no Limit Switches fitted!
    By Imagineering in forum Gecko Drives
    Replies: 0
    Last Post: 09-22-2017, 08:21 AM
  3. Strange limit switch issue.....
    By Matt McColley in forum Benchtop Machines
    Replies: 0
    Last Post: 10-31-2013, 04:59 PM
  4. limit switch triggered issue
    By 15mgtar in forum Mach Software (ArtSoft software)
    Replies: 6
    Last Post: 10-19-2009, 09:25 AM
  5. limit switch issue?
    By 300sniper in forum Tormach Personal CNC Mill
    Replies: 8
    Last Post: 01-28-2008, 05:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •