545,780 active members*
2,246 visitors online*
Register for free
Login
Results 1 to 6 of 6
  1. #1

    Unhappy Not properly working stepper motors

    Hello,

    recently I bought my first CNC, it´s a CNC Workbee (from Chinese company Bulk-Man 3D).
    As I followed all the uncertain instructions that I mostly figured out by myself, I´ve got a problem that I just can´t figure out.

    I got the whole machine connected to a computer with MACH3, got all the things set up, I just followed some guy on Youtube. And mine just doesn´t want to work with the motors.

    I believe the problem is in the motor tuning, but when I get it working on the arrow keys (on keyboard) then it doesn´t work on computer-operated actions (such as go to ZERO, etc.)
    Hopefully, all the cables are connected well, since I checked them like 10 times because I´m really desperate.

    I hope somebody will be able to help. Thanks
    Also adding some pictures and video for reference.

    Wire Connections -
    https://i.imgur.com/vaeK6c3.jpg
    https://i.imgur.com/1wrtm7R.jpg
    https://i.imgur.com/86tAZmf.jpg
    https://i.imgur.com/41IeEXl.jpg
    https://i.imgur.com/oOPXMP8.jpg

    Mach3 Setup -
    https://i.imgur.com/arCnoVG.jpg
    https://i.imgur.com/99HCnid.jpg
    https://i.imgur.com/RQjLgVk.jpg

    Motors video -
    https://drive.google.com/file/d/1Bh2...ew?usp=sharing

    Since all my photos and videos are quite big, I had to upload it to different sites, so sorry about the inconvenience.

  2. #2
    Gold Member
    Join Date
    Apr 2004
    Posts
    5361

    Re: Not properly working stepper motors

    Your video didn't play for me, but it's odd that it will jog but not respond to G-code commands. Are you going to the MDI screen and issuing a command like "G0X1.500" That's G zero, not "go to".
    Andrew Werby
    Website

  3. #3

    Re: Not properly working stepper motors

    Sorry about the video, I uploaded it to youtube : https://youtu.be/5NM-0HP7le0
    I meant it like an example, basically it does that whenever I set something from mach other than from jog.
    Also, I´m not really sure about the motor tuning, that might be the problem, I tried many different settings but almost none worked for me, and even after calculating all of it it didn't work.

  4. #4

    Re: Not properly working stepper motors

    Before I tried setting different values in motor tuning (on video) I found that the quietest setting was 800/200/200, which worked quiet with the jog, but the issue with the Gcode run stayed and kept doing the weird stuff like on the video.

  5. #5
    Gold Member
    Join Date
    Apr 2004
    Posts
    5361

    Re: Not properly working stepper motors

    That sounds horrible. No wonder it doesn't work. I can't tell what you're doing from your video, but it sounds like your motors are very unhappy, whatever it is. Did you buy this new, and if so, can you ask the seller what's going on? Is it supposed to be getting 220v and getting 110 instead?
    Andrew Werby
    Website

  6. #6

    Re: Not properly working stepper motors

    Yes, the set was new. I checked the Power supply that came with it and it seems okay.
    I will try to contact them again. It might be faulty PSU, since it "buzz" really loud when under load for longer periods.
    Also the 220v is selected, and we run on 220, which should be okay.

Similar Threads

  1. Properly ground stepper motors ???
    By Biggermens in forum General CNC Machine Related Electronics
    Replies: 8
    Last Post: 07-27-2020, 08:09 PM
  2. Stepper Motors not working Please help
    By emh114 in forum Stepper Motors / Drives
    Replies: 1
    Last Post: 01-14-2016, 02:50 AM
  3. Who is using Leadshine Hybrid Stepper motors in working machine?
    By darthmuller in forum General CNC Machine Related Electronics
    Replies: 0
    Last Post: 04-09-2015, 08:50 PM
  4. Wire EDM Stepper Motors Not Working
    By sparky212 in forum Stepper Motors / Drives
    Replies: 0
    Last Post: 01-11-2010, 04:20 PM
  5. servo and stepper motors living and working together on on system
    By eloid in forum DIY CNC Router Table Machines
    Replies: 0
    Last Post: 01-08-2008, 02:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •