549,889 active members*
2,206 visitors online*
Register for free
Login
IndustryArena Forum > Machine Controllers Software and Solutions > Fanuc > Parameter problems- part count not working
Page 1 of 2 12
Results 1 to 20 of 27
  1. #1
    Registered
    Join Date
    Apr 2011
    Posts
    50

    Parameter problems- part count not working

    We have a Hardinge Conquest ST225B and had some major unexplainable parameter issues. Our maintenance team got the machine back up and running but left it with a few errors through out the parameter settings. One problem is the part count is no longer even displayed when the "POS" button is pressed along with The power time, cutting time, cycle time etc. are all at zeros under "offset settings". This is not a new machine to us and have at one time had everything working till one day everything went haywire. HELP Please and Thank You!!!!

  2. #2
    Junior Member
    Join Date
    Jul 2010
    Posts
    369
    Is the part count showing Zero or not there at all?

  3. #3
    Registered
    Join Date
    Apr 2011
    Posts
    50
    It is not there at all but use to be.

  4. #4
    Junior Member
    Join Date
    Jul 2010
    Posts
    369
    Have you ran any parts?
    If not try a 'MDI" input of M30, and just see if the part counter shows up.
    Strange situation you have there.

    What Fanuc Control exactly is it you have?
    Is it an 18T ?

  5. #5
    Junior Member
    Join Date
    Jul 2010
    Posts
    369

    Fanuc 18T Param.

    Fanuc 18T Param.

    PARAMETERS OF DISPLAYING OPERATION TIME AND NUMBER OF PARTS

    Bit
    PCM

    M code that counts the total number of machined parts and the number of machined parts0 :M02, or M30, or an M code specified by parameter No.

    6710 :Only M code specified by parameter No. 6710

    6710 M code that counts the total number of machined parts and the number of machined parts

    [Valid data range]

    0 to 255 except 98 and 99The total number of machined parts and the number of machined parts arecounted (+1) when the M code set is executed.

    Note:
    Set value 0 is invalid (the number of parts is not countedfor M00). Data 98 and 99 cannot be set.

    6711 Number of machined parts
    Setting entry is acceptable.

    [Data type]
    2–word
    [Unit of data]
    One piece
    [Valid data range]
    0 to 99999999The number of machined parts is counted (+1) together with the totalnumber of machined parts when the M02, M30, or a M code specified byparameter No. 6710 is executed.

    6712 Total number of machined parts
    Setting entry is acceptable.
    [Data type]
    2–word
    [Unit of data]
    One piece
    [Valid data range]
    0 to 99999999This parameter sets the total number of machined parts.

    The total number of machined parts is counted (+1) when M02, M30, oran M code specified by parameter No. 6710 is executed.

    6713 Number of required parts

    Setting entry is acceptable.
    [Data type]
    Word
    [Unit of data]
    One piece
    [Valid data range]
    0 to 9999This parameter sets the number of required machined parts.Required parts finish signal PRTSF is output to PMC when the number of machined parts reaches the number of required parts. The number of partsis regarded as infinity when the number of required parts is zero. ThePRTSF signal is then not output.

    6750 Integrated value of power–on period

    Setting entry is acceptable.
    [Data type]
    2–word
    [Unit of data]
    One minute
    [Valid data range]
    0 to 99999999This parameter displays the integrated value of power–on period.

    6751 Operation time (integrated value of time during automatic operation)

    Setting entry is acceptable.
    [Data type]
    2–word
    [Unit of data]
    One ms
    [Valid data range]
    0 to 60000

    6752 Operation time (integrated value of time during automatic operation)
    Setting entry is acceptable.
    [Data type]
    2–word
    [Unit of data]
    One minute
    [Valid data range]
    0 to 99999999This parameter displays the integrated value of time during automaticoperation (neither stop nor hold time included).

    6753 Integrated value of cutting time

    Setting entry is acceptable.
    [Data type]
    2–word
    [Unit of data]
    One ms
    [Valid data range]
    1 to 60000

    6754 Integrated value of cutting time

    Setting entry is acceptable.
    [Data type]
    2–word
    [Unit of data]
    One minute
    [Valid data range]
    0 to 99999999This parameter displays the integrated value of a cutting time that isperformed in cutting feed such as linear interpolation (G01) and circularinterpolation (G02 or G03).

    6755 Integrated value of general–purpose integrating meter drive signal (TMRON)ON time

    Setting entry is acceptable.
    [Data type]
    2–word
    [Unit of data]
    One ms
    [Valid data range]
    0 to 60000

    6756 Integrated value of general–purpose integrating meter drive signal (TMRON)ON time

    Setting entry is acceptable.
    [Data type]
    2–word
    [Unit of data]
    One minute
    [Valid data range]
    0 to 99999999This parameter displays the integrated value of a time while input signalTMRON from PMC is on.

    6757 Operation time (integrated value of one automatic operation time)

    Setting entry is acceptable.
    [Data type]
    2–word
    [Unit of data]
    One ms
    [Valid data range]
    0 to 60000

    6758 Operation time (integrated value of one automatic operation time)

    Setting entry is acceptable.
    [Data type]
    2–word
    [Unit of data]
    One minute
    [Valid data range]
    0 to 99999999
    This parameter displays the one automatic operation drive time (neitherstop nor hold state included). The operation time is automatically presetto 0 during the power–on sequence and the cycle start from the reset state.

    Hope this will help you some :cheers:

  6. #6
    Gold Member
    Join Date
    Aug 2011
    Posts
    2517
    I doubt any of those will help. even if they are all 0 it just means the part count will not count up but will just stay on 0. the problem is more likely it is not enabled in the option parameters. the clock and part count is an option......

  7. #7
    Registered
    Join Date
    Apr 2011
    Posts
    50
    It is an 18T controller and I have checked most of the parameters listed and i can find values in certain parameters that will tell me some of the info i am looking for but the problem has to be like " fordave11 " says... There must be a parameter or something just to turn these options ON?? Thanks for the replys so far!!!

  8. #8
    Junior Member
    Join Date
    Jul 2010
    Posts
    369
    Ahh Yes! Options parameters begin at 9900.
    Short on time right now but I can post some more info later.
    Good Luck!:cheers:

  9. #9
    Registered
    Join Date
    Jan 2012
    Posts
    15
    ok

  10. #10
    Gold Member
    Join Date
    Aug 2011
    Posts
    2517
    I sent you a PM with the info. it can not be posted here publicly. check your PMs.

  11. #11
    Registered
    Join Date
    Apr 2011
    Posts
    50

    Think were getting close....

    We can't get the control to accept the change on this bit (@&$#.#). We are setting PWE to 1 in MDI. Program project is off. Is there someting else we must do?

  12. #12
    Registered
    Join Date
    Apr 2011
    Posts
    50
    TO: fordav11 - Passwords?

  13. #13
    Gold Member
    Join Date
    Aug 2011
    Posts
    2517
    as I already said that can't be posted here. check your PMs

  14. #14
    Quote Originally Posted by fordav11 View Post
    I sent you a PM with the info. it can not be posted here publicly. check your PMs.
    Hi Fordav11,

    My parameter begin 9900 lost too. Can help to send to me? famwhaiyun@hotmail.com

    Very much appreciated.

  15. #15
    Registered
    Join Date
    Jan 2006
    Posts
    59

    Re: Parameter problems- part count not working

    Go into ladder and search for the bit F62.7, it should eventually show you the line of logic for part count display and run time.

  16. #16
    Registered
    Join Date
    Aug 2011
    Posts
    34

    Re: Parameter problems- part count not working

    Check your PM, I sent you some info

    Mike

  17. #17
    Registered
    Join Date
    Apr 2011
    Posts
    50

    Re: Fanuc 18T Param.

    I'm not sure what we ended up doing but this machine has been gone for a few years now. Thanks for the input.

  18. #18
    Registered
    Join Date
    Jan 2012
    Posts
    3

    Re: Parameter problems- part count not working

    so what was the solution please?
    i have a 21-m on a kira not showing count or cycle time....

  19. #19
    Junior Member
    Join Date
    Jan 2014
    Posts
    106
    Quote Originally Posted by fordav11 View Post
    I doubt any of those will help. even if they are all 0 it just means the part count will not count up but will just stay on 0. the problem is more likely it is not enabled in the option parameters. the clock and part count is an option......
    Jreng1982,
    What is the model of the Kira machine you have?

  20. #20
    Registered
    Join Date
    Jan 2012
    Posts
    3

    Re: Parameter problems- part count not working

    vtc 30 elite, funny thing is in the shop we have 6 of them.
    Two of them with 20-m controller cycle works but the 21-m panels don't lol.
    i'm sure its just a enable bit that needs to be turn from 0 to 1 but which one.

Page 1 of 2 12

Similar Threads

  1. Replies: 1
    Last Post: 06-21-2012, 07:09 AM
  2. Part Count
    By Jerseycnc in forum Parametric Programing
    Replies: 16
    Last Post: 03-09-2012, 04:33 PM
  3. Part Count in Fanuc 21 MB
    By M.RISHIKESH in forum Fanuc
    Replies: 1
    Last Post: 10-22-2011, 01:29 PM
  4. What is important part count or utilization
    By chrisryn in forum General MetalWork Discussion
    Replies: 31
    Last Post: 07-15-2009, 09:06 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •