535,290 active members*
2,038 visitors online*
Register for free
Login
Results 1 to 6 of 6
  1. #1
    Registered
    Join Date
    Oct 2005
    Posts
    964

    PathPilot oddities

    I have run acroos some PP oddities here. I have 2 PathPilot controllers setup. Both setup on Bridgeports running Mesa 7i80db-16 controllers and 1 has an ATC. The one without the ATC will show a toolpath on program load. The one WITH the ATC will NOT show a toolpath on program load.

    The one without the ATC will runn M98/99 subprograms just fine . The one WITH the ATC will NOT run a M98/99 subprogram it will ONLY run a oword sub call.

    Both are setup with 2.7.0 and are running as 1100 S3 config. Has anyone else run into this oddity ??

    (;-) TP

  2. #2
    Member
    Join Date
    Jun 2014
    Posts
    1649

    Re: PathPilot oddities

    a couple of oddities here with PP are when I single click on a file it loads the file, when I want to just bring up the search window, (single click is too short) also the search window times out too early and sometimes has to be brought up again.

    When loading a file from a usb stick it doesnt highlight the file just transfered, it just highlights a random file.

    When editing a file I have to make sure the correct one is highlighted, the one loaded is not the one that appears in the edit file.

    BUT I can deal with these little anomalies when I think about all the grief that Mach 3 caused me!
    mike sr

  3. #3
    Registered
    Join Date
    Nov 2007
    Posts
    2004

    Re: PathPilot oddities

    Quote Originally Posted by vmax549 View Post
    I have run acroos some PP oddities here. I have 2 PathPilot controllers setup. Both setup on Bridgeports running Mesa 7i80db-16 controllers and 1 has an ATC. The one without the ATC will show a toolpath on program load. The one WITH the ATC will NOT show a toolpath on program load.

    The one without the ATC will runn M98/99 subprograms just fine . The one WITH the ATC will NOT run a M98/99 subprogram it will ONLY run a oword sub call.

    Both are setup with 2.7.0 and are running as 1100 S3 config. Has anyone else run into this oddity ??

    (;-) TP
    This is not a trivial task, Nice work!
    Your systems sound like they are rare and an oddity.
    If that is your only problem then your golden

  4. #4
    Registered
    Join Date
    Oct 2017
    Posts
    51
    Quote Originally Posted by vmax549 View Post
    I have run acroos some PP oddities here. I have 2 PathPilot controllers setup. Both setup on Bridgeports running Mesa 7i80db-16 controllers and 1 has an ATC. The one without the ATC will show a toolpath on program load. The one WITH the ATC will NOT show a toolpath on program load.

    The one without the ATC will runn M98/99 subprograms just fine . The one WITH the ATC will NOT run a M98/99 subprogram it will ONLY run a oword sub call.

    Both are setup with 2.7.0 and are running as 1100 S3 config. Has anyone else run into this oddity ??

    (;-) TP
    I had the same issue on PathPilot HUB. See my thread below for the reply from Tormach. In summary, it's in their software and will be corrected in the next release.

    My work around is to run as an 1100M. Give that a try

    Bruce

  5. #5
    Registered
    Join Date
    Oct 2005
    Posts
    964

    Re: PathPilot oddities

    O I think I have teh toolpath on load solved. The problem came into play from teh M6 ATC code. Now there is nothing in that code that PP would need to DRAW but it expects a certain order for things to happen otherwise it will NOT draw the toolpath display on file load. Don't know why just know it is that way. I rearranged the order of teh Subprograms that run teh ATC and it works now.

    As for the M98/M99 fanuc style subs I don.t have a clue as to where to even start looking.

    (;-) TP

  6. #6
    Registered
    Join Date
    Oct 2005
    Posts
    964

    Re: PathPilot oddities

    Hi Guys I figured out teh glitch with the M98/M99 and have turned in a report to Tormach so those quirks should be good to go now.

    (;-) TP

Similar Threads

  1. PathPilot 2.x and PathPilot Simulator
    By draper-ballou in forum Tormach PathPilot™
    Replies: 117
    Last Post: 01-01-2019, 01:42 AM
  2. PathPilot® v2.1.6 Now Available
    By kstrauss in forum Tormach PathPilot™
    Replies: 0
    Last Post: 12-10-2018, 06:49 PM
  3. PathPilot fix?
    By bradlyw1 in forum Tormach Personal CNC Mill
    Replies: 2
    Last Post: 11-16-2018, 06:26 AM
  4. Replies: 2
    Last Post: 12-03-2017, 12:02 AM
  5. Toolpath oddities
    By conanh in forum LinuxCNC (formerly EMC2)
    Replies: 9
    Last Post: 07-02-2015, 09:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •