541,105 active members*
1,888 visitors online*
Register for free
Login
IndustryArena Forum > MetalWorking Machines > Cincinnati CNC > PROGRAMS GETTING CORRUPT CHARACTERS AND CONTROL SEEMS TO LAG
Results 1 to 7 of 7
  1. #1
    Registered
    Join Date
    Jun 2015
    Posts
    56

    PROGRAMS GETTING CORRUPT CHARACTERS AND CONTROL SEEMS TO LAG

    Hi Guys,

    So I just replaced the power supply (AT P/S) for the control on an Arrow 1000 , 2100 control . The machine is back running ok. I am getting some weird stuff now though. When I send a program to the machine I am getting added characters. Its usually just a few but enough to slow me down a lot and cant really leave the machine unattended because it alarms from the incorrect gcode ( thankfullly it doesnt crash like a fanuc would ) . Also , the control is slower than usual and some menu buttons dont work if I have the spindle running. As soon as I shut the spindle off I get full control of the menus again. Weird .
    Somehow , I believe I have some interference from somewhere. Any ideas as to what this sounds like it could be ? I am going to maybe reseat the board and replug the peripherals and see if that helps. Any other suggestions are appreciated. Thanks

  2. #2
    Registered
    Join Date
    Jun 2015
    Posts
    56

    Re: PROGRAMS GETTING CORRUPT CHARACTERS AND CONTROL SEEMS TO LAG

    Update.. I did the whole unplug , replug thing and it still has problems with corrupt characters in the program and loss of control function buttons when the spindle is running. So there is a detail that I didnt mention previously. The OEM P/S is 230 watts (AT) . I had found a thread on here that it is better to get a larger wattage p/s , So I got a 400watt model. I was under the impression that the boards would only pull what they needed , I also thought the Hard drive would only pull what it needed. Now I am not so sure . Does anybody have any experience with this stuff ?

    Side note - Due to the corrupt gcode characters and the huge length of programs I usually have , I was trying to run the part plotter to basically test all the code for errors . Does anyone know if this is possible ? I dont have an operators manual and the one that used to be online has been taken down.

    Thanks for the help

  3. #3
    Registered
    Join Date
    Jun 2015
    Posts
    56

    Re: PROGRAMS GETTING CORRUPT CHARACTERS AND CONTROL SEEMS TO LAG

    Update ... I found and downloaded the operators manual - Still dont know if the plotter would help or if dry run would be faster. Would rather not have anything move, just want to test the program for errors.

  4. #4
    Registered
    Join Date
    Dec 2006
    Posts
    537

    Re: PROGRAMS GETTING CORRUPT CHARACTERS AND CONTROL SEEMS TO LAG

    You may have purchased a China made piece of junk power supply, if it is a 400W AT power supply it most likely came from China. You should buy a brand name ATX power supply and add a plug converter that goes from ATX to AT (P8, P9 ). The junk China power supplies can cause major problems with your A2100 control and result in a hard drive crash. I have seen it happen several times.

    MIKE CNC Machine Services INC | Cincinnati Milacron MachinesCNC Machine Services

  5. #5
    Registered
    Join Date
    Jun 2015
    Posts
    56

    Re: PROGRAMS GETTING CORRUPT CHARACTERS AND CONTROL SEEMS TO LAG

    Thanks for the reply. I also purchased a name brand ATX p/s with the converter cable. Problem I found is that there is no output plug from the p/s to the op panel. How do I get the power to the op panel ?

  6. #6
    Registered
    Join Date
    Dec 2006
    Posts
    537

    Re: PROGRAMS GETTING CORRUPT CHARACTERS AND CONTROL SEEMS TO LAG

    You can purchase a splitter for that on line

    MIKE CNC Machine Services INC | Cincinnati Milacron MachinesCNC Machine Services

  7. #7
    Member
    Join Date
    Mar 2008
    Posts
    90

    Re: PROGRAMS GETTING CORRUPT CHARACTERS AND CONTROL SEEMS TO LAG

    RS232 cable should be less than 50ft and shielded. Are you using Ctrl On/Off, have you tied to slow down the baud rates? A bad PC-Keyboard can pull down the +5V logic power and create all kinds of havoc...

Similar Threads

  1. Corrupt programs?
    By Most in forum Haas Mills
    Replies: 18
    Last Post: 04-03-2014, 01:22 PM
  2. Replies: 2
    Last Post: 12-20-2010, 12:39 AM
  3. Corrupt Programs after editing
    By BrianS. in forum General CNC (Mill / Lathe) Control Software (NC)
    Replies: 2
    Last Post: 07-29-2010, 07:25 AM
  4. VF2 Random Characters on Control
    By rrbmachining in forum Haas Mills
    Replies: 0
    Last Post: 09-09-2009, 05:31 PM
  5. VF-4 Control computer repeating characters
    By Drkk in forum Haas Mills
    Replies: 5
    Last Post: 11-02-2005, 05:32 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •