523,928 active members*
2,607 visitors online*
Register for free
Login
Results 1 to 7 of 7
  1. #1
    Registered
    Join Date
    Nov 2010
    Posts
    0

    M500 locked up - no keys function

    Hello,

    I have a FCA520MT control that will not communicate with the display. I get the Mitsibishi logo on the display but none of the keys function and no beeps are sounded when keys are pressed.
    On my QX521 card the SD LED doesn't light and on the display board RD doesn't light and MON blinks.
    I know that the problem is somewhere on the QX141-1 card because i swapped it and it worked for a few days before that one stopped working. Also the QX721 attached to the QX141-1 has LED2 on which i believe is a software error.

    Any help with troubleshooting this would be greatly appreciated.

    Thanks,

  2. #2
    Registered
    Join Date
    Nov 2010
    Posts
    0
    Really!!! No one even has any suggestions on what i can do to figure this out. That sucks......

  3. #3
    Registered
    Join Date
    Oct 2010
    Posts
    0
    Hi,
    Please try to measure the backup battery ( when machine is off) should be 3.0 VDC any below 2.4 VDC is bad!
    I have a similar problem right now and troubleshooting it. Customer told me that if turns machine on and off then sometimes starts. Let you know in a few days.

  4. #4
    Registered
    Join Date
    Nov 2010
    Posts
    0
    Hello Pocok,

    Did you ever have any luck in repairing your unit?

    Mine has the 3.0v All of this happened i believe when an incorrect spindle encoder cable was hooked into the spindle drive. "on both occasions."

  5. #5
    Registered
    Join Date
    Nov 2010
    Posts
    0

    FCA520MT LOCKED UP.

    Can anyone help with this. I repaired my problem i had previously by replacing the QX141-1 and QX721 boards. It worked fine for a long time and now that i am trying to add a spindle again my buttons on the front panel locked up and no longer work. "See my below post for a description of what it is doing"

    What i have is a FCA520MT control with a single axis setup on a test bench. I have tried to configure a spindle into the system unsuccessfully. It locked up this time when i removed the cables from the servos cn1 connector and wired only the spindle cn1a to the control and the terminator on cn1b. I also change "sysnu" for my servo axis to a 0 to eliminate it from the system. When i powered back up my display comes on but none of my keys function and the receive and transmit lights on the control and the back of the display board don't flash.

  6. #6
    Registered
    Join Date
    Feb 2012
    Posts
    0
    Hi ,
    I have a similar control & 9" screen . yours problem is with the QX084 power supply .
    The 24VDC from the power supply from the CPD06 is not connected or broken wire or damaged power supply. yours AC input is right , otherwise you do not have a LOGO screen either. Any question , please call at 416-274-3892 .

  7. #7
    Registered
    Join Date
    Jul 2017
    Posts
    1
    Quote Originally Posted by db3637 View Post
    Hi ,
    I have a similar control & 9" screen . yours problem is with the QX084 power supply .
    The 24VDC from the power supply from the CPD06 is not connected or broken wire or damaged power supply. yours AC input is right , otherwise you do not have a LOGO screen either. Any question , please call at 416-274-3892 .


    Dear I have same problem that CRT shows logo in initial then goes blank and none of the keys on control panel works..
    Kindly guide me
    Can have your WhatsApp number??

Similar Threads

  1. Need instructions m500
    By Shade in forum Redsail Laser
    Replies: 5
    Last Post: 02-01-2013, 11:01 AM
  2. Help on Red Sail M500
    By eshko22 in forum Redsail Laser
    Replies: 10
    Last Post: 12-13-2012, 02:26 AM
  3. M500 question
    By botha.y in forum Mazak, Mitsubishi, Mazatrol
    Replies: 0
    Last Post: 10-16-2012, 08:13 PM
  4. Replies: 3
    Last Post: 05-14-2010, 09:16 AM
  5. Edit function locked?
    By DDLES in forum Haas Mills
    Replies: 1
    Last Post: 01-09-2010, 10:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •