509,658 active members
3,926 visitors online
Register for free
Login
IndustryArena Forum > Machine Controllers Software and Solutions > Fanuc > Fanuc 6T alarm 212 strange problem
Results 1 to 6 of 6
  1. #1
    Registered
    Join Date
    Sep 2006
    Posts
    293

    Fanuc 6T alarm 212 strange problem

    Have a Fanuc 6T on an old Hitachi Seike lathe. I had to reinitialize the bubble memory board the other day and then reset the parameters and settings. Afterwards everything looks right except when i home the machine out on X axis it gives up a 212 alarm "has entered the forbidden zone of stroke limit". It moves away from home position fine, and when i set it to home and try to home it moves to the point where it slows down and just as it would normally stop at home and home out it throws up the alarm. Z axis does exactly the same thing but gives a different alarm number.

    I set all soft limit parameters to 99999999 and -99999999 and it still does it. No matter what i set the soft limits to nothing changes. What am i missing?

  2. #2
    Registered
    Join Date
    Jun 2004
    Posts
    511

    Fanuc service hot line

    1-888-326-8287
    They know alot!
    You may be hold for a bit, but they know controls well.

  3. #3
    Registered
    Join Date
    Oct 2009
    Posts
    192
    Quote Originally Posted by GITRDUN View Post
    Have a Fanuc 6T on an old Hitachi Seike lathe. I had to reinitialize the bubble memory board the other day and then reset the parameters and settings. Afterwards everything looks right except when i home the machine out on X axis it gives up a 212 alarm "has entered the forbidden zone of stroke limit". It moves away from home position fine, and when i set it to home and try to home it moves to the point where it slows down and just as it would normally stop at home and home out it throws up the alarm. Z axis does exactly the same thing but gives a different alarm number.

    I set all soft limit parameters to 99999999 and -99999999 and it still does it. No matter what i set the soft limits to nothing changes. What am i missing?
    Try with 99999998 or -99999998
    Regards
    Alex

  4. #4
    Registered
    Join Date
    Sep 2006
    Posts
    293
    I tried setting to 99999998 and -99999998, same results. Guess i will call the Fanuc number above and see if they can help. I dont have much luck when calling the mfg's on older machines. The technicians reply is usually something like we dont have any documentation on controls that old and ive never worked on one of those before. Maybe Fanuc will be more helpful.

  5. #5
    Registered
    Join Date
    Sep 2006
    Posts
    293
    Talked with a Fanuc tech. He had me try the same things i had already tried such as setting soft limits to all 9's and - 9's. In the end he couldnt understand it either. I reinitialized the board again thinking i might have done something wrong. After reinstalling the parameters i still have the same issue. I can get it to not alarm out when homing if i turn off the parameter which allows the machine to return to reference with a G28. But then i cant use G28 in programming. I can work around that i guess if i have to but id rather have it working as it should. Im stumped.

  6. #6
    Registered
    Join Date
    Sep 2006
    Posts
    293
    Ok finally got that mess resolved. Heres what i had to do. First i set all soft limits to +99999999 and -99999999 respectively. Then home the machine out. Instead of a 212 alarm it would then give a 214 alarm which is soft limit 2 or 3 alarm. Then i set all soft limits 2 and 3 to their original settings but left limit 1's to the 99999999 settings. After that it homes fine with no problems. If i put the soft limit 1's back to their settings it goes back to 212 alarm. So im leaving it alone and running with it.

    No i just have to get the RS232 settings figured out. But thats for another post.

Similar Threads

  1. Fanuc OM-D 003 P/S Alarm problem
    By chris661 in forum Fanuc
    Replies: 5
    Last Post: 12-03-2011, 01:16 AM
  2. Strange Alarm
    By Patriot Jon in forum Mazak, Mitsubishi, Mazatrol
    Replies: 2
    Last Post: 07-13-2011, 03:31 AM
  3. Strange problem with Mori AW22 / Fanuc 0T
    By emexcee380 in forum Mori Seiki lathes
    Replies: 3
    Last Post: 05-04-2011, 07:46 PM
  4. strange 021 alarm -OMC
    By OC_ in forum General CNC (Mill / Lathe) Control Software (NC)
    Replies: 1
    Last Post: 01-22-2008, 03:09 AM
  5. Strange Fanuc battery problem
    By timlkallam in forum Fanuc
    Replies: 0
    Last Post: 11-23-2007, 04:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •