512,711 active members
4,199 visitors online
Register for free
Login
Results 1 to 6 of 6
  1. #1
    mjscottinnc
    Guest

    Existing ZX-45 conversion

    I recently purchased a ZX-45 conversion (Actually ZX-7045) and the Z axis is for crap and I'm wondering how to solve the problem. First what is wrong... moving the Z always causes the servo driver to fault, oh it moves but it starts out smooth (short period of time - a second or two) and when ka-chunks its way along faulting with each ka-chunk. It does this in both directions.

    Servo driver is Gecko G-320, Motor is Reliance E660 1/4 HP (660 oz-in), encoder is US digital 250 PPR, Servo voltage is 60 VDC, Servo sprocket to lead screw sprocket is 1:2 - 1/2" timing belt, lead screw appears to be the original from the manual machine, Software is Mach3 with 33,000 pulse rate.

    I'm making the assumption that since it starts out ok, but faults when the speed picks up that it can not handle the pulse rate (acceleration). Originally the encoder was on the lead screw shaft, but it was also previously on the motor since a housing is still attached to the bottom the motor. I moved the encoder to the motor and I still get the problem and it has improved, but it still isn't 'right'. I can not find enough information on the motor to calculate what the encoder PPR should be. I can get it to move without faulting using a very very low speed and with that the ka-chunks turn into hick-ups.

    When I hand turn the Z lead screw by hand it is smooth in both directions, but require much more force to raise the head (not unexpected - gravity you know), I'm wondering if the motor is undersized, if the sprocket ratio is too small, should I check the servo and add a stepper, etc.

    Any suggestions from working ZX-45 conversions?

  2. #2
    zamazz
    Guest
    1/4 horsepower is what, just under 200W? I would say this is the problem, especially with 2:1 reduction and no counterweight on the head. I'd say increase your ratio or counterweight the head. Some gas struts from McMaster would be the easiest, cheapest route.

  3. #3
    ninefinger
    Guest
    A couple of things:
    1. Original lead screw - this will add alot of friction compared to a ballscrew - this will make any issue with servo size and reduction ratio worse
    2. How tight are the gibs on the Z-slide?
    3. The servos will fault when they are X number of counts behind where its supposed to be - so depending on how "tight" or "loose" the settings on the servo drive are you might get quite a bit of motion before the servo falls to far behind and faults. Backlash in the leadcrew / nut could be a problem too.

    Assuming (a dangerous thing) that it worked before you acquired it - here are some things to try:
    Loosen the gibs to see if the problem gets better,
    The motor doesn't matter when it comes to the encoder - its all a configuration thing. 250 PPR is 1000 steps in quadrature - trying to remember the Z-axis pitch but guessing it was ~ 0.1" / rev - check your steps per inch - should be ~ 10,000 with the encoder on the leadscrew or ~20,000 with it on the motor. Did you have to setup Mach yourself or was it supplied setup on a PC?
    I don't use the Gecko servo drives so can't help you figure their setup - I'm sure somebody else can (once they get past the new changes to the zone).

    Mike

  4. #4
    mjscottinnc
    Guest

    More Info

    Sorry, forgot to mention the gas struts, they are there and seem to be working. If I recall ¼ HP is about 186 watts. Mach3 was already setup for the mill when I purchased, (computer and all) I was a bit surprised to see the original lead screw as well, even to the extent that the bottom of the lead screw (toward the base) is not attached to anything (hand crank and bearings removed), the lead screw is just hanging down the column. I’ve tried both 10,000 and 20,000 counts per inch and it doesn’t seem to make a difference. I’ll loosen and see what the results are and report back.

    Thanks for the suggestions.

  5. #5
    mjscottinnc
    Guest
    The gibs were completely backed out, I hand tighten them to make contact. Same result. I also measured the pitch of the lead screw, it is .185". I have a new encoder coming tomorrow and will replace that to eliminate it as a possibility. I’m also thinking about upping the sprocket ratio to 2.5 or 3.

  6. #6
    Neuer Benutzer
    Join Date
    Mar 2013
    Posts
    0
    Thanks everyone for the help. Put a new encoder in and poof everything is working just the way you would expect. Must have been some kind of flaw on the interrupter that could not be seen. BTW, you have just got to love those CUI encoders with selectable resolution.

Similar Threads

  1. Modify existing driver?
    By Mike Hall in forum Maintenance DIY Discussion
    Replies: 0
    Last Post: 11-26-2011, 04:53 PM
  2. Revamp Existing Machine
    By NetStorm in forum CNC Wire Foam Cutter Machines
    Replies: 3
    Last Post: 08-04-2011, 08:11 PM
  3. Add Photos to Existing Portfolio
    By coykiesaol in forum Autodesk
    Replies: 0
    Last Post: 11-30-2010, 08:23 AM
  4. EMC and existing hardware/electronics
    By beege in forum LinuxCNC (formerly EMC2)
    Replies: 4
    Last Post: 03-02-2008, 02:55 AM
  5. X-Y CNC with existing leadscrews?
    By cyclestart in forum Benchtop Machines
    Replies: 2
    Last Post: 05-29-2007, 02:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •