508,289 active members
2,929 visitors online
Register for free
Login
IndustryArena Forum > CNC Electronics > Leadshine > ES-DH2306 Tuning Issue
Page 1 of 2 12
Results 1 to 12 of 19
  1. #1
    Registered
    Join Date
    Dec 2010
    Posts
    70

    Exclamation ES-DH2306 Tuning Issue

    Hello,

    I just bought some ES-DH2306 Leadshine drivers, paired with ES-MH342200
    The problem is I cannot connect it to the PC for tuning with ProTuner v1.3 software (from 3 different sources, minor differences, same result)

    When I want to open the connection I get "Unknow drive" error message, followed by "Communication fail! Please check he drive and the connections." error message

    The tuning cable used is provided by the seller, RS232 type
    I already tried almost all serial port's configurations. I tried to run it on XP/32 and W7/64, always same result (Unknown drive)

    I also sent an email to the Leadshine Tech Department but a very kind autoresponder told me they are in holliday until 27 of February....

    Can somebody to guide me into some useful direction?

    Kind regards,
    Seb
    HTM.Ro - Hobby Tools Manufacturing

  2. #2
    Registered
    Join Date
    Dec 2010
    Posts
    70

    Re: ES-DH2306 Tuning Issue

    Hello,

    The provider told me there is a problem with the application itself but for some other customers this issue was solved by using an USB2Serial adapter...
    Right now I don't have the adapter but this answer lead me to another question:

    leadshine mark one of Firewire connector's pin as +5v and the driver does not provide this +5v on that pin.
    Also, tha com port don't have +5v

    My question is: an usb adapter can provide 5v for the driver and make it to work?
    The strange thing is I have a negative (-) 3v on that pin (from driver)

    Thanks
    HTM.Ro - Hobby Tools Manufacturing

  3. #3
    Registered
    Join Date
    Dec 2010
    Posts
    70

    Re: ES-DH2306 Tuning Issue

    I tried to use an USB adapter, nothing changes, the ProTuner software still show the "Unknown drive" error...
    HTM.Ro - Hobby Tools Manufacturing

  4. #4
    Registered
    Join Date
    Jun 2013
    Posts
    4

    Re: ES-DH2306 Tuning Issue

    I also bought Leadshine closed-loop stepper, HBS507 + 573HBM20-1000 and having some issue with driver.
    Holding torque is not what I was expected, I think it is 40% of full load and it draws 0.21A with no load but when I try rotate motor shaft with hand, driver does not increase power and it is easy to loose holding position. With more force on shaft, motor loose a big step and having jerk motion. I tested encoder with an oscilloscope and I'm getting pulses when I try rotate shaft, so driver knows that position is not right but not respond on that.

    I cannot find ProTuner for HBS series but I tried ProTuner for ES series and get error on connecting to drive, maybe software version is problem !?

    Marijan

  5. #5
    Registered
    Join Date
    Feb 2012
    Posts
    32
    Anyone get this to work?
    I'm having the same problem: "unknown drive".
    HBS86H drive from Leadshine, Windows 10.


    I'm using a USB adapter and tuner cable from supplier.

  6. #6

    Re: ES-DH2306 Tuning Issue

    I've been having the same "Unknown Drive" issue with my ES-DH2306 drives purchased directly from Leadshine USA. The cable I first encountered the issue with was from Leadshine USA. After trying several operating systems & multiple PC's i tried several Serial and serial to USB cables, all with the same issue. I contacted Leadshine requesting support. After weeks of communication with USA & factory support in China, I was told a Digital Signature verification was added after my drives were produced. To work around this issue Leadshine said I needed V1.00 of the Protuner software. Leadshine has evidently archived the previous versions so they are no longer available. Leadshine USA's position with my drives is: They are now 16 months old and they do not feel obligated to update or replace them so the Protuner sofware can be accessed and there is no provision to update the firmware. Bottom line, it appears they are not willing to stand behind their products and provide advertised features that should be available.

  7. #7
    Registered
    Join Date
    Jun 2016
    Posts
    4

    Re: ES-DH2306 Tuning Issue

    Hi everyone.
    I have that problem, too. I have not been able to fix it.
    So, someone have a solution ?

  8. #8
    Neuer Benutzer
    Join Date
    Feb 2013
    Posts
    19

    Re: ES-DH2306 Tuning Issue

    I am about to start tuning mine.

    I have the HBS 2206 which is supposedly identical to the 2306 version.

    If you look up the Choosing Protune driver pdf (attached ) it states to use ProTuner_iES_iST_Setup_2013-10-14 driver for my driver set the ....MS11A series.

    The issue I have is that the port for the driver is a Firewire port and I think I need a USB firewire cable is that not correct. I am having trouble finding one in my area.

  9. #9
    Member
    Join Date
    Jun 2016
    Posts
    80

    Re: ES-DH2306 Tuning Issue

    Sorry for being so late, but hopefully this might help out others who are having trouble connecting to Leadshine type closed loop stepper drives.

    I had this same problem with the "Unknown Drive" error with some HBS86H drives a few months ago. (I think it actually says "Unrecognized Model" but this might depend on the software version.) I eventually discovered that if I plug the drive into COM1 on my computer and select COM1 in the software I get the "Unknown Drive" error, but if I select, for example, COM8 in the software and leave the drive connected to COM1 it works fine. There are 10 COM port choices in ProTuner and the one I have to select to get it to recognize the drive seems to very from drive to drive and day to day, but usually it is one of the higher numbers ports. I just try all the ports until I find the one that works.

    I only have four COM ports on my computer, so it took me a long time to figure this out as I did not think about selecting the higher number ports listed in ProTuner.

    I would be curious to know if this solution works for anybody else who it having problems connecting to their drives, or if my problem is unrelated.

    Kurt

  10. #10
    Member
    Join Date
    Jun 2016
    Posts
    80

    Re: ES-DH2306 Tuning Issue

    GusBiz,
    Don't know that drive you have but I am pretty sure the port is an RJ11, which looks similar to an Ethernet or Firewire port which is an RJ45. The main differance being the number of connectors, 8 for RJ45 vs. 4 for RJ11, but don't quote me on that.

    The drive almost certainly talks to the PC via RS323 serial communications, not Ethernet or Firewire. If you don't have a serial port on you computer you can purchase a USB to RS232 adapter quite cheaply. Read the reviews, some are not any good.

    Once you have a serial port you will need to make an adapter with a RJ11 on one end for the drive and a female 9 pin D-Sub on the other end to connect to the serial port.
    The pinout for the RJ11 port should be printed on the drive or at the very least found in the manual. Look up the pinout for the serial connector and connect the corresponding wires form the RJ11 end and you should be good to go.

    Hope that makes some sort of sense. Let us know how it goes.

    Kurt

  11. #11
    Registered
    Join Date
    May 2012
    Posts
    3

    Re: ES-DH2306 Tuning Issue

    Quote Originally Posted by mjakara View Post
    I also bought Leadshine closed-loop stepper, HBS507 + 573HBM20-1000 and having some issue with driver.
    Holding torque is not what I was expected, I think it is 40% of full load and it draws 0.21A with no load but when I try rotate motor shaft with hand, driver does not increase power and it is easy to loose holding position. With more force on shaft, motor loose a big step and having jerk motion. I tested encoder with an oscilloscope and I'm getting pulses when I try rotate shaft, so driver knows that position is not right but not respond on that.

    I cannot find ProTuner for HBS series but I tried ProTuner for ES series and get error on connecting to drive, maybe software version is problem !?

    Marijan
    Did you ever get the holding torque load changed. I think I have a similar issue. The motors don't have any warmth to them at all from holding amps and I can rotate it slightly with my hand. Just enough to see movement which would cause backlash.

    Sent from my SM-G920P using Tapatalk

  12. #12
    Registered
    Join Date
    Sep 2017
    Posts
    2

    Re: ES-DH2306 Tuning Issue

    Hi all,
    I am experiencing the same issue with another driver provided by leadshine: HBS1108S
    I have downloaded the ProTuner Ver 1.3 which is the last one, and installed it on my laptop running on Windows 10.
    I am using 2 cables to connect the firewire port of the driver to my USB port of my laptop.
    One firewire to RS232 as shown below:

    And one USB to RS-232 DB9 Serial fom UGREEN for connecting to my laptop.

    When I started ProTuner, I tested all COM ports but only one was providing a different error message, and looking at my settings, it looked consistent with the COM7 mentioned in the device information:



    Nevertheless, I am still not able to connect to the driver and always get the following error message:



    I also tried another driver version with no success, and also tried with an old laptop running on Windows 7 but no success neither :-(

    I sent a mail to Leadshine to get some help but not sure if a feedback will come

    Any help or suggestion are welcome!
    thanks

Page 1 of 2 12

Similar Threads

  1. G320 motor tuning issue with Fluke 124 scope
    By turbotoys in forum Gecko Drives
    Replies: 1
    Last Post: 12-16-2013, 11:54 PM
  2. G540 Motor Tuning Issue
    By csdisme in forum Gecko Drives
    Replies: 3
    Last Post: 07-26-2012, 01:54 AM
  3. Cambam issue or Mach 3 Issue??
    By tracyranson in forum CamBam
    Replies: 11
    Last Post: 07-11-2011, 04:03 PM
  4. Tuning motors issue
    By BrassBuilder in forum Benchtop Machines
    Replies: 1
    Last Post: 12-03-2010, 07:11 PM
  5. Help with selector switch wiring issue (***actually a motor issue***)
    By BEDFORD in forum Charter Oak Automation Support Forum
    Replies: 7
    Last Post: 04-07-2006, 09:19 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •