510,116 active members
4,040 visitors online
Register for free
Login
IndustryArena Forum > Other Machines > MicroMill > Z axis getting stuck
Results 1 to 5 of 5
  1. #1
    Registered
    Join Date
    Sep 2017
    Posts
    2

    Z axis getting stuck

    When trying out the GRBLpanel tutorial I encountered a problem with the Z-axis gantry getting stuck. When jogging it would seize with the screw not turning. Jogging it back and forward again would enable it to move past the point seized.

    Adding silicone lubricant to the guiderods seems to have helped a little but it is still getting stuck with the motor making an awful noise. There seems to also appear black powder (guessing the core material of the boards) on top of the gantry when this happens, so I'm wondering if the plastic bit on top of the lead screw is getting stuck in its hole.

    Any suggestions for fixing the issue? Also, how would one go about in replacing the Z-axis motor if/when it'll need replacing?

    Thanks.



  2. #2

    Re: Z axis getting stuck

    Ah! This is a known issue - unfortunately it was only discovered once the Tier2 machines had been dispatched. This should in no way apply to all Tier2 MicroMills, but clearly a handful have developed the issue.

    The problem is not any binding of the rails - which is what we had assumed initially - it is loose coupling grub screws. These have come loose - and are catching on the body panels that mount the motor.

    If you have a 2.5mm allen key, you can unscrew the Z motor from the underside, lift it up and retighten these screws. We found applying a bit of electrical tape around the coupling will ensure they cant come loose again. (loctite can also be used)

    https://www.kickstarter.com/projects.../posts/1981811

    Sorry that this has happened, but at least its an easy fix!

  3. #3
    Registered
    Join Date
    Sep 2017
    Posts
    2

    Re: Z axis getting stuck

    That was indeed the issue; one of the grub screws holding the leadscrew had backed out. Tightening it fixed the issue and I could finish my first carving. Thanks.

    There seems to still be some "sticktivity" in the Z-axis e.g. jogging down 0.1mm will take a couple jogs before it moves. Is this something that will correct itself when the mill gets run in or is there something that should be done about the issue.

  4. #4

    Re: Z axis getting stuck

    This may well sort itself over time, but its most likely as a result of stretching in the same coupling. When you re-tightened the grub screws, did you check the lead screw was fully inserted so it butts up agains the shaft of the motor inside the coupling?

    If everything lines up and you still get the bellowing effect, the application of electrical tape around the outside of the coupling will not only ensure the grub screws stay in, but also give some extra support and rigidity to the coupling to prevent this from happening.

    Hopefully that'll be the end of it!

    If it is the bellowing of the coupling, its going to be fairly consistent so shouldn't effect the performance of the MicroMill. You may want to increase the step-over value by 0.5mm or so just to ensure that 'stretch' is accounted for.

  5. #5
    Registered
    Join Date
    Sep 2017
    Posts
    3

    Re: Z axis getting stuck

    Well, that was hard to get to! I also had this issue, on top of a side panel that didn't fit (sorted) and a snap in the side (haven't fixed that yet) it's been a bit stressful.
    But, I got there. So, thanks for this thread.
    Finally did a test piece.
    https://imgur.com/a/KH0YZ

Similar Threads

  1. Need help with stuck Z Axis on QD6090 CNC - Please!
    By Aladdin of Canb in forum Chinese Machines
    Replies: 1
    Last Post: 07-08-2014, 11:59 PM
  2. Fanuc Oi MD Z Axis Stuck
    By ckkungu in forum Fanuc
    Replies: 5
    Last Post: 05-06-2014, 02:15 PM
  3. Bridgeport Series 1 CNC Z axis stuck
    By ross33912 in forum Bridgeport / Hardinge Mills
    Replies: 6
    Last Post: 02-07-2013, 05:37 AM
  4. Stuck X axis on a maxnc
    By bean7795 in forum Benchtop Machines
    Replies: 6
    Last Post: 06-19-2011, 04:29 PM
  5. bridgeport cnc x axis stuck
    By troysk8 in forum Bridgeport / Hardinge Mills
    Replies: 3
    Last Post: 02-27-2011, 06:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •