510,039 active members
2,629 visitors online
Register for free
Login
IndustryArena Forum > Machine Controllers Software and Solutions > Controller Cards > XHC-MKX-IV Rev 5 issue controlling laser, JTechPhotonics Driver and PicConvert (DAC)
Results 1 to 2 of 2
  1. #1
    Registered
    Join Date
    Sep 2005
    Posts
    353

    XHC-MKX-IV Rev 5 issue controlling laser, JTechPhotonics Driver and PicConvert (DAC)

    The boards are all successfully talking to each other, well sorta.

    I have an oddity with the XHC and the spindle output controlling the on/off of the laser itself. As a safety feature of the PicConvert board, I've wired from the XHC's Spindle Output#1 to the PicConvert Board input for enabling the laser only when a call is made from within the Gcode for an M03. I just happened to discover that issuing an M03 (normal start of the spindle) actually turns the laser OFF instead of ON. And M05 (normal stop) actually does the opposite.

    I'm using Mach3 and I've unchecked and checked active low / active high for Spindle Output, OutPut #1, etc. to no avail.

    For now I've swapped the M03 with an M05 at the start of the GCode and vice versa at the end of the file. Terrible workaround!

    This means I have to make sure the spindle start command has been invoked BEFORE I turn on the laser. The Spindle has been removed and I've built a drop in laser attachment in its place. This way I can carve as needed then remove the spindle and start laser engraving the work-piece.

    I haven't crossed swapped the wiring and don't want to do that, i.e., positive to negative. I have the positive out from the XHC going to the positive in to the PicConvert.

    I tried other outputs on the XHC and made matching changes in Mach3 for those outputs on the spindle setup tab. I was unable to measure any appreciable voltage changes on those outputs when calling for an M03 or M05. Only Output #1 will work. However, I also discovered that I need to have power switched on to the VFD for the output #1 to enable the PicConvert to send signal to the laser via the JTechPhotonics driver.

    The issue lies in the XHC-MKX-IV Rev5 board.

    Has anyone seen this before or could give suggestions on how to make it more conventional?
    I haven't even gotten to the M11P1 (ON) and M10P1 (OFF) yet.

  2. #2
    Did you ever get this resolved? I'm trying to get a laser going in my mkx-iv USB and I'm not getting anywhere.

Similar Threads

  1. Controlling Automated Laser Ablation Machine
    By Dolan in forum Laser Control Software
    Replies: 1
    Last Post: 04-23-2019, 12:30 AM
  2. Issue with microstep driver (Z axis)
    By ZedWings in forum Laser Hardware
    Replies: 7
    Last Post: 03-23-2017, 05:58 PM
  3. PMDX-126 with jtechphotonics DAC PWM
    By Bx3mE in forum Controller Cards
    Replies: 1
    Last Post: 10-06-2015, 11:07 AM
  4. controlling chinese laser power supply
    By dominicburke200 in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 8
    Last Post: 07-02-2014, 10:34 PM
  5. Controlling Stepper motor driver boards
    By scarr in forum General CNC (Mill / Lathe) Control Software (NC)
    Replies: 4
    Last Post: 01-28-2006, 03:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •