515,623 active members
6,349 visitors online
Register for free
Login
Results 1 to 4 of 4
  1. #1
    Registered
    Join Date
    Apr 2018
    Posts
    2

    Exclamation G0704 Z axis trouble

    Hello friends,
    I've been busy converting a G0704 to CNC, and I've run into my first real issue. The scenario is this. I zero the z axis in g54, command a g00 z-1.0, the head moves exactly one inch down. However, I then enter a g00 z0.0 and the head moves up by aprox .960". Soooooo, I reenter the g00 z-1.0, the head moves back to exactly one inch below the g54 offset... I don't suspect backlash here, because the repeatability in negative travel. Any ideas??

    PS I'm using Mach 3, and NEMA 34 steppers with 5mm pitch TBI ball screws.

  2. #2
    *Registered User*
    Join Date
    Apr 2018
    Posts
    34

    Re: G0704 Z axis trouble

    try moving the z with a slow feed rate... say 5 ipm.

    and back.

    if it hold position, maybe your stepper is losing step.

    mayb also try purposely entering a zero in the backlash in mach3, if it happens to be blank.

  3. #3
    Registered
    Join Date
    Apr 2018
    Posts
    2

    Re: G0704 Z axis trouble

    Ok, I just gave it a try... Same result... I also played around with the MPG. The DRO always matches my indicator dead nuts, whenever I make a negative z move. Any positive jog, and the indicator never registers as much travel as the DRO.... But again, even after that, any Z negative move will sync the indicator and DRO back together. Bad Stepper???

  4. #4
    *Registered User*
    Join Date
    Apr 2018
    Posts
    34

    Re: G0704 Z axis trouble

    hmmm...

    I think I would try swapping the z axis motor with one of the other axis motors...see if the problem follows the motor or stays with the Z.

    If it follows the motor, you know its replacement time.

    If it stays on the Z axis, keep searching there. Look for mechanical backlash first - I presume you've already done that.

    I would swap the Z stepper driver with another axis next...see if it follows the driver.

    If the problem stays on the Z, then you either have a breakout board issue or mach issue.

Similar Threads

  1. Trouble cutting circles. Trouble with y-axis
    By chrisv7 in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 2
    Last Post: 06-08-2016, 09:43 PM
  2. G0704 4 Axis CNC....
    By j.steensen in forum Benchtop Machines
    Replies: 4
    Last Post: 05-12-2015, 03:30 AM
  3. Having trouble getting the backlash out of my G0704's X axis
    By Hypnotoad in forum Benchtop Machines
    Replies: 2
    Last Post: 04-12-2015, 03:10 AM
  4. 4th Axis for G0704
    By Potatohead908 in forum Benchtop Machines
    Replies: 16
    Last Post: 01-23-2015, 01:20 PM
  5. G0704 5th axis
    By outsider787 in forum Benchtop Machines
    Replies: 4
    Last Post: 12-14-2012, 01:04 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •