517,644 active members
2,916 visitors online
Register for free
Login

Thread: G320X Users

Results 1 to 2 of 2
  1. #1
    Registered
    Join Date
    Oct 2008
    Posts
    1972

    G320X Users

    Ok, who has G320X drives that have been in service (used atleast a couple times a week) for more than a couple years?

    What voltage and current are you run through them?

    Did you install that dump circuit that GeckDrive suggests you build and install?

    Are they still performing the same as when you first installed them?
    Bob La Londe
    http://www.YumaBassMan.com

  2. #2
    Registered
    Join Date
    Dec 2017
    Posts
    9

    Re: G320X Users

    I use them to drive a couple of fanuc 5m and one 10m fanuc dc servos for one and a half year whitout any problem on the drives, using non regulated 63 VDC supply, current setting 90% of the max. Encoders are the amt´s 102 v, not using dump circuit, max rapids 180 ipm. Machine is an old Bridgeport VMC 520. The only change i need to made was install linuxcnc in replacement of mach 3 . Never got to tune mach3 for real reliability when i ran the machine few hours whitout stop. Until now the drives perform rock solid.

Similar Threads

  1. G320X Tuning..
    By lancut in forum Gecko Drives
    Replies: 1
    Last Post: 01-31-2017, 04:32 PM
  2. G320X problem
    By CS900 in forum Gecko Drives
    Replies: 1
    Last Post: 06-21-2013, 12:35 AM
  3. G320X MANUAL
    By mayo in forum Gecko Drives
    Replies: 0
    Last Post: 04-27-2013, 04:51 AM
  4. Another G320X question
    By w7bcw in forum Gecko Drives
    Replies: 0
    Last Post: 04-03-2013, 08:14 PM
  5. G320X PID
    By w7bcw in forum Gecko Drives
    Replies: 1
    Last Post: 04-03-2013, 03:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •