508,124 active members
3,352 visitors online
Register for free
Login
IndustryArena Forum > Community Club House > General Off Topic Discussions > Mach3 Function wizards Lathe threading REV 1.17 Problem . Help me please.
Results 1 to 6 of 6
  1. #1
    Registered
    Join Date
    Jun 2016
    Posts
    2

    Mach3 Function wizards Lathe threading REV 1.17 Problem . Help me please.

    Hi
    I'm DIY CNC Lathe use BOB Mach3 Parrarel port

    I connect Proximity and config to index mach3

    I test run put parameter spindle 300 rpm, and Strue show about 303 - 307 rpm

    I try use wizards threading in mach3 turn, and export gcode this below

    G0 G40 G18 G80 G50 G90
    G00 X11
    G00 Z0
    G00 X10
    M03 S300
    G76 X8.5 Z-18 Q0 P1.5 J0.3 L0 H0.1 I0 C1 B0.025 T0
    M9
    M5
    M30


    Spindle 300 RPM
    Thread 1.5

    but when result part thread is about 2.0

    I try run code again I see in monitor I found number of mm per REV = 2.06

    how to fix it's for same gcode P1.5
    Sorry i'm newbie.

  2. #2
    Junior Member
    Join Date
    Jun 2010
    Posts
    3897

    Re: Mach3 Function wizards Lathe threading REV 1.17 Problem . Help me please.

    Are you working in inches or millimetres?
    What metal are you cutting?

    Cheers
    Roger

  3. #3
    Registered
    Join Date
    Jun 2016
    Posts
    2

    Re: Mach3 Function wizards Lathe threading REV 1.17 Problem . Help me please.

    Hi mr.Roger
    I'm use in mm.
    I use matt is ss400


    Sent from my SM-G955F using Tapatalk

  4. #4
    Junior Member
    Join Date
    Jun 2010
    Posts
    3897

    Re: Mach3 Function wizards Lathe threading REV 1.17 Problem . Help me please.

    OK, known problem.
    When the tool hits the metal, the spindle is slowing down because of the load. On a geared lathe this does not matter, but on a small CNC lathe without gears and the spindle synchronising only on one pulse per rev, it does matter - hugely.
    You can try to use the PID controls in Mach3 if you are using a parallel port, but with only one pulse per rev ... no great joy.
    You could try making much smaller cuts so the spindle is not loaded as badly, but with SS, I have some doubts.
    Or you could use a geared lathe or a die.
    Sorry, but that's how it is.

    Cheers
    Roger

  5. #5
    Registered
    Join Date
    Aug 2004
    Posts
    710

    Re: Mach3 Function wizards Lathe threading REV 1.17 Problem . Help me please.

    I don´t think the issue has anything to do with slowing down as rcaffin suggested.

    The thread looks fine, consistent, and thus the pitch is wrong.

    Does g1 move x and z accurately.
    E.
    Move 30 mm, and measure with calipers.

    Can you thread *anything* accurately in pitch ?

    A scratch test with 0.02 mm deep contact, one pass, should show if the tracking is wrong in pitch, or if spindle load affects it.
    A 0.02 mm deep cut has == zero spindle load.

    Your spindle rpm might be misread or "float" with rpm.
    This is common.
    Index pulse sensors are often soft and fuzzy in the signal.
    Thus they can report different rpms and varying lag delays at different rpms, or warm/cold lathe, or heavy chuck vs light chuck, etc.

    Single index pulses, when testing with custom microkernel and 533 Mhz tracking speed, proved to track a thread within 0.01 mm, even from 530 rpm one day to 450 rpm next morning with a cold lathe running slow due to cold oil.

  6. #6
    Junior Member
    Join Date
    Jun 2010
    Posts
    3897

    Re: Mach3 Function wizards Lathe threading REV 1.17 Problem . Help me please.

    Yes, do a 'scratch' test with a tiny cut.

    Cheers
    Roger

Similar Threads

  1. Lathe Threading problem/question
    By Beansdiesel in forum BobCad-Cam
    Replies: 6
    Last Post: 01-31-2016, 10:44 PM
  2. Threading problem Haas SL10 lathe
    By christopher_s in forum General Metalwork Discussion
    Replies: 1
    Last Post: 10-11-2014, 05:50 PM
  3. Replies: 9
    Last Post: 05-13-2013, 04:14 AM
  4. Threading problem Victor Lathe 1660B
    By rdanner in forum Uncategorised MetalWorking Machines
    Replies: 9
    Last Post: 10-08-2009, 04:21 PM
  5. Threading function for Lathe Help?
    By Cartierusm in forum Dolphin CADCAM
    Replies: 22
    Last Post: 06-15-2009, 05:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •