506,654 active members
2,960 visitors online
Register for free
IndustryArena Forum > MetalWorking Machines > Hitachi Seikis > do you have a VK or VM machine with a working 4th axis?
Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2007

    do you have a VK or VM machine with a working 4th axis?

    I have added all the hardware to mine for the 4th but get a "NO OPTION" when I try to move it.

    If you do have a machine that the A axis buttons on the console actually move the 4th axis on your machine, would you be willing to share your parameters? I think some undocumented bit needs flipped to make this work and I would love to compare your settings to mine!

    Thank you!

  2. #2
    Join Date
    Dec 2009

    Re: do you have a VK or VM machine with a working 4th axis?

    Hey Dan
    Whats the control you’re setting up on?

    Sent from my iPhone using Tapatalk

  3. #3
    Join Date
    Aug 2007

    Re: do you have a VK or VM machine with a working 4th axis?

    John, it's a Secos II

    boards in the machine are:
    and a pair of SVIF boards

  4. #4
    Join Date
    Aug 2007

    Re: do you have a VK or VM machine with a working 4th axis?

    Hoping ya'll might be able to help. I have been wanting to add a fourth axis to my VK45 for years and last year I purchase a second VK45 for parts. I grabbed the X axis servo drive and servo, cables, resistor, relays and the SVIF board. Wired in all parts to my original VK.

    I have set the following parameters as follows. I tried to match values to what the X axis has just for testing.
    5 bit 3 = 1
    10 bit 1 = 0
    23 = 30
    27 = 3
    31 = 200
    43 = 15000
    66 = 500.000
    67 = -500.000
    71 = 0
    75 = 0
    79 = -500.000
    83 = 0
    87 = 0
    91 = 0
    110 = .0079
    137 = 570.000
    173 = 10000

    I tried all address combinations listed in parameter 01 & 08. Only seems to change the name (A,B,C,U,V & W) on the position display.

    Kept getting the NO OPTION error so I changed param 6 position 6 that matches the address of 4786. Rebooted the machine and boom! No more error! I can now select the A axis with the "Handle" and pressing cw or ccw for A in jog mode no longer creates an alarm.

    Last I did a comparison of the ladder paths for Z and A. It starts at the press of the + button (1084 and 1086) ....triggers coil 3131 & 3133 respectively. The contacts for the latter two then trigger 3261 & 3263 labeled "feed +Z axis, HIY=FO" and "feed +4th axis, HI4=FO". Those coils have no contacts in the ladder and I can't find them in the schematics.

    The position screen now shows X,Y,Z & A. The diagnostic 01 screen now shows all four servos and I was able to adjust the servo "droop" amount to near 0 on the A axis. (AE does not flicker as XE,YE & ZE do). Diagnostic 02, line 3 bits 3&4 toggle when A+ or A- is pressed. Diagnostic 03 line 9 shows *dec of one for X,Y,Z but not A. Line 10 shows all four "ready". Line 11 shows all four "off". Line 13 shows no over travel on any axis. Diagnostic 09, line 60, the A and B phase flicker if I rotate the shaft of the A servo. The multi status "speed", pg 2 will show values for all axis

  5. #5
    Join Date
    Aug 2007

    Re: do you have a VK or VM machine with a working 4th axis?

    I went through the maintains manual’s servo diagnostics, checking each signal to the servo drive. All were present and of the correct values however when I checked the supply voltage I found the brake relay was not engaged. I had missed a wire. Some interesting things I noticed in this unpowered state. I cannot use 100% rapids (such as when the machine is not had all axis referenced to “zero”). I noticed at times, I can go to the DIAG page and rotate the servo by hand and the encoder count changes. This is not always the case. Seems to happen after a program ends with G28. If the machine state is that I can cause the count to change via rotation, I noticed the VCMD signal would show up the correct polarity for a given direction. If left there more than a few seconds, a 031 WATCHDOG alarm would trigger.

    Present state. I fixed the power to the brake relay. Now moving the servo is out of the question. It is being held by the control. It still will not move via “HAND”, “JOG” nor “RAPID” and if in MIDI mode I send G1 F10. A10. I get an immediate 031 WATCHDOG alarm.

    I have two Hitachi documents that discuss the watchdog. One involving maintenance of the main board identifies a jumper to disable the watchdog timer (does not seem like a good idea and could cause a servo run away). The second talks about mods to the SVIF board, setting the 8 pos switch and installing a jumper and resistor.

    Most I have found says “replace boards”. I don’t think that is the problem as I can disable the 4th axis and no more alarm. Any ideas?

Similar Threads

  1. Switch view between machine working enveloppe and job not working?
    By skillalot in forum Screen Layouts, Post Processors & Misc
    Replies: 0
    Last Post: 08-10-2015, 03:55 PM
  2. Zenbot 4848 CNC Router... A (4) axis is not working with y axis motor
    By spitz2015 in forum Mach Software (ArtSoft software)
    Replies: 3
    Last Post: 06-01-2015, 10:43 PM
  3. Replies: 2
    Last Post: 02-13-2014, 10:09 PM
  4. 5 axis breakout board and 3 single axis drivers tb6560, not working
    By MROX15 in forum Stepper Motors / Drives
    Replies: 2
    Last Post: 11-06-2013, 07:34 PM
  5. New Machine - Y Axis not working
    By cautious32 in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 8
    Last Post: 09-04-2013, 04:26 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts