512,281 active members
2,721 visitors online
Register for free
Login
Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Feb 2005
    Posts
    138

    No motor movement Warp9 ESS+C11+Mach4

    I have a Warp 9 Smooth stepper connected to my C11 Multi Function Break Out board

    I'm getting no motor movement when jogging with the keyboard. My setup is listed below and I need some help.

    I'm using Mach4 with an ESS Smoothstepper and a C11 Breakout Board.

    Previously the C11 was used with my mach3 setup and worked fine but I decided to upgrade and use a smoothstepper and new software.



    The Smoothstepper configured fine and is communcating with Mach4.

    Here's my setup so far.
    All outputs ere enabled, this is done by jumping pin Ena pin to 5V. The Output enable status LED is 'lit'
    The C11 has 2 5Vdc supplies. First is taken from the PC USB port and the second is by a separate external supply.
    The Ess is not used to power the C11. Pin 26 Jumpers are off.
    The C11 On board charge pump is disabled.
    In Control Config, Axis mapping for X Y & Z is enabled.
    In Control Config (Input Signals) Jogging for all 3 Axis is set (Input selected to keyboard)
    In Ess config Port 1 pins 2 to 9 are set for (X step X dir) (y step y dir) (z step z dir)
    In Ess config Input Signals, nothing is set here
    In Ess config Homing, nothing is set here
    In jog mode the DRO's follow for all 3 axis. The output staus LED's allocated for each of the Step & Dir signals all illuminate during jogging.

    The motors 'Lock' and cannot be turned by hand!


    Still no motor movement.


    Can anyone help please.

    George

  2. #2
    Member
    Join Date
    Feb 2005
    Posts
    138

    Re: No motor movement Warp9 ESS+C11+Mach4

    Since posting , I've been an idiot. I had one of my jumpers incorrectly set. How I missed it I'll never know.
    Thanks for your help it has been very much appreciated.
    ESS + C11 now have movement.

  3. #3
    Registered
    Join Date
    Jan 2018
    Posts
    326

    Re: No motor movement Warp9 ESS+C11+Mach4

    I'm just as silly. I had no movement on my mill.
    I have it wired with the Enable wires connected to drivers. pul/dir are active low, had enable set active low as well.
    Turns out enable needed to be active high. D'uh.

Similar Threads

  1. Mach4 Help Needed: Potentially Paid Mach4 & CNC Consulting
    By rappinadam in forum Mach Software (ArtSoft software)
    Replies: 0
    Last Post: 11-26-2018, 06:49 PM
  2. Mach4 & ESS Warp9
    By rchristie in forum Mach 4
    Replies: 0
    Last Post: 06-30-2015, 11:30 PM
  3. Warp9 Ethernet smoothstepper with a G540 and MACH4 troubleshooting
    By zoomak in forum Machines running Mach Software
    Replies: 6
    Last Post: 06-21-2015, 11:34 PM
  4. mach3 and ess warp9
    By dukes57@295.ca in forum Machines running Mach Software
    Replies: 5
    Last Post: 03-29-2014, 03:41 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •