504,567 active members
3,940 visitors online
Register for free
Login
IndustryArena Forum > Machine Controllers Software and Solutions > Dynapath > Dynapath 40-50-60 battery died,lost parameters!!!!!!
Results 1 to 12 of 12
  1. #1
    Registered
    Join Date
    Apr 2008
    Posts
    207

    Exclamation Dynapath 40-50-60 battery died,lost parameters!!!!!!

    Hello all.
    I moved my machine from one location to another. It took a while to power it up again, now the battery died...
    I get the following error. Power fail: Part program and setup must be re loaded. Also touch multi key is not present or invalid.

    If I boot her up in DOS, I get CMOS checksum failiure Run setup utility.

    Anybody have a copy of the setup utility,part program or parameters that I could use to fix this? I am an idiot and am now in deep doo doo.

    I have all this work to run asap of course.:drowning:

  2. #2
    Registered
    Join Date
    Aug 2011
    Posts
    63

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    Nastyzen,

    What year is your control? Did you check that all cards are well seated in the motherboard? How long was it without power?

    CMOS checksum failure is usually related to the motherboard battery failure which is a different battery than the parameter RAM backup battery. It would be odd for both to fail together unless you've been without power for some time. The multi key error is another odd one. Perhaps this is something you should ask Dynapath directly, they are responsive in my experience.

    If you have access to an oscilloscope you should have a look at the power supply voltages. They are known to cause odd problems with these controls. Excess ripple would be a red flag.

    RT

  3. #3
    Registered
    Join Date
    Apr 2008
    Posts
    207

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    Thanks for responding so quickly cngbrick.
    The controller is a1998. It was out for 6 weeks. I changed the motherboard battery while I was at it...I called the people at Dynapath just before. Glen the tech is not in until tomorrow morning.
    No oscilloscope. Sorry just a dumb machinist here.

  4. #4
    Registered
    Join Date
    Aug 2011
    Posts
    63

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    Did you disturb the small ribbon cable on top of the cards when you changed the battery?

    RT

  5. #5
    Registered
    Join Date
    Apr 2008
    Posts
    207

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    Mine has the ribbon on the bottom. I had to unplug it from the card to be able to pull it out to get to the battery. Soldered a new 3.6V one on as I could not find the same battery anywhere.
    Was able to replace the motherboard one normally.

  6. #6
    Registered
    Join Date
    Aug 2011
    Posts
    63

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    Just to confirm: which batteries did you replace?

    The memory board has a battery soldered on and an additional connector for a replacement battery. If you remove the battery from the memory board without supplying another source of power to the card you will lose your parameters and programs.

    The motherboard may have a CMOS backup battery but in some cases it is built into the clock chip ("Dallas chip"). If it is in the clock chip, then it's a soldering job to replace. CMOS parameters are pretty easy to reset.

    The axis board has what looks like a coin type battery but is actually the key that unlocks the options on the control. It is easy to mistake for a battery. Hopefully you did not change this for a battery or if you did, have kept the original key. That could be the source for a key error.

    RT

  7. #7
    Registered
    Join Date
    Apr 2008
    Posts
    207

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    OMG I'm a menace to myself!! I'm looking at the book and it's right there. I went and soldered a battery to the damn key socket! Who would make a key that looks like a battery!?
    So I put it back the way it was and I still get the same errors..
    Going to call them up before I do anything else. I need a holiday.
    I will update as I get this going again to help anyone else who makes a bozo move.

  8. #8
    Registered
    Join Date
    Aug 2011
    Posts
    63

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    Good luck, you are certainly not the first to do this.

    RT

  9. #9
    Registered
    Join Date
    Apr 2008
    Posts
    207

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    Thanks, I still feel like an idiot though. I hope I didn't fry the axis board. The Fanuc guy left here with 6 grand, just last week..

  10. #10
    Registered
    Join Date
    Apr 2008
    Posts
    207

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    There is a god for dummies! I spoke to Glen who was rather horrified with what I did to my machine. Turns out all I had to do ( other than remove the battery from the axis board and replace the key ) was to auto detect the hard drive in the Ambios setup program. It now boots up the cnc part of things. The CMOS in the main board simply resets its self with the default. I have control!! YES!!
    My worry now is homing it safely. There appears to be the same travel limits still set on the controller. I will wait to speak to Glen again before pushing the button.

  11. #11
    Registered
    Join Date
    Apr 2008
    Posts
    207

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    Folks, we are making chips again! Woo Hoo! I still have to change that battery, but I'll make some parts first this time. For your info, the axis board is $956 US. Glad I didn't have to go there.
    Thanks for your help cngbrick.

  12. #12
    Registered
    Join Date
    Aug 2011
    Posts
    63

    Re: Dynapath 40-50-60 battery died,lost parameters!!!!!!

    Glad you are up and running. This is a nice control with good support.

    RT

Similar Threads

  1. Lost battery and parameters TM-1p
    By paradiddle1 in forum Haas Mills
    Replies: 0
    Last Post: 06-21-2016, 02:10 AM
  2. Mazak M5N with T32-2 Controller battery died
    By MONKEY2TO2 in forum Mazak, Mitsubishi, Mazatrol
    Replies: 1
    Last Post: 06-19-2014, 11:21 PM
  3. Citizen E32 servo alarms after battery died
    By brainbuktl in forum CNC Swiss Screw Machines
    Replies: 3
    Last Post: 04-05-2014, 06:27 PM
  4. FH6800
    By jimica in forum Mazak, Mitsubishi, Mazatrol
    Replies: 0
    Last Post: 06-15-2013, 10:49 AM
  5. Lost CMC-rte disk and computer just died tonight!
    By m_mcgranahan in forum Uncategorised MetalWorking Machines
    Replies: 0
    Last Post: 01-08-2013, 04:14 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •