505,967 active members
2,634 visitors online
Register for free
Login
IndustryArena Forum > EDUCATION + CNC TRAINING > TECHNICAN - FORUM > Z-axis NOT functioning - stepper motor? Controller?
Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Sep 2019
    Posts
    6

    Z-axis NOT functioning - stepper motor? Controller?

    Hi,

    Im new to CNC machines and just bought an Industrial Artesan 4x8 used for 3 months. My Z-axis is just making a buzzing sound and not spinning when I try to hold pag up or down keyboard keys. I was told to change the stepper motor controller then the power transformer and the Z was still not working(X and Y axis work fine). I plugged the Z stepper motor to a different controller(such as X or Y) and it turns out that it works fine. The “lifetime help support” refused to help since I didn't buy directly from them even though the machine is technically brand new.
    Attached Thumbnails Attached Thumbnails AA9DEF98-2A4F-44B9-BF71-A250C809A6E7.jpg  
    Last edited by ddv0605; 09-12-2019 at 05:22 PM.

  2. #2
    Registered
    Join Date
    Sep 2005
    Posts
    165

    Re: Z-axis NOT functioning - stepper motor? Controller?

    does it work on the different controller? Couldn't decipher your last sentence.

  3. #3
    Member
    Join Date
    Sep 2019
    Posts
    6
    Yes it works when hooked up to a diff motor. Also the Z motor works when hooked up to a different controller board. And the controller board works when hooked up to a different motor as well. All components work when connected to a different line such as X or Y but not when hooked up to the Z. I am confused what could cause that. I bought brand 4 brand new controller boards, 1 new power transformers and still the same result - the Z is not spinning, just buzzing sound with vibrations.
    I have attached a photo of the actual controller boards and this part to the very right that all wires lead to( I don't know what's the type of board called). I am starting to think that this "unknown type of board" could be the issue here but don't know for sure. I checked it for burned marks or anything similar but couldn't find anything wrong with it.
    Do you think it could be the Power Transformer that was changed since the old one was burned out? this is the type I purchased - https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
    Last edited by ddv0605; 09-12-2019 at 05:27 PM.

  4. #4
    Registered
    Join Date
    Mar 2007
    Posts
    1986

    Re: Z-axis NOT functioning - stepper motor? Controller?

    Its hard to see from the photos but looking at the inputs to the stepper drivers

    the wiring to the middle stepper driver looks odd with 2 black wires

    Click image for larger version. 

Name:	stepper driver input wiring.jpg 
Views:	3 
Size:	60.5 KB 
ID:	427258

    going to what I think is the clock/step input

    John

  5. #5
    Member
    Join Date
    Sep 2019
    Posts
    6
    Quote Originally Posted by john-100 View Post
    Its hard to see from the photos but looking at the inputs to the stepper drivers

    the wiring to the middle stepper driver looks odd with 2 black wires

    Click image for larger version. 

Name:	stepper driver input wiring.jpg 
Views:	3 
Size:	60.5 KB 
ID:	427258

    going to what I think is the clock/step input

    John

    Thank you. All wires including the 2 black wires were the same way when I first bought the cnc machine a month ago. Back then the Y1 and Y2 weren't working and the X and Z were working fine. The only thing I did was to replace one of the power transformers with the one that I posted a link above. After that I hooked up all stepper boards back how they were and turned the CNC back on. Then the Z wasn't working. I was even thinking to put back the burned out Trasnformer to see if the Z will go back to work?!
    I am attaching a photo of the drawing of the wiring I did to the cnc(see below)
    Attached Thumbnails Attached Thumbnails 67292279_375966139766731_2545448067742564352_n.jpg  
    Last edited by ddv0605; 09-12-2019 at 06:12 PM.

  6. #6
    Registered
    Join Date
    Mar 2007
    Posts
    1986

    Re: Z-axis NOT functioning - stepper motor? Controller?

    trace the 2 black wires to see where they go

    from the breakout board
    I would of expected a black and a red wire for each axis will go to the step and direction inputs on one of the 4 stepper drivers

    Attachment 427260

    assuming your using mach3

    have a look in ports and pins to see how pins 2 to 9 have been assigned

    you may find its something like this

    Attachment 427264

    if they have slaved 2 axis drivers to one 1 axis in software
    ( A axis slaved to Z axis )

    the alternative would be if they had connected 2 stepper drivers to 1 BOB axis output
    in which case I would of expected you would have found on one driver to have both a pair of black wires on one input and a pair of red wires on the other input
    so the step and direction signals loop from the Y1 axis driver to the Y2 axis driver


    John

  7. #7
    Member
    Join Date
    Sep 2019
    Posts
    6
    Quote Originally Posted by john-100 View Post
    trace the 2 black wires to see where they go

    from the breakout board
    I would of expected a black and a red wire for each axis will go to the step and direction inputs on one of the 4 stepper drivers

    Attachment 427260

    assuming your using mach3

    have a look in ports and pins to see how pins 2 to 9 have been assigned

    John
    The black wire just connects both Ys together. It is how it suppose to be as far as the diagram above explains. The issue is with the Z-axis not being functional. Check the image on here to see which one is that. I keep thinking its a wire issue but the diagram is made by a professional electric guy who also have no answer why is the Z-axis still not working.
    Attached Thumbnails Attached Thumbnails 70303680_379466586332974_5764802991290843136_n.jpg  
    Last edited by ddv0605; 09-12-2019 at 07:10 PM.

  8. #8
    Registered
    Join Date
    Mar 2007
    Posts
    1986

    Re: Z-axis NOT functioning - stepper motor? Controller?

    what test equipment do you have ?

    while you can use a multimeter set to the 10V range to see the direction signal change

    its not easy to use a voltmeter to see the narrow step pulses

    a logic probe make it easy
    Attachment 427268
    https://www.ebay.co.uk/i/311908924223


    if the 2 Y axis drivers are connected to 1 BOB output
    you have a spare BOB axis output that you could connect to the Z axis driver to

    John

Similar Threads

  1. Rabbit Laser X-Axis motor not functioning properly
    By wonderboyv1 in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 0
    Last Post: 09-17-2018, 09:06 AM
  2. 3 axis CNC controller kit 3 NEMA17 78 oz-in stepper motor + 3 axis CNC board
    By Chaparro1973 in forum Stepper Motors / Drives
    Replies: 3
    Last Post: 03-12-2012, 10:26 AM
  3. 3 axis motor stepper controller
    By jigoku in forum Linear and Rotary Motion
    Replies: 0
    Last Post: 09-23-2010, 01:32 PM
  4. Multi-axis stepper motor controller
    By uirobot in forum News Announcements
    Replies: 0
    Last Post: 06-23-2010, 10:18 AM
  5. New 3 Axis Stepper Motor controller
    By Kelinginc in forum Automation Technology Products
    Replies: 0
    Last Post: 09-17-2008, 08:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •