513,202 active members
4,061 visitors online
Register for free
IndustryArena Forum > Machine Controllers Software and Solutions > WinCnc > CNC 3Axis Router w/rotary addition Software Glitch
Results 1 to 4 of 4
  1. #1

    Join Date
    Oct 2018

    CNC 3Axis Router w/rotary addition Software Glitch

    . Hello! I have an APE 200HD running WinCnc (could use help finding out the version) BTW: I'm a Mac person. Anyway, Running two different jobs yesterday, one rotary and one 3-axis. About 60% through the rotary job when machine loses position and ruins the job. On Rotary, cut almost to center of work-piece along the Y-axis (X=B, or rotary, on my machine). On the 3-axis job at about 60% the machine again lost position and cut into the work. Not as drastic, but ruined none the less. In both cases the Z-axis (once the job was aborted) would not respond to homing commands. When I shut the job down on the 3-axis job, I rebooted the controller and used the SEEK LIMITS command with no effect. When I tried the GO HOME command, the Z- axis did not retract and it snapped off the bit as it went home, instead of returning to its upper position as usually happens. With the rotary axis, I was able to shut everything down and manually move the machine head along the X-axis to clear the work. Fortunately the tool also cleared the table and I moved it close to Machine Zero and ran the SEEK LIMITS command and re-homed it. I am trying to narrow down machine vs operator error. BTW: using Vectric Aspire v. 9.510 if that matters.

    Thanks for any help!!

    Steve Weaver

  2. #2
    Join Date
    Mar 2008

    Re: CNC 3Axis Router w/rotary addition Software Glitch

    When a loss of steps is indicated I recommend that you cut feedrates in half and repeat to see if that cured the problem
    Gary Campbell CNC Technology & Training
    GCnC411 (at) gmail.com www.youtube.com/user/Islaww1/videos

  3. #3

    Join Date
    Oct 2018

    Re: CNC 3Axis Router w/rotary addition Software Glitch


  4. #4
    Join Date
    Oct 2019
    I went through this exact problem recently. The machine was retrofitted to WinCNC by a bit of a hack. I had to trace all the grounds and make sure they were reconnected, make sure the cabinet was well cooled, remove old cables, deal with stepper motor over torque shutdown, verify that everything was hooked up to spec ect... The Mach3CNC manual is very good for helping the DIY'er hook stuff up. And be sure to check for mechanical rigidity. If you do all this stuff and it's still not working right, grab an oscilloscope and look at the pulses going to the steppers. And set the debounce correctly for your hard limits. Good luck and happy to answer any questions. Ian.

Similar Threads

  1. Bobcad software glitch
    By mstire in forum BobCad-Cam
    Replies: 5
    Last Post: 02-10-2017, 11:48 PM
  2. Designing my first 3Axis cnc router, able to cut alu.
    By Pettersen in forum DIY CNC Router Table Machines
    Replies: 9
    Last Post: 12-19-2015, 08:45 PM
  3. Limit / Homing switches and a software glitch
    By sanddrag in forum Tormach Slant Lathe
    Replies: 4
    Last Post: 10-21-2015, 11:45 PM
  4. Home switch addition to rotary table
    By aubreyj in forum Uncategorised MetalWorking Machines
    Replies: 8
    Last Post: 09-06-2012, 04:57 PM
  5. Could 3axis cnc router server as 3d?
    By preciseformwork in forum Controller & Computer Solutions
    Replies: 1
    Last Post: 10-25-2010, 08:03 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts