510,084 active members
2,711 visitors online
Register for free
Login
IndustryArena Forum > CNC Electronics > Stepper Motors / Drives > steppers worked fine on one machine , shakes on another
Results 1 to 4 of 4
  1. #1
    Registered
    Join Date
    Aug 2017
    Posts
    2

    steppers worked fine on one machine , shakes on another

    Hi !

    I recently salvaged a prusa i3 so I could use some of its parts in a "drawing robot" , but the steppers shake intensely and do move (the coils are connected properly) but the shaking is
    so extreme that the entire thing just moves when I put it on the ground , and this sort of shaking was nonexistent when the motors were on the prusa .
    I have tried 1/16 and 1/32 microstepping (because switching to 1/32 saved me from this shaking once in the past) but nothing changed. I also tried fine tuning the potentiometer on the
    driver but it shakes no matter how much current it gets.
    I also have another issue regarding grbl itself but I have no idea where to ask , because I believe this forum is about bigger machines than what I am working on ?

    thanks in advance !

  2. #2

    Join Date
    Oct 2019
    Posts
    1

    Re: steppers worked fine on one machine , shakes on another

    You may be trying to spin it too fast. Try to reduce the 'feedrate' and acceleration and see if that helps, steppers can only handle so much torque (in the form of acceleration and speed) before they go crazy. What type of drivers are you using?

  3. #3
    Registered
    Join Date
    Mar 2007
    Posts
    2037

    Re: steppers worked fine on one machine , shakes on another

    the prusa i3 is a light weight machine so the stepper drivers will be low power and motors have a low torque

    what is the new machine like ?

    if its larger and heavier , the motor could be stalling

    photos are helpful

    the more detail you can give the easier it will be for others to help


    John

    PS

    I expect your stepper drivers are something like the Reprap Stepper Driver A4988 Stepper MotorDriver Module

    Click image for larger version. 

Name:	Reprap Stepper Driver A4988.jpg 
Views:	0 
Size:	62.6 KB 
ID:	430348

  4. #4
    Registered
    Join Date
    Aug 2017
    Posts
    2

    Re: steppers worked fine on one machine , shakes on another

    Hi ! thanks !
    Yes I am using polulu drivers (DRV8825) , I will try changing the acceleration.
    the torque requirements for this application is much less than the 3d printer itself , so I assume it is a speed/acceleration issue , but grbl is more confusing than 3dprinter firmwares since theres less documentation.
    thanks !

Similar Threads

  1. Replies: 8
    Last Post: 10-19-2018, 08:47 PM
  2. Shakes on the Y axis in 6040 CO2 laser machine
    By snopa in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 3
    Last Post: 09-24-2018, 10:35 AM
  3. I want to build a fine cutting machine
    By Znc in forum General Laser Engraving / Cutting Machine Discussion
    Replies: 1
    Last Post: 09-04-2016, 09:35 PM
  4. Machine worked great now won't cut
    By nandrus in forum Precision Plasma
    Replies: 0
    Last Post: 05-04-2016, 09:48 PM
  5. Replies: 27
    Last Post: 11-07-2009, 11:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •