I have created a sketch with the word Christmas. All I am trying to do is cut this word out using a 2D contour tool path but I CANNOT select the geometry. I can select the leading C but the rest of the text, which was all created at the same time, I cannot select. If I create Merry Christmas I can select the M and the erry and the C but not the hristmas.
See attached Paint (.png) file.

I don't get it.

The text is create as follows.

I create a new sketch.

I do a create text and set up the text.

I accept the text.

I do an explode text.

I trim out the extraneous lines.

I finish the sketch.

I select all the letters.

I do a press pull for .121 inches.

I go to manufacture and create a new setup.

I select the 2D contour and TRY to select all the contours but I can only select the C.

Attachment 430422

This has worked perfectly in the past and works now with the word Merry but not with Christmas.
Even if I leave off the C the rest of the word will not allow me to select it. All I get are a bunch of little segments instead of the entire outline.

I don't get it.

I attached the fusion file.
If anybody has a clue about this please help.