512,697 active members
4,487 visitors online
Register for free
Login
Results 1 to 10 of 10
  1. #1
    Registered
    Join Date
    Apr 2012
    Posts
    109

    Disable screensaver

    Some screensaver keep blanking out my screen. How do I disable this? My PC and monitor are both Tormach stock. I'm running the latest Path v2.3.6.
    "You can't teach stuff in a school that you would learn in real life unless the real life people are in charge of the school." - Gene Sherman

  2. #2
    Registered
    Join Date
    Aug 2014
    Posts
    233

    Re: Disable screensaver

    Within PP you can open a terminal up using the "Ctrl+Alt+X" keys.
    At the terminal prompt enter the command: "mate-screensaver-preferences" and the "ScreenSaver Preferences" window should appear.
    From here you can select your preferences.
    In your case make sure the "Activate screensaver when computer is idle" box is unchecked.
    Also, make sure under the "Power Management" -> "On AC Power" tab, under "Display" -> "Put display to sleep when inactive for:", is set to "Never".

  3. #3
    Registered
    Join Date
    Apr 2012
    Posts
    109

    Re: Disable screensaver

    I already had screen saver preferences and power management setup that way. Either it doesn't work or something else blanking the screen. I went into the menu on the monitor itself and didn't see any screensaver settings.
    "You can't teach stuff in a school that you would learn in real life unless the real life people are in charge of the school." - Gene Sherman

  4. #4
    Registered
    Join Date
    Aug 2014
    Posts
    233

    Re: Disable screensaver

    You can try disabling the screen saver daemon from running when starting up. From a terminal run the command "mate-session-properties" and under the "Startup Programs" tab scroll down to "Screensaver" and disable it from running - uncheck the box.

    If this doesn't do it then something else is loading that is enabling the screen saver. It could be that the PP start script is forcing a screen saver to occur.

    To tell you the truth I've never noticed on my machines if a screen saver activates. It could be that it does but I just never thought anything about it. I'll have to check that out ...

  5. #5
    Registered
    Join Date
    Apr 2012
    Posts
    109

    Re: Disable screensaver

    Thanks, I'll give that a try. My screensaver comes on pretty quickly. I haven't timed it, but it's around 15 minutes.
    "You can't teach stuff in a school that you would learn in real life unless the real life people are in charge of the school." - Gene Sherman

  6. #6
    Registered
    Join Date
    Apr 2012
    Posts
    109

    Re: Disable screensaver

    Screen saver daemon was already unchecked. I did uncheck the power management daemon and re-booted, but that didn't change anything. When I boot my controller, I have it setup to go to the linux desktop, to open PP I have to click on the PP startup script. Even if I'm just on the linux screen, the screensaver still kicks in. So I don't think it's a pathpilot setting.
    "You can't teach stuff in a school that you would learn in real life unless the real life people are in charge of the school." - Gene Sherman

  7. #7
    Registered
    Join Date
    Oct 2005
    Posts
    847

    Re: Disable screensaver

    The ScreenSaver save COULD be in teh BIOS settings.

    (;-) TP

  8. #8
    Registered
    Join Date
    Apr 2012
    Posts
    109
    Quote Originally Posted by vmax549 View Post
    The ScreenSaver save COULD be in teh BIOS settings.

    (;-) TP
    I checked the BIOS, I didn't see any screensaver settings
    "You can't teach stuff in a school that you would learn in real life unless the real life people are in charge of the school." - Gene Sherman

  9. #9
    Registered
    Join Date
    Aug 2014
    Posts
    233

    Re: Disable screensaver

    There is a installed Linux command "xset" which might do the trick. In a terminal try entering:

    $ xset s off
    $ xset -dpms

    If this works you can add it to the startup list of commands to run.

    This has been an issue with Linux Mint 17.3 (Rosa) which PP is based on. There is a thread How to disable screen blanking? you might want to read for more information.

    Otherwise, since you have mentioned you're using Tormach supplied hardware maybe they can help.

    Besides xset I'm out of ideas ...

  10. #10
    Registered
    Join Date
    Apr 2012
    Posts
    109

    Re: Disable screensaver

    Quote Originally Posted by rdsi View Post
    There is a installed Linux command "xset" which might do the trick. In a terminal try entering:

    $ xset s off
    $ xset -dpms

    If this works you can add it to the startup list of commands to run.
    xset worked, thanks!
    "You can't teach stuff in a school that you would learn in real life unless the real life people are in charge of the school." - Gene Sherman

Similar Threads

  1. how can i disable air on this little one ?
    By deadlykitten in forum Okuma
    Replies: 10
    Last Post: 08-28-2016, 11:21 AM
  2. SCREENSAVER
    By Mr Bonavita in forum Cincinnati CNC
    Replies: 2
    Last Post: 07-17-2012, 08:11 PM
  3. 16i-MB Screensaver
    By Jwl in forum Fanuc
    Replies: 7
    Last Post: 11-10-2009, 06:41 AM
  4. How do you disable SMI?
    By SpeedsCustom in forum LinuxCNC (formerly EMC2)
    Replies: 3
    Last Post: 03-04-2009, 10:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •