521,531 active members*
2,593 visitors online*
Register for free
IndustryArena Forum > MetalWorking Machines > Bridgeport / Hardinge Mills > Dx32 runtime error, Invalid screen
Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2014

    Unhappy Dx32 runtime error, Invalid screen

    Hello guys!

    I got yet an other problem with my Tq 22, This time is what apears to be a Dos related error?

    First, when i load a new program either from the floppy, HD, or try to DNC it i get a message on the bottom of the screen, saying invalid screen, followed by what should be the normal loading screen, but the thing is it ofsets everything and it goes back to normal until i reset the BOSS ( with the "run" command , or cont+alt+del) , if i dont reset it it shows everything mixed, how ever the keys still work as usual, I've put a picture of what i mean on the atachments.

    The next error is more random, but still happens ofter, ( once a week maybe).

    I get a runtime error, also at the bottom of the screen, like if i was on Dos mode, How ever the machine still runs the loaded program if it happens, its just the screen thats "freezes", but i sill can type dos commands.

    Also the message cant divide by zero happens often as a dos prompt.

    And last but not leats, im getting the following error when loading Fusion 360 files " Cant load CNC!", i know the dx32 has a a 256kb limit when loading from floppy drives, but the programs im trying to load are in the 10-60 kb range. Im not sure what could be causing this.
    Sometimes it loads just the very first lines of code and lets me run it.
    I'm using the oficial dx32 post from autodesk.

    I also atached an example of a file i can't oppen.

    Here is the video of the run time error thing

    Hope some one can give me some insight into what i should look for

  2. #2
    Join Date
    Sep 2003

    Re: Dx32 runtime error, Invalid screen

    Boy that is a tough one for sure sounds like a internal communication problem maybe, I'd pull and reseat all the boards and see if that helps, as far as loading fusion programs make sure they are a text file , -----.txt or the dx32 wont load them, Good luck Jon P.

  3. #3
    Join Date
    Nov 2014

    Re: Dx32 runtime error, Invalid screen

    Thanks Jon p,

    Sorry for not answering sooner ,I had a little vacation with my girl.

    And i got news!

    I took apart all the boards, gave them a good blow and reasembled them.
    Sadly i kept getting the same errors and glitches.

    It apears my motherboard is not original.
    I bought the machine from a friend that has it from new, and he said there had been work done to it, but he cant recall what.
    The mother board has 32 megs of ram installed, and also a 64 mb DOM instead of a phisical hdd.

    Today i was runing a "big file" ( 276kb) and when i tryed to dnc it from the floppy drive it stoped half way.
    I tryed to copy the file to the hdd to run it from there, but i kept getting errors, so i took it out of the machine , and put it on my laptop, only to find the floppy was damaged and needed to be formated, i tryed to do it but nothing, death.

    I tryed with a new drive, and....
    Yep it worked flawless, im running a program right now and its working really good.
    And whats best is the weird screen glitches are gone when i load from the new floppy.

    This brings me to my next question, how hard is to set up a shared folder on the bridgeport hard disk?
    I already installed Win 3.11 for workgroups, but im unsure on what to do next.

    It would be nice to get rid of those anoying floppy disk.


  4. #4
    Join Date
    Dec 2005

    Re: Dx32 runtime error, Invalid screen

    You do not need to install the full blown Win3.11 for LANMAN support. You just need the basic DOS client. I documented the method a while back on my long WW thread. Understand the forum has some issues recently so all the images are broken at the moment.

    My floppy never worked right on my TC-3. I generally DNC from the hard drive. I transfer my files to a folder on the hard drive using FTP and a packet driver. Lightweight and easy. I also have USB capability (documented in the thread above) but I don't like needing to reboot to swap/mount a drive. I setup LANMAN/SAMBA just to see if I could do it. It worked well and you'd simple mount the remote share and use it. This is likely the easiest, especially if your connecting to a share that your post processor writes to.

    As for your run-time error M6101 : MATH - floating-point error. Does this happen on every G02/03 arc or just occasionally?
    These errors often point to a lack of math co-processor on older x86 machines. What CPU are you using? If you have MS-DOS 6.0+ you can run MSD.EXE (Microsoft Diagnostics) to view the co-processor status. You need a co-processor for floating point math.

    As a test try turning off Smoothing on the Passes tab in Fusion 360. This should export your code as line segments instead of arcs.

Similar Threads

  1. Partner 1F Runtime Error 216
    By bluekat in forum Milltronics
    Replies: 3
    Last Post: 12-24-2014, 02:16 PM
  2. Runtime error
    By mstreur in forum Deckel, Maho, Aciera, Abene Mills
    Replies: 0
    Last Post: 07-09-2014, 07:26 PM
  3. v-25 demo runtime error
    By 1234567 in forum BobCad-Cam
    Replies: 1
    Last Post: 05-29-2012, 11:39 PM
  4. Runtime error
    By ARHEA in forum EnRoute
    Replies: 0
    Last Post: 05-17-2012, 06:43 PM
  5. Runtime error
    By msme-lc in forum General CNC (Mill / Lathe) Control Software (NC)
    Replies: 1
    Last Post: 09-30-2008, 10:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts