515,589 active members
7,354 visitors online
Register for free
Login
IndustryArena Forum > MetalWorking Machines > Fadal > Need Help Fadal Turn M04 but not M03
Results 1 to 13 of 13
  1. #1
    Registered
    Join Date
    Jan 2018
    Posts
    6

    Need Help Fadal Turn M04 but not M03

    I have a Fadal 4020 it work fine but in a job of 4 Al plate I notice that the spinddle have some issues it reduce RPM but I finish the job but I turn the M03 manually and the drivers when to fault but on M04 the machines works fine
    Any suggestions to check?

  2. #2
    Registered
    Join Date
    Jan 2015
    Posts
    359

    Re: Need Help Fadal Turn M04 but not M03

    In the Back of the machine control box below the Spindle drive is the 1100-2 board. M3 spindle on is the K3 relay and also F1 fuse. M4 spindle reverse is the K4 relay.... You can try swapping the M4 spindle reverse relays and fuse into the positions for the M3 spindle on to test using MDI do a M3. Look on the Cabinet door it tells you what fuses and relay are for which direction.
    Attached Thumbnails Attached Thumbnails IMG_20200207_141520.jpg  

  3. #3
    Registered
    Join Date
    Jan 2018
    Posts
    6

    Re: Need Help Fadal Turn M04 but not M03

    Actually we already try it, the Relays works we change them around and the problems continue, I review spinddle driver it works I swap the spinddle card and it work what about the Mill card has to ve check?

  4. #4
    Registered
    Join Date
    Jan 2015
    Posts
    359

    Re: Need Help Fadal Turn M04 but not M03

    Did you swap the K7 and the K9 also below the fuses?

  5. #5
    Registered
    Join Date
    Jan 2018
    Posts
    6

    Re: Need Help Fadal Turn M04 but not M03




    Yes I swap them but the M04 turn Ok but the M03 what triggers this relays the Mill Card or the Spinddle card?

  6. #6
    Registered
    Join Date
    Jan 2015
    Posts
    359

    Re: Need Help Fadal Turn M04 but not M03

    The 1040 card Mill interface slot 17 controls the relays.

    what are your voltages on the 6 pin connector going to the spindle drive?
    Attached Thumbnails Attached Thumbnails Capture2.JPG  

  7. #7
    Registered
    Join Date
    Jan 2018
    Posts
    6

    Re: Need Help Fadal Turn M04 but not M03

    I'll check it.

    Let me undestand the card job because some times the M03 turn with no problem but I continue to test and the RPM start to be erratic the Mill cad 1040 turns the relay on, or does the card continue to work wile the spinddle is on.?

  8. #8
    Registered
    Join Date
    Jan 2015
    Posts
    359

    Re: Need Help Fadal Turn M04 but not M03

    1040 card activates the relays and the Spindle card controls the voltage sent to the Drive 0-10vdc which is the rpm. It is starting to look as if your Spindle invertor is going bad unfortunately? Do you have another fadal that you can swap drives? Or a really really good friend with a Fadal. Not sure if you have rigid tap or vector with a Encoder on top of Spindle motor. If so the encoder might be bad... but if it was you should have the problem in both M3 and M4

  9. #9
    Registered
    Join Date
    Jan 2018
    Posts
    6

    Re: Need Help Fadal Turn M04 but not M03

    I will send the 1040 to be review,

    I have a technician that has a vector drive from FadalCNC He came in and swap them but the problem did not change.

    The machine has epron for rigid taping not use to offten on tested and it works but the first thing that I did I change the encoder but the old one was in good condition it has the metal and change to new of metal they sell you some ship plastic that I don't trust.

  10. #10
    Registered
    Join Date
    Jan 2015
    Posts
    359

    Re: Need Help Fadal Turn M04 but not M03

    Voltage to the spindle drive is what makes the rpm 0-10 vdc to the pins in the previous post. The 1040 card does nothing for the rpm.

  11. #11
    Registered
    Join Date
    Jan 2018
    Posts
    6

    Re: Need Help Fadal Turn M04 but not M03

    Yesterday I swap Spinddle Drive and the machine is running with with no problem the only problem is to pay 2550 for one new I call A tech that fixed them for about 1,000 bucks but I ratter wait and buy a new one

    Rodney247 Thank you for all your help I do appreciate that some one takes there time to help a stranger.

  12. #12
    Member
    Join Date
    Aug 2009
    Posts
    352

    Re: Need Help Fadal Turn M04 but not M03

    ...was reading your thread today and did some googling
    https://www.cnczone.com/forums/fadal...0-spindle.html
    long story short... I see in their thread Delw found his problem "I undid the wires opened the case and noticed that one of the blue thick nickle sized MOV parts vibrated. I touched it and it fell to the floor.
    he had told me to check this and see if they were connected ,loose or even there on the bottom of the control box. Apparently this has happened a few times in the past with the older sweo drives (1995 model)."

    DJ

  13. #13
    Registered
    Join Date
    Jan 2015
    Posts
    359

    Re: Need Help Fadal Turn M04 but not M03

    That is a possibility to repair yourself wouldn't hurt to try replace anything that looks burnt only problem can be if something is burnt usually there is other damage. If all else fails here is another option a little cheaper also from one of the original Fadal peeps https://www.calmotion.com/calamp-7.html

Similar Threads

  1. Replies: 0
    Last Post: 09-20-2019, 08:18 AM
  2. Replies: 2
    Last Post: 05-24-2016, 12:47 AM
  3. Replies: 3
    Last Post: 09-21-2014, 01:04 AM
  4. MachStdMill Turn and Mill-Turn Announcement
    By mvcalypso in forum Screen Layouts, Post Processors & Misc
    Replies: 4
    Last Post: 11-16-2012, 03:38 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •