521,997 active members*
2,759 visitors online*
Register for free
Login
IndustryArena Forum > MetalWorking Machines > Mori Seiki lathes > Loader help on Mori RL-253, MSC-803 Controller
Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    May 2020
    Posts
    3

    Loader help on Mori RL-253, MSC-803 Controller

    Good morning!

    I have a fun one for you guys!

    I've got an old (1999) Mori-Seiki RL-253 lathe with a gantry loader on it. I'm trying to teach the loader the points for loading the spindles, but I can't get the loader to go into the machine.

    Here’s where I’m at this morning:

    I pulled a G30 before zero-returning, and now I have the secondary home lights flashing.
    Teach Pendant is in “0” mode.
    Front doors are closed, nothing operating in bypass.

    Still no good. It clearly seems that the vague statement in the manual that “all conditions for robot entry at the lathe must be satisfied” is such that these conditions are NOT satisfied.

    I thought the conditions were:
    1.) spindle stopped
    2.) shutter open
    3.) secondary home

    I’ve got all of those.

    I fired the M31 to allow the spindle to move, just in case it made a difference. No love.

    I thought maybe it needed permission to enter, so I fired an M64 (loader request) in MDI, but all that did was give me a feed hold error.

    I feel I’m close, but I really can’t figure out why this damnable loader won’t go into the machining bay.

    Any insights – I’m pretty much euchred if I can’t get this thing into the bay…

    Thanks, in advance, to anyone who can help me!

  2. #2
    Member
    Join Date
    May 2020
    Posts
    3

    Re: Loader help on Mori RL-253, MSC-803 Controller

    Okay, more info:

    I got the ladder out, and it seems that there’s one bit that’s holding up the M3755 “Loader Machine Position OK”, and that’s M3228 “Turret Data COIN#L”.

    What the what is that? It’s the outcome of a compare, between “TAC#L.1” and “TR&LD#L.1”. However, I have no idea what those are.

    From what I can tell, the “TAC#L.1" is "turret A-phase count:addition", and the “TR&LD#L.1” is the "turret and loader data".

    I don't know what those are, or how they work. Any help would be great.

    Thanks!

  3. #3
    Member
    Join Date
    May 2020
    Posts
    3

    Re: Loader help on Mori RL-253, MSC-803 Controller

    Okay: In case anyone else cares, I figured it out with help from DMG-Mori in Canada.

    The problem is the turret position. The two parameters #6302 and #6313 were set to 11. These are the LS and RS (respectively) positions the turrets have to be in order for the loader to go into the machine. Thus, when I changed from T1 to T11 I got the robot to go into the bay!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •