525,818 active members*
3,260 visitors online*
Register for free
Login
Results 1 to 9 of 9
  1. #1
    Registered
    Join Date
    Oct 2007
    Posts
    17

    Input Stopped Working

    I am moderately sure I have the Hobby CNC Pro chopper driver board. It is 10+ years old. The input I have assigned to my probe has stopped working. I have ohmed all the wiring right to the board and no dice. I have changed the probe pin assignment and it all works when assigned to another pin. Pin 10 seems to be dead. Is this common? Would it be possible that since my machine is all conductive, that this has somehow stressed the input to the point of failure? I use all available inputs, so I don't have a spare.

    Thank you

    Ryan

    Sent from my SM-N970U using Tapatalk

  2. #2
    Registered
    Join Date
    Nov 2012
    Posts
    891

    Re: Input Stopped Working

    Is this what your board looks like?



    If so, then the input probably failed because the board does not have any galvanic isolation between the inputs and the PC. Problem is, most lilkely it's your computer's parallel port that has failed.

  3. #3
    Registered
    Join Date
    Oct 2007
    Posts
    17

    Re: Input Stopped Working

    Pretty sure that's it. Been a while since I layed eyes on it. Like, three days, so of course I can remember.

    I'm also using an ESS so the problem could be there also?


    Sent from my SM-N970U using Tapatalk

  4. #4
    Registered
    Join Date
    Nov 2012
    Posts
    891

    Re: Input Stopped Working

    So the HobbyCNC is connected to the ESS, not to the parallel port? Then the problem is likely in the ESS or its breakout board. Judging by the pictures I could find, HobbyCNC just passes the pin 10 signal through and pulls it up.

  5. #5
    Registered
    Join Date
    Oct 2007
    Posts
    17

    Re: Input Stopped Working

    The input pins are pulled up. At least the ESS is much easier to access. I see if I can do we checking there.

    Sent from my SM-N970U using Tapatalk

  6. #6
    Registered
    Join Date
    Oct 2007
    Posts
    17

    Re: Input Stopped Working

    Wow. Sorry for the fat fingers and auto corrupt.

    Sent from my SM-N970U using Tapatalk

  7. #7
    Registered
    Join Date
    Oct 2007
    Posts
    17

    Re: Input Stopped Working

    Fixed! Or rather a suitable work around. Moved the probe to an input on port 2 of the ESS. Thank you Warp 9 for providing 3 ports!

    Finally back to my SOP. Sometimes you don't realize how important something is until you are forced to do without it.

    CitizenofDreams, thanks for your help!

    Sent from my SM-N970U using Tapatalk

  8. #8
    Registered
    Join Date
    Nov 2012
    Posts
    891

    Re: Input Stopped Working

    Glad you got your machine working, thanks for the update!

    Is the ESS connected to the HobbyCNC directly, or does it have a breakout board with opto isolators? Without isolation, you may lose another input eventually when the stars align in a wrong way.

  9. #9
    Registered
    Join Date
    Oct 2007
    Posts
    17

    Re: Input Stopped Working

    Directly connected. Is there a stand alone opto isolation device that I can add? Although the driver box is about 13 years old so I don't feel too bad, I don't feel I'm a lucky person either.

    Sent from my SM-N970U using Tapatalk

Similar Threads

  1. DIY CNC Stopped working?
    By PJRU0304 in forum DIY CNC Router Table Machines
    Replies: 4
    Last Post: 06-04-2019, 04:55 AM
  2. V21 CAM stopped working
    By Fabriquer in forum BobCad-Cam
    Replies: 2
    Last Post: 10-13-2016, 08:47 PM
  3. Md1-stopped working
    By Scrambled1 in forum HURCO
    Replies: 4
    Last Post: 05-11-2016, 08:32 PM
  4. G540 stopped working
    By enricodina in forum Gecko Drives
    Replies: 0
    Last Post: 10-22-2014, 10:01 AM
  5. SX3 Stopped Working
    By mikemill in forum Syil Products
    Replies: 13
    Last Post: 01-09-2009, 04:54 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •