530,149 active members*
2,548 visitors online*
Register for free
Results 1 to 4 of 4
  1. #1

    Join Date
    Aug 2020

    First time CNC project


    Not sure which forum to post this in, so if this is the wrong one, I will apologize in advance and hope you will move it to the correct forum.

    I am completely new to this CNC / Mach3 / Breakout board / Stepper motor world, so please take it easy on me

    My first project is going to be a CNC plasma cutter table, but my problem is way more basic.

    I can't seem to get the stepper motors to rotate.

    Here is my setup:

    I am trying with just one stepper motor for testing purpose.

    I am using a C10 breakout board, but I also have a C11G breakout board that gives me the same result.

    The problem is a simple as; Nothing happens on the breakout board when I drive the motor in Mach3.

    I have set up the ports and pins correctly in Mach3. I have set the PUL to pin 5 (red wire) and DIR to pin 4 (Yellow wire)

    I have used a UC100 USB controller with the same result and I can see in Mach3 that pin 4 is activated when I drive the X axis a certain way. However, the voltage on pin 4 is 0, never 5V

    From Mach3s POV everything is fine, the X axis is running fine, however nothing happens on the board.

    How can I troubleshoot this?

    Is it the 5V power supply to the board?

    I use a USB charger, found an old UBS wire and cut it open and found the 5V wires.

    I have tried with Win 10 Laptop (UC100), Win 7 laptop (UC100) and Win xp (Parallell port) stationary PC, all with the same result.

    Hopefully you can help me


  2. #2
    Join Date
    Dec 2003

    Re: First time CNC project

    My guess is that the problem is with the cables from the drives to the steppers and you may have one pair incorrectly connected.Do you have the means of checking which pairs of the motor connections are on the same circuit?I had a similar problem getting my steppers to work with LinuxCNC.

  3. #3
    Join Date
    Jul 2018

    Re: First time CNC project

    Hi Damoros - Check you are getting voltage out of the phone charger. Phone chargers have circuits that shut down the charger if the current is low ie the phone is charged or disconnected. Since the charger is expecting amps and the control circuit uses very small current this maybe the issue. Other wise check, check and more checking... Peter

  4. #4

    Join Date
    Aug 2020

    Re: First time CNC project


    Thank you both for your reply! I actually found the problem
    I needed to connect the enable terminal (ENA) to the 5V terminal..
    Did that and a green "active" LED lighted up on the board and the motors worked perfetly

    Again, thank you for you help! Really appreaciate it! <3


Similar Threads

  1. Available full time, part time,project base ,
    By jrefffffddgewgshs in forum Employment Opportunity
    Replies: 0
    Last Post: 03-21-2019, 06:29 AM
  2. Great first time CNC project
    By msimpson99 in forum DIY CNC Router Table Machines
    Replies: 1
    Last Post: 08-26-2015, 04:46 PM
  3. Big project 48+ hours run time.
    By Mr.Chips in forum Uncategorised WoodWorking Machines
    Replies: 7
    Last Post: 02-05-2014, 01:44 PM
  4. MS Project Extension - Time Resolution
    By harryn in forum General Business Practices / Pricing
    Replies: 1
    Last Post: 07-23-2010, 10:22 PM
  5. Summer project time
    By dmansr25sd in forum Mini Lathe
    Replies: 0
    Last Post: 04-24-2008, 09:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts