540,882 active members*
2,364 visitors online*
Register for free
Login
IndustryArena Forum > MetalWorking Machines > Milltronics > Partner 1 M19 parameter needed
Results 1 to 7 of 7
  1. #1
    Member
    Join Date
    Jun 2010
    Posts
    87

    Partner 1 M19 parameter needed

    I have a Partner 1 with the plunger style 6 pocket tool changer. I lost the cmos battery a while ago and sent the control to get repaired but unfortunately I didn't have a backup of the parameters. I have everything working now except for M19 spindle orient for the tool change macro. All the other codes seem to do what they are supposed to but M19 just rotates the spindle at the jog speed but never activates the cylinder that locks the spindle. Even if I do the codes separately they don't work together.
    Anyhow, I'm hoping someone here might have the parameter files for this style too changer they could send me?

    Thanks!

    Mike

  2. #2
    Member
    Join Date
    Jun 2010
    Posts
    87

    Re: Partner 1 M19 parameter needed

    Here's a picture of the mill to help identify it. There has to be another one of these out there with this tool changer that I could get the parameters from? I tried re-loading them just in case something didn't copy correctly, but no luck.

    Click image for larger version. 

Name:	20210407_173800.jpg 
Views:	0 
Size:	115.2 KB 
ID:	461654

  3. #3

    Join Date
    Mar 2019
    Posts
    28

    Re: Partner 1 M19 parameter needed

    I attached the TC macro from my machine, might help get you going. It needs to be copied to a directory in DOS if I remember correctly. I believe it is the same for 6 or 12 pocket TC. Have you tried M27 or M28? They move the plunger in and out. M19 should move the plunger out while rotating the spindle, and stop the spindle when it gets the signal that the plunger is out, while leaving the plunger out to lock the spindle for a tool change. Also, verify that the path for the TC macro is correct in the parameters and that the correct kind of tool changer is selected.

  4. #4

    Join Date
    Mar 2019
    Posts
    28

    Re: Partner 1 M19 parameter needed

    I thought I attached it, oops. Change the extension to ".tc" from ".txt" before you use it. I couldn't upload it without changing it.

  5. #5
    Member
    Join Date
    Jun 2010
    Posts
    87
    Thanks for that file! I'll look at it tomorrow. I have a feeling that it's the .hex file that the save parameter option should save to the floppy that is my problem. M19 just spins the spindle and doesn't activate the plunger. I can get the plunger to work with their M codes but if I activate it before M19 it just retracts before the spindle turns. I've gone thru the settings and I think they are right. Machine is other and the ATC is set to manual/Avanti. The path appears correct.
    Thanks again!
    Mike

    Quote Originally Posted by cbChris View Post
    I thought I attached it, oops. Change the extension to ".tc" from ".txt" before you use it. I couldn't upload it without changing it.

  6. #6
    Member
    Join Date
    Jun 2010
    Posts
    87

    Re: Partner 1 M19 parameter needed

    Well, your ATC file is a bit different than mine for sure. I'll give try loading it tonight & see if it makes a difference. I'm thinking not though because it still just calls M19 by itself which right now just causes the spindle to turn until I hit E-Stop. The plunger never activates to lock the spindle. Do you have a acro2.hex file you could copy here? It's just a bunch of numbers, but I think it is what tells the boards in back what to do when M codes are called. I'm pretty sure the part for M19 isn't right in mine.

    Thanks again.

  7. #7

    Join Date
    Mar 2019
    Posts
    28

    Re: Partner 1 M19 parameter needed

    Send me an email at chris a tripleaxismfg.com (replace a with @, remove spaces) and I'll send you all of my milltronics files this evening. Maybe one of them will have what you need to get going.

    Sent from my SM-N960U using Tapatalk

Similar Threads

  1. Parameter Help Needed
    By gunda in forum Fanuc
    Replies: 3
    Last Post: 10-08-2019, 01:41 PM
  2. Replies: 2
    Last Post: 07-05-2016, 07:36 PM
  3. fanuc 6mb parameter needed
    By beekeeper in forum Fanuc
    Replies: 16
    Last Post: 09-22-2011, 03:14 AM
  4. Partner Lathe "Parameter File Corrupted"
    By Joe Miranda in forum Milltronics
    Replies: 9
    Last Post: 09-03-2011, 03:25 AM
  5. Parameter needed for Mazatrol M-1
    By ahmed4040 in forum Mazak, Mitsubishi, Mazatrol
    Replies: 0
    Last Post: 04-06-2011, 09:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •