543,653 active members*
2,142 visitors online*
Register for free
Login
IndustryArena Forum > MetalWorking Machines > CNC Machining Centres > 5 Axis CNC- toolpath not working right
Results 1 to 1 of 1
  1. #1
    Member
    Join Date
    May 2021
    Posts
    2

    5 Axis CNC- toolpath not working right

    I have generated a 5-axis toolpath for a simple model using Powermill 2020. After I export the g-code and load it onto the machine, it does not work properly. The exact issue is that the machine is not milling according to the material block. It is going outside the block and the coordinates do not match the simulation in Powermill.
    When I export the code, Powermill shows me an error saying “ the machine tool in Powermill and the machine tool in option file differ “. Can this be the issue for the coordinates not exporting properly?
    Attached Thumbnails Attached Thumbnails 5 axis CNC_ Setup.jpg   Control software settings.jpg   export error_Powermill.jpg  

  2. #2
    Registered
    Join Date
    Dec 2003
    Posts
    926

    Re: 5 Axis CNC- toolpath not working right

    Almost certain to be the problem.I don't know Powermill,but if the default machine geometry that the program comes with doesn't match the machine you are using,it will be unlikely that the toopathyou generate will produce the shape that has been designed.There may well be a couple of places in the postprocessor parameters where you need to insert the values relating to your machine.Almost certainly related to either the tool length or the distance from the tool tip to the centre(s) of rotation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •