545,723 active members*
2,369 visitors online*
Register for free
Login
IndustryArena Forum > CNC Electronics > Spindles / VFD > newbie Wj200 inverter settings
Results 1 to 9 of 9
  1. #1
    Registered
    Join Date
    Jan 2013
    Posts
    27

    newbie Wj200 inverter settings

    Hey guys, been looking to hook up my cnc xpro v5 controller to my cnc machine i have just built and am having trouble setting up spindle control. Coming from a G540, ive never set up the automatic spindle control.
    Ive been looking for hours now on how to setup the different settings in the wj200. i have downloaded installed and connected via the usb port on the inverter to change settings etc.
    My goal is to use the 0-10v to control the spindle speed but it doesnt seem to do anything. i have sent M3 S12000 in terminal and the light comes on to indicate the spindle relay(which reads 5.12v)
    I have the negative from the controller going to (L) and the 10v going to (O).
    ive set my settings in the vfd base and max freq to 400, 220v, and 8 amp as indicated on the spindle motor.
    A001 01
    A002 01B
    B037 0
    A082 220
    A004 400
    H003 2.2

    When i run H001 2, and i sent M3 S12000 i get 180Hz output on the screen of the vfd, but the motor doesnt spin.
    When connected to USB i can control the spindle using the frequency and direction buttons on the control tab and the motor works as intended.
    i feel like i am missing some sort of setting in the vfd, any help would be appreciated thank you.

  2. #2
    Member
    Join Date
    Jan 2005
    Posts
    12546

    Re: newbie Wj200 inverter settings

    Quote Originally Posted by sharpen047 View Post
    Hey guys, been looking to hook up my cnc xpro v5 controller to my cnc machine i have just built and am having trouble setting up spindle control. Coming from a G540, ive never set up the automatic spindle control.
    Ive been looking for hours now on how to setup the different settings in the wj200. i have downloaded installed and connected via the usb port on the inverter to change settings etc.
    My goal is to use the 0-10v to control the spindle speed but it doesnt seem to do anything. i have sent M3 S12000 in terminal and the light comes on to indicate the spindle relay(which reads 5.12v)
    I have the negative from the controller going to (L) and the 10v going to (O).
    ive set my settings in the vfd base and max freq to 400, 220v, and 8 amp as indicated on the spindle motor.
    A001 01
    A002 01B
    B037 0
    A082 220
    A004 400
    H003 2.2

    When i run H001 2, and i sent M3 S12000 i get 180Hz output on the screen of the vfd, but the motor doesnt spin.
    When connected to USB i can control the spindle using the frequency and direction buttons on the control tab and the motor works as intended.
    i feel like i am missing some sort of setting in the vfd, any help would be appreciated thank you.
    The Relay output should not have any voltage

    What G540 output pin numbers are you connected to with the ( L ) and ( O ) same for the Relay how are you switching the Relay
    Mactec54

  3. #3
    Registered
    Join Date
    Jan 2013
    Posts
    27

    Re: newbie Wj200 inverter settings

    Quote Originally Posted by mactec54 View Post
    The Relay output should not have any voltage

    What G540 output pin numbers are you connected to with the ( L ) and ( O ) same for the Relay how are you switching the Relay
    Sorry for not being clear. im using a cnc xpro v5, not a g540. the ground and 0-10v output from the 'toolhead' plug on the xpro.

  4. #4
    Member
    Join Date
    Jan 2005
    Posts
    12546

    Re: newbie Wj200 inverter settings

    Quote Originally Posted by sharpen047 View Post
    Sorry for not being clear. im using a cnc xpro v5, not a g540. the ground and 0-10v output from the 'toolhead' plug on the xpro.
    It does not say if the 0-10v is for VFD Drive speed control

    Is this an analog 0-10v output ??? if not it will not work

    Your VFD Drive can use step/dir signal for speed control if you have a problem with the 0-10v
    Mactec54

  5. #5
    Registered
    Join Date
    Jan 2013
    Posts
    27

    Re: newbie Wj200 inverter settings

    Quote Originally Posted by mactec54 View Post
    It does not say if the 0-10v is for VFD Drive speed control

    Is this an analog 0-10v output ??? if not it will not work

    Your VFD Drive can use step/dir signal for speed control if you have a problem with the 0-10v
    This controller 0-10v is an analog output specifically for vfds.
    It also has 0-5v,pwm and rs485 outputs. Would just like to have spindle control so if those are easier to set up, im listening.
    I chose 0-10v because it seemed tp be the easiest. I figured I was close because the vfd sees the signal and converts it to a frequency on the display, the spindle just doesn't turn on.

  6. #6
    Member
    Join Date
    Jan 2005
    Posts
    12546

    Re: newbie Wj200 inverter settings

    Quote Originally Posted by sharpen047 View Post
    This controller 0-10v is an analog output specifically for vfds.
    It also has 0-5v,pwm and rs485 outputs. Would just like to have spindle control so if those are easier to set up, im listening.
    I chose 0-10v because it seemed tp be the easiest. I figured I was close because the vfd sees the signal and converts it to a frequency on the display, the spindle just doesn't turn on.
    So that sounds like the Relay then is not tuning it on or there is a Parameter or jumper not set correct for remote control

    With the choices you have the 0-10v is the easiest to setup / use it seems you have this part working
    Mactec54

  7. #7
    Registered
    Join Date
    Jan 2013
    Posts
    27

    Re: newbie Wj200 inverter settings

    Quote Originally Posted by mactec54 View Post
    So that sounds like the Relay then is not tuning it on or there is a Parameter or jumper not set correct for remote control

    With the choices you have the 0-10v is the easiest to setup / use it seems you have this part working
    Which relay are you referring to? Vfd or controller? What can i do about it?

  8. #8
    Member
    Join Date
    Jan 2005
    Posts
    12546

    Re: newbie Wj200 inverter settings

    Quote Originally Posted by sharpen047 View Post
    Which relay are you referring to? Vfd or controller? What can i do about it?
    You said in your first post ( terminal and the light comes on to indicate the spindle relay(which reads 5.12v)

    So I'm just guessing that you have a Relay that you are using to turn the Spindle On / Off

    Need more information on this as I said before there should not be any voltage on the output of this Relay if you are using this, when you posted you said it had 5.12v
    Mactec54

  9. #9
    Registered
    Join Date
    Jan 2013
    Posts
    27

    Re: newbie Wj200 inverter settings

    Quote Originally Posted by mactec54 View Post
    You said in your first post ( terminal and the light comes on to indicate the spindle relay(which reads 5.12v)

    So I'm just guessing that you have a Relay that you are using to turn the Spindle On / Off

    Need more information on this as I said before there should not be any voltage on the output of this Relay if you are using this, when you posted you said it had 5.12v
    Oh understood. The cnc xpro v5 has a relay for the circuit for the "toolhead" it controls laser or vfd etc based on internal jumpers, also turning on an indicator LED on the outside of the unit.
    So the 50% RPM signal is between 0-10v which in this case is 5.12v at the toolhead output.
    I also have a bit of an update, if i use the control terminal input on the VFD and set the start and stop signal to front panel on the VFD, everything else works as intended. M3 Sxxxx codes work as intended but wont power the spindle on or off.
    Hope i clarified enough, explaining something in front of me over the internet isnt my strong suit... Thanks again for the help

Similar Threads

  1. WJ200-022sf and 2.2kw Spindle settings
    By Jmhx2 in forum Spindles / VFD
    Replies: 20
    Last Post: 04-15-2020, 01:13 AM
  2. newbie needs help wj200 2.2kw settings please
    By steve78 in forum Spindles / VFD
    Replies: 0
    Last Post: 12-03-2016, 02:07 PM
  3. Need help with Mach3 modbus settings with Hitachi WJ200
    By macplus in forum Mach Software (ArtSoft software)
    Replies: 1
    Last Post: 10-26-2016, 07:40 AM
  4. * NEW * Hitachi WJ200-075LF Variable Frequency Drive Inverter 10 HP 240v 3-Phase
    By Feeler_Gauge in forum Newly Posted Classifieds Listings
    Replies: 0
    Last Post: 03-05-2016, 01:35 AM
  5. Hitachi WJ200 Settings Help
    By BanduraMaker in forum Spindles / VFD
    Replies: 28
    Last Post: 10-09-2014, 05:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •