543,717 active members*
2,295 visitors online*
Register for free
Login
Page 1 of 3 123
Results 1 to 20 of 55
  1. #1
    Registered
    Join Date
    Jan 2008
    Posts
    3

    Fanuc 0iMC PCMCIA CF Memorycard

    Hello, I'm Ander from Bilbao (Spain). I have a new machine with 0iMC control. I have purchased a 8GB Sandisk Compact Flash Card Ultra II and a pcmcia adapter.
    Well... it does not work
    What is the limit of memory that we can install?
    Is it possible to format the memory card inside the control?
    I have read in the forum that is necesary to change a parameter. What is the parameter in the 0i control?
    Any advice?
    Thanks

  2. #2
    Gold Member
    Join Date
    Mar 2003
    Posts
    2931
    Set your I/O Channel to 4 for the Memory Card (see attached JPG). It's possible to format the card on the control, but you shouldn't need to.

    Be careful inserting the PCMCIA adapter into the control. Those connectors are notoriously weak, and subject to failure.
    Attached Thumbnails Attached Thumbnails Setting (HANDY) Page 1.jpg  

  3. #3
    Registered
    Join Date
    Jan 2008
    Posts
    30
    I have purchased a 8GB Sandisk Compact Flash Card Ultra II and a pcmcia adapter.
    I have the same setup on my FANUC 18-i. On my control I did have to format the card while it was connected to the machine. I am not familiar with the O1MC but assume that the I/O stuff is the same. Does your control have a CRT with soft keys to change the display? If it does, you might want to try this:

    -Push in the (2) far right soft keys while powering up the machine. If your control is anything like mine, you should get a screen whth several options for the machine. One of the options should be to format the memory card. On my controll it is option #7. Cursor down to the correct option, hit select and follow the prompts.

    Hope this helps.
    It is the poor craftsman that blames the tool

  4. #4
    Registered
    Join Date
    Nov 2006
    Posts
    174
    As per op's manual, maximum 2Gb cards are accepted. Well, 1G sure works, tested.
    to format the cards, use [SYSTEM] <PMC> <right arrow> <I/O> <M-CARD> <FORMAT>
    Also, carefully delete files on a XP computer - if XP make "recycle bin" or other hidden files, CNC will not accept this cards

  5. #5
    Registered
    Join Date
    Jan 2008
    Posts
    30

    Couldn't Get it to Work

    Hi f-bu,
    I tried that on my 18-i control. While the options were there just like you said, after the format I kept getting a "memory card error" message when I tried to use the card. I had to go back and use the method that I described before. Maybe it is just the diffrence in the control.
    It is the poor craftsman that blames the tool

  6. #6
    Registered
    Join Date
    Nov 2006
    Posts
    174
    Maybe, CAD/CAM Man, I used this on 0i, 18i, 21i, 31i with success, but who knows...

  7. #7
    Registered
    Join Date
    Sep 2007
    Posts
    36
    simliar problem here w/ pcmcia card...getting" memory card error 1010", I agree dcoupar, these adaptors are sensitive. I have my i/o to channel 4, and can not find an explanation for error 1010 in manual.

  8. #8
    Registered
    Join Date
    Feb 2008
    Posts
    29
    If you format the card in Windows you should select in options not FAT16 but FAT. Or maybe use the way CAD/CAM Man suggested

  9. #9
    Registered
    Join Date
    Jun 2006
    Posts
    89
    We had an issue like this on our Fanuc OiMC control, it would read a card sometimes and then at other times, alarm out. I will look tomorrow and see if I wrote the error number down in my notes. It ended up being a bad card reader in the machine. We installed a new reader and it has worked great so far. If I find the alarm code, I will post it tomorrow. I do know that the OiMC will read at least up to a 4Gig card, that's what I use all the time.
    Dave

  10. #10
    Registered
    Join Date
    Oct 2008
    Posts
    3
    I've read through this thread and I am still having problems.

    I'm running an OiMC controller, using a 1G Sandisk SD card in PCI adapter. IO Channel is set to 4, SD card is formatted in FAT on Windows XP computer, card is blank. I've tried formatting the card on the machine both ways listed in this thread.

    Using the technique given by CAD/CAM man (holding the two soft keys at start up) I select the "Format Memory Card" and away it goes. The machine then sits there blinking "Formatting Memory Card" at the bottom of the screen. It's been doing this for the last hour.

    When I try steps set out by user f-bu to format from the card, as soon as I confirm that I want to format the card, the controller crashes and I get an error screen with a bunch of numbers.

  11. #11
    The card should be formatted in FAT file system NOT FAT32 or NTFS!
    FAT is limited to approx. 2 Gb.

    no strange files should be on the card like pictures or cam files etc.

    be aware that the IO Channel needs to be on 4.

    but why 8gb on the control? there are some 0i Versions that are limited to 512Mb! check fanuc site for your max limit

  12. #12
    Registered
    Join Date
    Oct 2008
    Posts
    3
    Just thought I'd share with others in case they are having the same problems;

    After talking with a tech at FANUC, we were told that the machines do not support SD cards, only ATA Flash and Compact Flash memory. This is likely the problem.

  13. #13
    Gold Member
    Join Date
    Mar 2003
    Posts
    2931
    Anderin (the original poster) is using a CF memory card, not SD, so that's not the problem in his case. I've never used an "Ultra II" card... I wonder if these newer cards could be a problem?

  14. #14
    Registered
    Join Date
    Feb 2008
    Posts
    29
    Well I've got Sandisk Ultra II 1Gb card and everything goes OK. These cards are even acceptable by Siemens 810 which is very "sensitive" to card speed - if card is too fast it isn't recognized. Fanuc 0iMC accepts faster cards and everything is OK with them.

  15. #15
    Gold Member
    Join Date
    Mar 2003
    Posts
    2931
    Thanks, that's good to know.

  16. #16
    Registered
    Join Date
    Oct 2008
    Posts
    3
    I guess I'll try one of the Ultra II cards today then.

  17. #17
    *Registered User*
    Join Date
    Dec 2008
    Posts
    5
    bigbobr, did you, by any chance, repartition your card? Check if it has only one partition, and if it's set active. If the partition is not active, the control wont read such card and will display 1010 error.

  18. #18
    Registered
    Join Date
    Jan 2008
    Posts
    3
    Hi, on my 0iMC control a 8GB (2+2+2+2) partitioned memory card doesn't work.
    It works fine with a 2GB Kingston and 2GB SanDisk Ultra II CF "FAT" formatted.

  19. #19
    *Registered User*
    Join Date
    Dec 2008
    Posts
    5
    anderin, what I meant was that the card needs to have a single FAT16 partition, necessarily set as "active".
    To be honest, I don't know if 0i reads cards with more than one partition, but it definitely requires an active partition. I assume that you have split the card into four partitions yourself - in such case you probably removed the original one (which was active) and then created 4 new, but none of them is active now. You can check that under Disk Management in Windows, for instance

  20. #20
    Registered
    Join Date
    Sep 2003
    Posts
    14
    has anyone had the 1010 and 00330 error? I have been running the cf card successfully for a while now and suddenly it gives me these errors.fanuc Oi-mc . Wondering if it could be the reader, we tried a new card with same results.

Page 1 of 3 123

Similar Threads

  1. Serious problem in new Fanuc 0iMC.
    By motordude in forum Fanuc
    Replies: 15
    Last Post: 03-07-2011, 12:14 PM
  2. simulation in Fanuc 0imc
    By ahmed4040 in forum Fanuc
    Replies: 6
    Last Post: 05-30-2010, 09:37 AM
  3. Fanuc 0iMC param. problem.
    By GPena in forum Fanuc
    Replies: 2
    Last Post: 08-12-2009, 04:05 PM
  4. 0iMC PCMCIA Memory Card
    By anderin in forum Fanuc
    Replies: 2
    Last Post: 11-03-2008, 01:26 PM
  5. tool change prblem with fanuc 0imc
    By ahmed4040 in forum Fanuc
    Replies: 7
    Last Post: 01-06-2008, 10:17 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •