508,184 active members
2,165 visitors online
Register for free
Login
Results 1 to 3 of 3
  1. #1
    Registered
    Join Date
    Aug 2008
    Posts
    12

    Z Servo Drive Fault

    Hi !! Noob here with a problem... hoping someone can help!

    We have a Bridgeport Eztrak fitted with the Millpwr control. Machine has fairly new and not had much use. [We took delivery about 3 weeks before Bridgeport UK went bust, so no warranty ].

    When we switched on earlier, [first time for 4-6 weeks I would think], when trying to 'Find Home' nothing moves and we get error message 'Z Servo Drive Fault'.

    Now we have guessed that this means there is something wrong with the Z servo drive... , but has anybody any ideas exactly what this might be or have you had this problem before?

    Look forward to any help offered!!

    Graham. [Jaff]

  2. #2
    Moderator machintek's Avatar
    Join Date
    Nov 2004
    Posts
    3028
    I know nothing about what is in your machine, but probably you have 3 axis drives. Swap the Z with the Y or x and see if the problem follows the drive. Since the Z is the first to home, I would also make sure that the power is OK (fuses, breaker, etc).

    George
    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)

  3. #3
    Registered
    Join Date
    Aug 2008
    Posts
    12
    Thanks George,

    ... that's basically what we did yesterday. We established that power was not getting to any of the drives and after fiddling with the power supply plug and socket, [common to all drives], it all fired up ok. Wire connections all checked out fine so can only assume that the plug was not square to the socket or something.

    Grah.

Similar Threads

  1. SL-20 A-axis drive fault
    By metaltec in forum Haas Lathes
    Replies: 2
    Last Post: 12-28-2007, 03:05 AM
  2. Fanuc Spindle drive fault
    By gromit68 in forum Fanuc
    Replies: 3
    Last Post: 08-25-2007, 01:51 AM
  3. Z Axis Drive Fault
    By jeremy_d in forum Servo Motors / Drives
    Replies: 2
    Last Post: 08-16-2006, 04:04 AM
  4. Spindle Drive Fault
    By n5jjr in forum Machine Problems, Solutions , Wireless DNC, serial port
    Replies: 15
    Last Post: 03-31-2005, 03:26 PM
  5. Axis Drive Fault
    By Bluey in forum Machine Problems, Solutions , Wireless DNC, serial port
    Replies: 3
    Last Post: 11-04-2004, 01:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •